Configuring DSA Multiple VLANs on Netgear 6700v2 (MT6721 chipset)

I have 2 Netgear 6700v2's running as dumb ap's, gigabit-wired at the center to my TP-Link Archer A7v5 all running Openwrt 21.02.1. I want to get rid of the A7v5 and and use one of the Netgear 6700v2's as my primary router. I cant configure VLANS (vlan filtering) without soft-bricking. Seems the MT6721 chipset on this router use DSA configuration and dont support the older style switch configurations. As dumb AP's, they work with multiple vlans, no problem and no vlan filtering setup is required. I've read the guides and cant seem to configure the switch properly. Can someone point me in the right direction to get VLAN set up using DSA that mimimcs the image of the switch configuration below from my Archer A7v5:

/etc/config/network on Archer A7v5

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option device 'br-lan'

config interface 'guest'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
        option device 'br-guest'

config device
        option name 'br-guest'
        option type 'bridge'
        list ports 'eth0.3'

config interface 'iot'
        option proto 'static'
        option ipaddr '192.168.4.1'
        option netmask '255.255.255.0'
        option device 'br-iot'

config device
        option name 'br-iot'
        option type 'bridge'
        list ports 'eth0.4'

config interface 'wan'
        option proto 'dhcp'
        option peerdns '0'
        option delegate '0'
        option device 'eth0.2'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'

config interface 'wan6'
        option delegate '0'
        option proto 'none'
        option auto '0'
        option device 'eth0.2'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '0t 2t'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option ports '0t 2t 5'
        option vid '4'

Believe me when I tell you I read the entire tutorial and others and still does not seem to work. The router hangs/soft bricks and I end up having to reflash using nmrpflash. What I have tried was to add ports 1-4 to br-lan and then tag vlans 3 and 4 on port 1 (see pictures below). Anytime I try it, router hangs. Even if I enable VLAN Filtering and just add VLAN ID 1 with all four ports as untagged, or even set port 1 to untagged and as primary id (u*), it results in instant softbrick.

you aware that there is no link in lan1 & lan3, right? can you make sure your cables are ok first, try to replace.

I took it off the wired lan network when I took this pic so regardless of whether there is a link on it or not doesnt matter. I am accessing it via Wifi and this picture is taken. I've tried switching cables also no issue (keep in mind that it works fine with the Archer A7) from the original post which has the switch menu option. The problem as I mentioned is it leads to a soft-brick (I have to reset to default).

ok, just making sure trivials are not overlooked. if your hw model is supported then unfortunately i have no clue why using a feature would lead to soft-brick, sorry.

No worries and it probably is something I might be overlooking. I recently bought a used WRT1900ACS v2 on ebay and use that as main router instead of the R6700v2. On the WRT1900, I am able to get the VLAN's to work as expected with OpenWRT 19, because it supports the older swconfig (switch) configurations. But with OpenWRT 21 with the DSA, I am having the same issues as I do with the Netgear. This led to conclude that its something Im probably overlooking rather than OpenWrt itself.

On that note, the TP-Link Archer v7 for some reason retains the Switch configuration menu option in Luci with OpenWRT 21 whereas neither the Linksys nor the Netgear has them with OpenWRT 21. When I upgraded to OpenWRT 21 from 19, I did fresh installs but still cannot get it to work.

When you start setting up bridge VLANs, make sure to change the LAN interface device from br-lan to br-lan.1. Also I suggest to do bridge VLAN modifications via wireless, saves some headaches and false leads due to intermittent ethernet outages.

After many days of attempts and lockups, finally solved the issue. It turns out that Bridge VLAN Filtering was not even the right solution. I had to manually create 2 VLAN Devices for the lan 1 switch port since thats where traffic from br-guest (VLAN 3) and br-iot (VLAN 4) would travel from the dumb-AP. I usually prefer working via with command line uci and text but for this case the luci GUI was actually more helpful visualizing it. So:

  1. Create VLAN(802.1q) for switch port lan1 with vlan id 3 which creates lan1.3
  2. Create VLAN(802.1q) for switch port lan1 with vlan id 4 which creates lan1.4
  3. Assign Bridge Device br-guest to only bridge ports lan1.3
  4. Assign Bridge Device br-iot to bridge ports lan1.4 and lan4 (I dedicated one physical port on the main AP to br-iot)

After doing this and applying the settings, I instantly was able to communicate with all guest and iot devices connected between my new main-AP and the dumb-AP.

Edit: I'm include the relevant config:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config device
        option vid '3'
        option type '8021q'
        option name 'lan1.3'
        option ifname 'lan1'

config device
        option name 'br-guest'
        option type 'bridge'
        list ports 'lan1.3'

config interface 'guest'
        option device 'br-guest'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'

config device
        option vid '4'
        option type '8021q'
        option name 'lan1.4'
        option ifname 'lan1'

config device
        option name 'br-iot'
        option type 'bridge'
        option igmp_snooping '1'
        list ports 'lan1.4'
        list ports 'lan4'

config interface 'iot'
        option device 'br-iot'
        option proto 'static'
        option ipaddr '192.168.4.1'
        option netmask '255.255.255.0'
3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.