Configuring dhcpv6 from ISP

I'm trying to get an external ipv6 address from my isp.

OpenWRT router is connected directly to the modem.
My ISP does support ipv6
they provide a /56 prefix,
but they do not support IA_NA requests. I am not sure how to prevent IA_NA requests.

I'm not sure how to use this information to get an ipv6 address on the wan6 interface. My initial attempts have failed.

Suggestions?

Is your router directly connected to the internet or is the OpenWrt router behind the ISP one?

It is connected to the modem directly. No router from ISP.

Could you share your network configuration file please located at /etc/config/network?

here's my /etc/config/network file:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd13:8bcb:23b2::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.5.5.1'
        option netmask '255.255.255.0'
        option ip6assign '64'

config device
        option name 'wan'
        option macaddr '62:38:e0:d7:3a:03'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        list dns '8.8.8.8'
        list dns '8.4.4.8'
        list dns '208.67.220.220'
        list dns '208.67.222.222'
        option hostname '*'
        option delegate '0'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqprefix '56'
        option ip6assign '64'
        option reqaddress 'try'

uci set network.wan6.reqaddress='none' ; uci commit network; ifup wan6
Also you don't need to assign any IPv6 on wan6 from the delegated.
uci delete network.wan6.ip6assign ; uci commit network; ifup wan6

Ok, I did this, and I'm still not having any luck...

I figured out how to use tcpdump to watch the traffic, so when I run:

tcpdump -i wan port 546 or 547 -v -e -n

and restart the wan6 interface, i get:

tcpdump: listening on wan, link-type EN10MB (Ethernet), capture size 262144 bytes
13:35:15.170803 62:38:e0:d7:3a:03 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 174: (flowlabel 0xfe526, hlim 1, next-header UDP (17) payload length: 120) fe80::6038:e0ff:fed7:3a03.546 > ff02::1:2.547: [bad udp cksum 0x7823 -> 0xd078!] dhcp6 solicit (xid=d829d8 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 6238e0d73a03) (reconfigure-accept) (Client-FQDN) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix ::/56 pltime:0 vltime:0)))
13:35:16.329525 62:38:e0:d7:3a:03 > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 174: (flowlabel 0xfe526, hlim 1, next-header UDP (17) payload length: 120) fe80::6038:e0ff:fed7:3a03.546 > ff02::1:2.547: [bad udp cksum 0x7823 -> 0xd005!] dhcp6 solicit (xid=d829d8 (elapsed-time 115) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 6238e0d73a03) (reconfigure-accept) (Client-FQDN) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix ::/56 pltime:0 vltime:0)))

This just repeats indefinitely... From what I can tell, the DHCP request is being made, but there is no response. Correct?

I looked at the firewall rules to make sure it allows incoming DHCPv6, and it seems fine.

Allow-DHCPv6 rule : Allow incoming ipv6 protocol UDP on wan port 546 to this device = enabled

Quite right.