Configure TL-MR3020 for Software-VLAN/CableModemRouter

Hello,

i have following problem with this litlle nice router. I can use this router as an AP for other WLANs (Repeater-Mod) with no problems. But when i connect my 3020 on a CableModemRouter (DOCSIS) i have WAN_access but the network from the router will be completly unreachable. I can access the CableModemRouter Interface and can connect with the AP and use internet.

I know VLAN is the best option for my problem. Now my questions.

  1. How can is use/config VLAN that i can use the subnet from the cablemodemrouter and from the mr3020?

  2. Is it possible to create 2 Interfaces on eth0 and eth0.1 that the router use eth0.1 when i connect to cmrouter and when i connect to my AP-Repeater-Conf then eth0 act as an normal Interface for an normal client (lan to wan). Which combination of interface to networks must i use in luci or as an config-file?

Must i use static routes or an firewall tunnel roule for this?

Or can i only use this little 3020 with one lan and one configuration and must code some shell-skripts for the switch-triggers?

thx

I want excat reply the wired networking modus im ap-switch like here:
http://www.tp-link.com/us/faq-685.html

I might get your description wrong, but it looks like you are really overcomplicating things. If I get you right, you want to use the MR3020 as an access point, wirelessly extending your existing wired network.

For that, the only changes to the default configuration you need to make is to set the LAN interface to an unused static address within your existing network (or, even simpler, set it to DHCP, but then you need to check your main router which address it assigned to it) and disable dnsmasq (so it doesn't compete with the existing DHCP on your main router). And then it should all work out.

Thx for the answer. I will try it.

At the moment i have an WLAN-AP and 1 WWAN-WLANs as an WLAN-Repeater.

  1. When i put an simple client on the cable the router should be give the one LAN-Client and all other WLAN-Clients internetaccess. This functioned all. I have a stable 3020-WLAN-AP with repeat another WLAN-Network for inetaccess.

  2. But when i plug the lan-cable in my cablemodemrouter i have internet, all wlan-clients have internet but i dont can reach the 3020-Router on the assigned ip from the cablerouter.

I have forget to say this is an CableModemRoter with 4 Lan-Ports and no CableModem.

How i say i will try it. But i knows anybody the /etc/config/network from the original Firmware from TP-Link? I mean the original FW switches between 3 configs when iam use the hardware-switch and for all this i want the excact Configs from TP-Link.

ps: oh and the wnr2200 from netgear has an vlan-switch and with this switch i have 2 subnets, the subnet from my cablemodemrouter and the subnet from the 2200.

You certainly don't need VLANs for what you are trying to achieve, and unless base operation is working fine you'd just add complications to your setup that complicate troubleshooting.

From your description It's hard to tell what you did up to this point, what went wrong and why it went wrong. You might have gotten a detail wrong, or fuddled your way through wrong attempts to get it almost working.

I would really suggest you start over from the beginning ... Use "firstboot" on the MR3020 to completely reset it, then configure your Wifi on the MR3020, test, disable the dnsmasq service and set the MR3020's LAN interface to DHCP, then test again.

The original firmware is not based on OpenWrt, there are no "configs from TP-Link" you could re-use. In OpenWrt the switch does nothing. There are ways to use the switch, but it's a little more involved. Concentrate on getting one configuration to work, then let's go further from there.

I have made it and i have internet for all clients from the WLAN-AP but i don't can reach the 3020-Router on this configuration. I can access the CableModemRouter-IP and all 3020-Clients are showed in the Web-Interface from the cable router.

But only one client has no hostname this must be the 3020-router but i can't reach him,

WLAN-Routers with 4 Switches are very closed here in germany and bugged firmware. When i will config my 3020 i must plug off him from the cmrouter and restart.

Post your /etc/config/network please.

`
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd13:8679:d858::/48'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option _orig_ifname 'eth0'
    option _orig_bridge 'true'
    option ifname 'eth0'

config interface 'wwan_ap'
    option proto 'dhcp'

config interface 'wwan'
    option proto 'dhcp'
    option enabled '1'

config interface 'lan_dhcp'
    option type 'bridge'
    option proto 'dhcpv6'
    option ifname 'eth0'
    option reqaddress 'try'
    option reqprefix 'auto'
`

This is the config after hours of test. I use interface to disable some of them with switches. Or in the future i will use uci export functions in my switch-scripts.

Why the "wwan" and the "lan_dhcp" interfaces? What recommendation did you follow there? (Certainly not mine.) "wwan" is usually used in repeater howtos, but what you want is a simple access point.

Honestly, I'm kind of amazed that it works at all with this configuration. And assuming that somehow, your main router does the DHCP, I'm guessing it is 192.168.1.1. Which of course would imply that your MR3020 is using the same IP, or is in a different subnet altogether, which explains why your main router wouldn't talk to it because ... uhm, again, I'm amazed that it works at all.

Again, you did a lot more than would be necessary. I can only repeat the above: From the default stock configuration with only a 'lan' interface

  • name, secure and turn on the Wifi network
  • set the 'lan' interface to proto 'dhcp'
  • disable dnsmasq using /etc/init.d/dnsmasq disable

reboot, and that should be it. No need for all this "wwan" and "lan_dhcp" business.

Hello,
thx so i will try it. Can i read from your answer that i don't can setup two subnets like the vlan-switches on other routers and then bridge over the two subnets with this small tp-link router?

As an explaining about my network config:

the interface wwan_ap is the Main-WLAN_AP
the interface wwan is the WLAN-Client-Bridge to an community wlan
the interface lan_dhcp is excactly that what i have tried what you with the lan interface, i disconnect interface lan and connect interface lan_dhcp :slight_smile:

But i try your answer and when i goes i must work with uci export rules for the hardware-switches for the both ap-modes AP->CommunityWlan and AP->CableModemRouter.

A little thing: when i set the lan to dhcp then i don't can connect to the router when i boot up the router with no lan-cable plugged in.

Try to get one use case working instead of doing everything at the same time.

Naturally, the lan interface will not have an IP address without DHCP.

Hi,

short update its functioned without dhcp on lan-interface. I need only firstboot then setup wlan and then i must reconnect my wlan-clients when i put the lan-cable on the router (then the complety clients are members of the subnet from the router) and when i plug off the lan-cable i reconnect the wlan-client and i have my original lede-subnet with access to the router.

thx

But a little one question i have: how can i setup the 3020 that he connect and leave the original subnet accessable? At the moment its functioned like the original firmware.

At the moment i have an fully automated BridgeAPMode.

https://wiki.openwrt.org/doc/recipes/routedap
is that what i need?

Honestly, I'm getting a little tiny bit tired of recommending something and you doing something different and then complaining that it doesn't quite work. This is my last attempt at helping you, and I'm actually just repeating myself one more time, after that somebody else is free to help you further.

No. What you want is
https://wiki.openwrt.org/doc/recipes/bridgedap
and that's what I have been describing to you about half a dozen times now.

helpful would be a picture of your network. I haven't really understand what you will achieve with the mr3020? Can you explain what is your goal in one sentence.

Hi,
thx. One sentence, oki i try :slight_smile::

I will use the mr3020 as an WLAN-AccessPoint for an WLAN-Community-Net and when iam at home i will connect the mr3020 at my CableModemRouter-4PortLan.

Following functioned perfectly: WLAN-AP-Internetprovider (WISP-Mode) for 1xLANClients and xWLAN-Clients, the switch WISP trigger this Mode. When i switch on AP-Mode then i load the configuration what are the Problem-Configuration. The AP-Mode use the LAN-Port not as an Client-Port he use this as an Connection to other LANs like my CableModemRouter-4Port and other Switches and Routers.

You have me much helped with your Answers. All functioned. The BridgeAP-doc link is very helpful,too.

My cablemodemrouter-access are very restricted, clients can only be showed with an webinterface. Can it be that this is an docsis-router that this is the problem? When i connect for testing the mr3020 on an lan-port from my wnr2200 the i have access to the mr3020, the wnr2200 and the cableroutermodem-webinterface.

But at the moment thx for your help. I have configured the wps-button to reset my configuration and i can test a little bit easier :slight_smile:.