Configure single IP for wifi client

This is not something anyone can answer, I get that and I was merely looking for thoughts and ideas on what could have happened since I don't know how it did happen :).

My question was why did hdhcp run on its own the first time I fired up the wifi interface then never again.
I had not installed any DHCP server at the time I posted this but now I have and it's working but still curious what happened.

Well, without knowing specifically what changes you made and when, nobody else can answer. What we can tell you is, based on your configuration files, the behavior you are seeing is expected.

A DHCP server is installed by default (as part of the dnsmasq that is part of the standard image). It is configured by default to run on the lan network interface.

Why did it stop? Well, you changed stuff... it's hard to know exactly what sequence of things led to your current state (only you would know that), but the configuration is not valid for a running DHCP server.

You had not installed any DHCP server, but it was already there -- by default. You can install dnsmasq-full if you want, but that is not necessary for most users.

I am not using the default image, I build my own and don't have a DHCP server or dnsmasq installed.

$ opkg list-installed | grep dhcp
odhcpd-ipv6only - 1.15-3

I don't use IP6 but maybe that's what kicked in? I really don't know since I saw udhcp fire up.

Well, without knowing specifically what changes you made and when, nobody else can answer.

That's what my last comment said. I can see this is going to be the never ending question that already ended :). As we've all said, there is no answer as I cannot provide the history at this point.

Did you state that earlier?

Yes, but you asked what might have changed, and I was just reiterating that you are the only one who knows that.

No, I didn't state that earlier, you just made that assumption :).

No, I don't know the answer, that's why I posted asking for ideas, not solutions, just ideas as to what might have happened.

It's fine, re-read what I've said. There is no answer because the history is gone.

Why is this question not ending? It's over. I appreciate your help. Thank you.

This is what we would consider to be material information that would normally be incumbent on you (the person with the problem you wish to resolve) to disclose. Sure, maybe I should have asked... but you could have (and absolutely should have) offered this information at the outset.

Right and instead continuing to give me grief for no obvious reason, you could let it go now.

I said specifically that I was simply looking for thoughts, ideas, input from professionals that are using openwrt. Have you never called up a tech friend and said 'this just happened, I have no freaking idea why'? Of course you have, it's how we all learn.

Please, enough trying to find a way to bash me for my question. Are you trying to drive me away from openwrt by making me feel it's not worth trying to learn?

Give it a break please.

Sorry if it came across as blaming you or giving you grief.

On this forum, it is generally assumed that people are using a standard OpenWrt build (stable or snapshot) unless it is otherwise stated (or discovered during some of the troubleshooting). Because customized personal or forked versions can have significant impacts on how OpenWrt operates, it is information that should be available as part of the discussion, but this never came up. My bad for assuming here, but also a lesson for next time you have a question to post here -- please be sure to include this relevant info.

I'm usually the person my friends/family call when something goes wrong, and I try to get some background information, plus information about what they have done or know to have changed recently. In your case, it was possible to see (from the config files) that the DHCP server just wasn't going to run... but it wasn't clear how exactly you got into that state. It was hard to figure this out, so there were lots of questions and also assertions about why it wasn't working. The best way to lay this out in the future is to give some sort of brief summary of what was working and then what specific changes you made that caused it to fail... that can help us recreate this sequence and recommend better solutions.

Anyway, all of that said, I'm going to bow out now (not out of anger or anything... just that this thread does appear to be done). I do hope that your problem is solved or at least understood, or that you have a path to realizing the goals you've got for the device.


In case the thumbs up wasn't noticed, thank you. Yes, all solved.

Great! Glad to see that your issue is resolved.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Sure, no problem.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.