ok, if you have trouble with connecting specific vlan to specific port, we will try to figure out something
Ok sounds good. Thanks.
ok, if you have trouble with connecting specific vlan to specific port, we will try to figure out something
Ok sounds good. Thanks.
Hi @NPeca75,
So here is what I did for the config of /etc/config/network. Let me know if this will work, as I haven't implanted it yet.
Remember that I would like to have CLI port LAN4 with VLAN1 untagged (management/wired VLAN), along with VLAN20 (wireless devices) and VLAN21 (guest wifi) tagged.
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '4 6t 0t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '6t 0t'
config switch_vlan
option device 'switch0'
option vlan '20'
option ports '4 6t 0t'
config switch_vlan
option device 'switch0'
option vlan '21'
option ports '4 6t 0t'
config device
option type 'bridge'
option name 'br-vlan1'
list ports 'eth0.1'
config device
option type 'bridge'
option name 'br-vlan2'
list ports 'eth0.2'
config device
option type 'bridge'
option name 'br-vlan20'
list ports 'eth0.20'
config device
option type 'bridge'
option name 'br-vlan21'
list ports 'eth0.21'
config interface 'vlan1'
option device 'br-vlan1'
option proto 'static'
option ipaddr '192.168.10.200'
option netmask '255.255.255.0'
option gateway '192.168.10.1'
list dns '192.168.10.1'
option ip6assign '60'
config interface 'vlan2'
option proto 'none'
option device 'br-vlan2'
config interface 'vlan20'
option proto 'none'
option device 'br-vlan20'
config interface 'vlan21'
option proto 'none'
option device 'br-vlan21'
look at your original config
6t and 0t is NOT used as same time
that is why i wrote: 1,2,3,4 seems to be bond to 6t
so, it will be
option vlan '1'
option ports '4 6t'
option vlan '2'
option ports '6t'
option vlan '20'
option ports '4t 6t'
option vlan '21'
option ports '4t 6t'
4 - access (untagged)
4t - tagged
since i have no at hand two cpu port device with swconfig, i suggest you that for now leave out port5 + 0t and concentrate only on port4 / 6t for now
So I tried your implementation but lost access to the device still. I think I need to concentrate on just retaining access to the device after making changes. Any other idea?
ok, it is my mistake, sort of
option vlan '1'
option ports '4 6t'
here i pointed out that simple 4 is untegged in vlan1
so it should be '1 2 3 4 6t'
this way, all lan port will remain untagged on vlan1
Ok I got it working, but here's how....
config device
option type 'bridge'
option name 'br-vlan1'
list ports 'eth0.1'
Needed to be changed to
config device
option type 'bridge'
option name 'br-vlan1'
list ports 'eth1.1'
So the bridge was using the incorrect eth interface. Once I changed it from eth0 to eth1, I was able to re-connect after rebooting. I already implemented the rest of the config and it is working as I need.
Thanks much for @NPeca75 for your help. I am stoked to be able to have this function working on my R7800
hi @simon_lefisch
glad you sorted out
please consider to mark topic as [solved] and answer as "solution"