Configure PuTTY to serial conection USB-Serial to flash a router


I have a problem when try to connect mi laptop to a router serial port.

I supose must to use three wires: RX, TX and GND from my bridge USB-COMx Prolofic

I configure PuTTY 57600, 8, n, 1, none to use COM8, but when connect the power on, only see this:
PuTTY screen unreadable

Anyone can help me about configure PuTTY to understand this screen?


The usual speed is 115200.


I tried 115200 bps, but the result is tha same, wrong characters.

The bootloader from OpenWrt configure the connection, and tftp client, doesnt?


Make sure the ground on your adapter is connected to the router board's ground plane. Do not connect the 3.3 volt or 5 volt power wire. Try all the bauds from 9600 on up. The baud rate has to be known beforehand, it does not autoconfigure. The bit pattern is almost always 8 N 1 but again that does not autoconfigure.

What model of router is this?

The router is Samknows Whitebox V8.

This is the PCB layout for serial port:

Como conectar al puerto serie J2 de la PCB SK-WB8

I solded 2,3 and 4th pines to my bridge USB-COM Prolific.

Do you have the proper TTL Serial voltage adapter that converts your computer's 5 Volt serial to the router's 3 Volt serial connection???

See post #4 here: [solved] Can't connect even when in failsafe mode

and others regarding the TTL adapter.

you used rs232 usb
need USB TTL
I used before rs232 get the same problem !
but with USB TTL is work Good

Hi Marlowe,

Did you manage to fix the putty connection? I get the same unreadable messages in putty with two routers, an Edimax and a Netgear. And only connecting Tx to Tx and Rx to Rx. When using crossed connection, Rx to Tx and Tx to Rx the putty window remain black. I use a FTDI232 usb to ttl interface.

I've tried all kind of setting in putty but without success. Did someone have any ideea?

Thank you,

Hi again,

I managed to fix it myself. There were two issues: first was a faulty ftdi232 module (even with loop test I have all characters echoed), and second an incorrect baud rate. After I changed the ftdi232 module and find the right baud rate (115200, N,1,1) everything worked fine... till I tried to load openwrt and after reboot the router remained totally dead. But for this I'll try to open a new post.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.