Configure Outdoor Router with 4G as AP

Hi I am working on setting up a router from "outdoorrouter" which run a slightly customized version of Openwrt. It has a 4G modem integrated, 2.4g wifi, Eth0 as WAN and ETH1 as LAN. I also run a main router which controls all DNS, DHCP, Firewall, NAT, VPN, and Gateway. I will refer to the outdoor router as R2 and the main router as R1.

My main router runs a customized DDWRT firmware that I do not have control over static routes or changing the gateway etc. so I need to treat R1 as non modifiable. R2 runs openwrt with full configurability.

What I want to perform is to have R2 to provide internet via the 4G modem and serve as a dummy AP for R1. Given I have 2 eth ports,what I am trying to accomplish is have eth0 (wan) work as a LAN2 and connect it to LAN side of R1. LAN1(eth1) leave as is and connect it to WAN side of R1.

Where I have gotten so far is removed eth0 from WAN, Then I created LAN2 with eth0 attached and set it up to match the subnet of R1. As long as I do not have a gateway on LAN2 I can get internet access from LAN1. However, if I configure LAN2 with ip,subnet, gateway, dns, and broadcast (similar to how I have on other dummy APs running on my network) I then lose internet access but still have network from LAN1 (which is just set up with a static IP and subnet mask, no other special details)

So I feel like there is some issue with tagging? Ultimitely, LAN2 should have no communication from the mobile WAN side of R2 and should only be an extension of R1. Then, LAN1 should basically act like a modem to R1. I do not have the switching menu as eth0 and eth1 are not switched.

Here is my network config (note= if LAN2 gateway is blank internet access is still available on LAN1 but if it is added I lose access to the internet but still have network communication):

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.30.1'
	option netmask '255.255.255.0'
	option ifname 'eth1'

config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.100.1'
	option netmask '255.255.255.0'
	option ifname 'wlan0-1'

config interface 'MOBILE'
	option metric '3'
	option signalrate '30'
	option proto 'modemmanager'
	option device '/sys/devices/platform/ehci-platform/usb1/1-1/1-1.3'

config interface 'LAN2'
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.12.14.13'
	option netmask '255.255.255.0'
	option broadcast '10.12.14.13'
	option dns '10.12.14.10'
	option gateway '10.12.14.10'
	option ifname 'eth0'

The AP side should be a dumb AP-- use an interface of proto 'none' to form a layer 2 bridge from the Ethernet port to the wifi AP. You don't want this router doing anything at layer 3 with those packets. That will all be handled by your other router.

That does leave the issue of how you can log into OpenWrt. You can place an IP address on the LAN bridge for that, but then you have to be careful that it doesn't start routing locally. Another approach is to have an entirely separate admin network with its own SSID.

Here is what I get when I try to add an interface:

"form a layer 2 bridge from the Ethernet port to the wifi AP" ... What does this mean? I will still assign the eth0 port a static address?

Nevermind I set it to 'none' in config and see it has equivalent to unmanaged.

Next would be regarding firewall, NAT and DNS, as I want eth1 to act like that of a modem. Do I simply disable NAT, DNSmasq and the firewall on the outdoor router? I guess I will need to leave DHCP on so it assigns an IP to the main routers WAN

Or I'm wondering if I simply need to bridge WAN and LAN1?

Edit: I found this section but as it says I should follow my manufacture documentation for setting it into bridge mode. There is no documentation for setting the modem into bridge mode... I also saw on a post last year about this possibly being performed with modemmanager but I have been unsuccessful at locating how to do that.

So where I am at now is MK24s suggestion to bridge wifi and eth0 as an unmanaged interface has proved successful. I added a service wlan with it's own interface and dhcp so I can still connect to the router (R2 - outdoor router). Now my remaining dilemma is how to bridge wwan to eth1 so that R1 receives the public IP.

I have found quite a few posts regarding this but not able to follow what the end solution was.