Configure OpenVPN only on some LAN ports

@trendy, I'm afraid it's because of the WAN finding code and the fact that both wan and wwan are present on the system.

I'll have a look at the code again.

1 Like

Hi @stangri and @trendy thank you very much for looking at this.

Please let me know if there is any other data or information I can provide.

Thank you!

@stangri and @trendy

Thank you for your help. All sorted. VPN-PBR working great!

The first bit of the solution from Stan was to renamed WWAN to sta (so as the name did not include wan).

Secondly created an interface in Luci for the VPN.

And finally the OpenVPN config I used included a kill switch (doh.....) - after turning that off, all is working as expected.

Thank you for your patient help!

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.