Configure openvpn & nordvpn

First I configure the client openvpn through router openwrt/wireguard with subnet 192.168.99.x vpn works,
but if connected to ISP router which have subnet 192.168.100.x vpn does not work

with subnet 192.168.111.1 also does not work

I suggest you post contents of /etc/config/network configuration file.

Also post contents of system log for the Openvpn instance, to observe for error messages.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd41:7938:ff45::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.111.1'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option peerdns '0'
        option dns '8.8.8.8 8.8.4.4'
                                      
config interface 'wan6'              
        option ifname 'eth0'         
        option proto 'dhcpv6'       
                                    
config interface 'nordvpntun'       
        option proto 'none'         
        option ifname 'tun0'        
  
Sat Nov 23 16:21:04 2019 OpenVPN 2.4.5 mips-openwrt-linux-gnu [SSL (OpenSSL)] [L
Sat Nov 23 16:21:04 2019 library versions: OpenSSL 1.0.2t  10 Sep 2019, LZO 2.10
Sat Nov 23 16:21:04 2019 WARNING: --ping should normally be used with --ping-res
Sat Nov 23 16:21:04 2019 Outgoing Control Channel Authentication: Using 512 bit 
Sat Nov 23 16:21:04 2019 Incoming Control Channel Authentication: Using 512 bit 
Sat Nov 23 16:21:04 2019 TCP/UDP: Preserving recently used remote address: [AF_I
Sat Nov 23 16:21:04 2019 Socket Buffers: R=[163840->163840] S=[163840->163840]  
Sat Nov 23 16:21:04 2019 UDP link local: (not bound)                            
Sat Nov 23 16:21:04 2019 UDP link remote: [AF_INET]184.170.253.38:1194          
Sat Nov 23 16:21:04 2019 write UDP: Network unreachable (code=128)              
Sat Nov 23 16:21:04 2019 Network unreachable, restarting                        
Sat Nov 23 16:21:04 2019 SIGUSR1[soft,network-unreachable] received, process res
Sat Nov 23 16:21:04 2019 Restart pause, 5 second(s) 
Sat Nov 23 16:21:09 2019 WARNING: --ping should normally be used with --ping-res
Sat Nov 23 16:21:09 2019 TCP/UDP: Preserving recently used remote address: [AF_I
Sat Nov 23 16:21:09 2019 Socket Buffers: R=[163840->163840] S=[163840->163840]  
Sat Nov 23 16:21:09 2019 UDP link local: (not bound)                            
Sat Nov 23 16:21:09 2019 UDP link remote: [AF_INET]184.170.253.38:1194          
Sat Nov 23 16:21:09 2019 write UDP: Network unreachable (code=128)              
Sat Nov 23 16:21:09 2019 Network unreachable, restarting                        
Sat Nov 23 16:21:09 2019 SIGUSR1[soft,network-unreachable] received, process res
Sat Nov 23 16:21:09 2019 Restart pause, 5 second(s)                             
Sat Nov 23 16:21:14 2019 WARNING: --ping should normally be used with --ping-res
Sat Nov 23 16:21:14 2019 TCP/UDP: Preserving recently used remote address: [AF_I
Sat Nov 23 16:21:14 2019 Socket Buffers: R=[163840->163840] S=[163840->163840]  
Sat Nov 23 16:21:14 2019 UDP link local: (not bound)                            
Sat Nov 23 16:21:14 2019 UDP link remote: [AF_INET]184.170.253.38:1194          
Sat Nov 23 16:21:14 2019 write UDP: Network unreachable (code=128)              
Sat Nov 23 16:21:14 2019 Network unreachable, restarting                        
Sat Nov 23 16:21:14 2019 SIGUSR1[soft,network-unreachable] received, process res
Sat Nov 23 16:21:14 2019 Restart pause, 5 second(s)                             
Sat Nov 23 16:21:19 2019 WARNING: --ping should normally be used with --ping-res
Sat Nov 23 16:21:19 2019 TCP/UDP: Preserving recently used remote address: [AF_I
Sat Nov 23 16:21:19 2019 Socket Buffers: R=[163840->163840] S=[163840->163840]  
Sat Nov 23 16:21:19 2019 UDP link local: (not bound)                            
Sat Nov 23 16:21:19 2019 UDP link remote: [AF_INET]184.170.253.38:1194          
Sat Nov 23 16:21:19 2019 write UDP: Network unreachable (code=128)              
Sat Nov 23 16:21:19 2019 Network unreachable, restarting                        
Sat Nov 23 16:21:19 2019 SIGUSR1[soft,network-unreachable] received, process res
Sat Nov 23 16:21:19 2019 Restart pause, 5 second(s)                             
Sat Nov 23 16:21:24 2019 WARNING: --ping should normally be used with --ping-res
Sat Nov 23 16:21:24 2019 TCP/UDP: Preserving recently used remote address: [AF_I
Sat Nov 23 16:21:24 2019 Socket Buffers: R=[163840->163840] S=[163840->163840]  
Sat Nov 23 16:21:24 2019 UDP link local: (not bound)                            
Sat Nov 23 16:21:24 2019 UDP link remote: [AF_INET]184.170.253.38:1194          
Sat Nov 23 16:21:24 2019 write UDP: Network unreachable (code=128)              
Sat Nov 23 16:21:24 2019 Network unreachable, restarting                        
Sat Nov 23 16:21:24 2019 SIGUSR1[soft,network-unreachable] received, process res
Sat Nov 23 16:21:24 2019 Restart pause, 10 second(s)                            
Sat Nov 23 16:21:34 2019 WARNING: --ping should normally be used with --ping-res
Sat Nov 23 16:21:34 2019 TCP/UDP: Preserving recently used remote address: [AF_I
Sat Nov 23 16:21:34 2019 Socket Buffers: R=[163840->163840] S=[163840->163840]  
Sat Nov 23 16:21:34 2019 UDP link local: (not bound)                            
Sat Nov 23 16:21:34 2019 UDP link remote: [AF_INET]184.170.253.38:1194          
Sat Nov 23 16:21:34 2019 write UDP: Network unreachable (code=128)              
Sat Nov 23 16:21:34 2019 Network unreachable, restarting                        
Sat Nov 23 16:21:34 2019 SIGUSR1[soft,network-unreachable] received, process res
Sat Nov 23 16:21:34 2019 Restart pause, 20 second(s)                            
- /tmp/ovpn.log 58/58 100%

I just realised you have mentioned an openwrt/wireguard router. Is this a VPN router?

So is your ISP blocking access to the NordVPN server you wish to use?
Can you successfully ping 184.170.253.38 through your ISP router?

yes, (another vpn provider)

i can ping 184.170.253.38 through my laptop which connected to ISP router

Are there any firewall rules on the ISP modem which may be using port 1194?

What is your location?
Does your ISP block use of port 1194?

If you use a PC, can you connect to same server and port number using openvpn client software via your ISP router?

Someone else may have other suggestions.

found a reason, in the router ISP work(or disabled) only two out of four eth ports

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.