Configure new ISP with PPPoE

Hello I have a new ISP and would like to connect via PPPoE, I tried adding a new interface with login and passwd they provide, but got no connection.

Here are the config i did:

config interface 'Tiscali'
        option proto 'pppoe'
        option device 'eth1'
        option password 'xxxxxxxxxxx'
        option ipv6 '0'
        option username 'xxxxxxxxxxxxxxxx'

Their documentation: https://assistenza.tiscali.it/internet-telefono/modem/guida/parametri-connessione/

In order to assist you, please provide the full /etc/config/network configurations.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf0:fc2d:bdb1::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'Tiscali'
        option proto 'pppoe'
        option device 'eth1'
        option password 'xxxxxxxxxxx'
        option ipv6 '0'
        option username 'xxxxxxxxxxxxxxxx'

In my poor italian I see a VLAN 835 specified, yet no such thing in your config?

2 Likes

True, I don't know how to config that.

config interface 'Tiscali'
        option proto 'pppoe'
        option device 'eth1.835'
        option password 'xxxxxxxxxxx'
        option ipv6 '0'
        option username 'xxxxxxxxxxxxxxxx'

Hope this helps.

1 Like

It does not connect yet

What type of hardware do you have?

Keep your wan interface named 'wan' (in lower case) since that name is already defined in a firewall zone.

Examine the log for possible pppoe activity and errors.

3 Likes

GL.inet Spitz X750v2

How to examine the logs?

Status | System Log and scroll down.

Use

wan.835

how exactly?

No this is a QCA95xx chip, which are still swconfig, and eth1 is a port direct to outside. So eth1.835 is the proper setting assuming the modem expects pppoe packets tagged 835.

Ok, so I just tried with this config:


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd2b:1180:d5b6::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1.835'
        option proto 'pppoe'
        option username 'my username'
        option password 'my passwd'
        option ipv6 'auto'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

and got this log:

Tue Jun 13 19:42:41 2023 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using nameserver fd00::b2f2:8ff:fe0c:f402#53
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 2 addresses
Tue Jun 13 19:42:41 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Tue Jun 13 19:42:55 2023 daemon.warn pppd[6105]: Timeout waiting for PADO packets
Tue Jun 13 19:42:55 2023 daemon.err pppd[6105]: Unable to complete PPPoE Discovery
Tue Jun 13 19:42:55 2023 daemon.info pppd[6105]: Exit.
Tue Jun 13 19:42:55 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:42:55 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:42:55 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:42:55 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:42:55 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:42:55 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:42:55 2023 daemon.info pppd[6380]: Plugin pppoe.so loaded.
Tue Jun 13 19:42:55 2023 daemon.info pppd[6380]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:42:55 2023 daemon.notice pppd[6380]: pppd 2.4.9 started by root, uid 0
Tue Jun 13 19:43:10 2023 daemon.warn pppd[6380]: Timeout waiting for PADO packets
Tue Jun 13 19:43:10 2023 daemon.err pppd[6380]: Unable to complete PPPoE Discovery
Tue Jun 13 19:43:10 2023 daemon.info pppd[6380]: Exit.
Tue Jun 13 19:43:11 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:43:11 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:43:11 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:43:11 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:43:11 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:43:11 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:43:11 2023 daemon.info pppd[6463]: Plugin pppoe.so loaded.
Tue Jun 13 19:43:11 2023 daemon.info pppd[6463]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:43:11 2023 daemon.notice pppd[6463]: pppd 2.4.9 started by root, uid 0
Tue Jun 13 19:43:26 2023 daemon.warn pppd[6463]: Timeout waiting for PADO packets
Tue Jun 13 19:43:26 2023 daemon.err pppd[6463]: Unable to complete PPPoE Discovery
Tue Jun 13 19:43:26 2023 daemon.info pppd[6463]: Exit.
Tue Jun 13 19:43:26 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:43:26 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:43:26 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:43:26 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:43:26 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:43:26 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:43:26 2023 daemon.info pppd[6546]: Plugin pppoe.so loaded.
Tue Jun 13 19:43:26 2023 daemon.info pppd[6546]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:43:26 2023 daemon.notice pppd[6546]: pppd 2.4.9 started by root, uid 0
Tue Jun 13 19:43:37 2023 daemon.notice netifd: Network device 'eth1' link is down
Tue Jun 13 19:43:37 2023 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Jun 13 19:43:37 2023 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Jun 13 19:43:37 2023 kern.info kernel: [10356.673637] eth1: link down
Tue Jun 13 19:43:37 2023 daemon.notice netifd: wan6 (4506): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wan6" } (Permission denied)
Tue Jun 13 19:43:37 2023 daemon.err pppd[6546]: select (waitForPADO): Interrupted system call
Tue Jun 13 19:43:37 2023 daemon.warn pppd[6546]: Timeout waiting for PADO packets
Tue Jun 13 19:43:37 2023 daemon.err pppd[6546]: Unable to complete PPPoE Discovery
Tue Jun 13 19:43:37 2023 daemon.info pppd[6546]: Exit.
Tue Jun 13 19:43:37 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:43:37 2023 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Tue Jun 13 19:43:37 2023 daemon.notice netifd: Interface 'wan6' is now down
Tue Jun 13 19:43:44 2023 daemon.notice netifd: Network device 'eth1' link is up
Tue Jun 13 19:43:44 2023 daemon.notice netifd: Interface 'wan6' has link connectivity
Tue Jun 13 19:43:44 2023 daemon.notice netifd: Interface 'wan6' is setting up now
Tue Jun 13 19:43:44 2023 daemon.notice netifd: Interface 'wan' has link connectivity
Tue Jun 13 19:43:44 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:43:44 2023 kern.info kernel: [10363.955389] eth1: link up (100Mbps/Full duplex)
Tue Jun 13 19:43:44 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:43:44 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:43:44 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:43:44 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:43:45 2023 daemon.info pppd[6716]: Plugin pppoe.so loaded.
Tue Jun 13 19:43:45 2023 daemon.info pppd[6716]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:43:45 2023 daemon.notice pppd[6716]: pppd 2.4.9 started by root, uid 0
Tue Jun 13 19:44:00 2023 daemon.warn pppd[6716]: Timeout waiting for PADO packets
Tue Jun 13 19:44:00 2023 daemon.err pppd[6716]: Unable to complete PPPoE Discovery
Tue Jun 13 19:44:00 2023 daemon.info pppd[6716]: Exit.
Tue Jun 13 19:44:00 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:44:00 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:44:00 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:44:00 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:44:00 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:44:00 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:44:00 2023 daemon.info pppd[6739]: Plugin pppoe.so loaded.
Tue Jun 13 19:44:00 2023 daemon.info pppd[6739]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:44:00 2023 daemon.notice pppd[6739]: pppd 2.4.9 started by root, uid 0
Tue Jun 13 19:44:15 2023 daemon.warn pppd[6739]: Timeout waiting for PADO packets
Tue Jun 13 19:44:15 2023 daemon.err pppd[6739]: Unable to complete PPPoE Discovery
Tue Jun 13 19:44:15 2023 daemon.info pppd[6739]: Exit.
Tue Jun 13 19:44:15 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:44:15 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:44:15 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:44:15 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:44:15 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:44:15 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:44:15 2023 daemon.info pppd[6822]: Plugin pppoe.so loaded.
Tue Jun 13 19:44:15 2023 daemon.info pppd[6822]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:44:15 2023 daemon.notice pppd[6822]: pppd 2.4.9 started by root, uid 0
Tue Jun 13 19:44:30 2023 daemon.warn pppd[6822]: Timeout waiting for PADO packets
Tue Jun 13 19:44:30 2023 daemon.err pppd[6822]: Unable to complete PPPoE Discovery
Tue Jun 13 19:44:30 2023 daemon.info pppd[6822]: Exit.
Tue Jun 13 19:44:31 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:44:31 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:44:31 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:44:31 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:44:31 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:44:31 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:44:31 2023 daemon.info pppd[6909]: Plugin pppoe.so loaded.
Tue Jun 13 19:44:31 2023 daemon.info pppd[6909]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:44:31 2023 daemon.notice pppd[6909]: pppd 2.4.9 started by root, uid 0
Tue Jun 13 19:44:46 2023 daemon.warn pppd[6909]: Timeout waiting for PADO packets
Tue Jun 13 19:44:46 2023 daemon.err pppd[6909]: Unable to complete PPPoE Discovery
Tue Jun 13 19:44:46 2023 daemon.info pppd[6909]: Exit.
Tue Jun 13 19:44:46 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:44:46 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:44:46 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:44:46 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:44:46 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:44:46 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:44:46 2023 daemon.info pppd[6992]: Plugin pppoe.so loaded.
Tue Jun 13 19:44:46 2023 daemon.info pppd[6992]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:44:46 2023 daemon.notice pppd[6992]: pppd 2.4.9 started by root, uid 0
Tue Jun 13 19:45:01 2023 daemon.warn pppd[6992]: Timeout waiting for PADO packets
Tue Jun 13 19:45:01 2023 daemon.err pppd[6992]: Unable to complete PPPoE Discovery
Tue Jun 13 19:45:01 2023 daemon.info pppd[6992]: Exit.
Tue Jun 13 19:45:01 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:45:01 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:45:02 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:45:02 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:45:02 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:45:02 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:45:02 2023 daemon.info pppd[7075]: Plugin pppoe.so loaded.
Tue Jun 13 19:45:02 2023 daemon.info pppd[7075]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:45:02 2023 daemon.notice pppd[7075]: pppd 2.4.9 started by root, uid 0
Tue Jun 13 19:45:17 2023 daemon.warn pppd[7075]: Timeout waiting for PADO packets
Tue Jun 13 19:45:17 2023 daemon.err pppd[7075]: Unable to complete PPPoE Discovery
Tue Jun 13 19:45:17 2023 daemon.info pppd[7075]: Exit.
Tue Jun 13 19:45:17 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:45:17 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:45:17 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:45:17 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:45:17 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:45:17 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:45:17 2023 daemon.info pppd[7158]: Plugin pppoe.so loaded.
Tue Jun 13 19:45:17 2023 daemon.info pppd[7158]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:45:17 2023 daemon.notice pppd[7158]: pppd 2.4.9 started by root, uid 0
Tue Jun 13 19:45:32 2023 daemon.warn pppd[7158]: Timeout waiting for PADO packets
Tue Jun 13 19:45:32 2023 daemon.err pppd[7158]: Unable to complete PPPoE Discovery
Tue Jun 13 19:45:32 2023 daemon.info pppd[7158]: Exit.
Tue Jun 13 19:45:32 2023 daemon.notice netifd: Interface 'wan' is now down
Tue Jun 13 19:45:32 2023 daemon.notice netifd: Interface 'wan' is setting up now
Tue Jun 13 19:45:32 2023 daemon.err insmod: module is already loaded - slhc
Tue Jun 13 19:45:32 2023 daemon.err insmod: module is already loaded - ppp_generic
Tue Jun 13 19:45:32 2023 daemon.err insmod: module is already loaded - pppox
Tue Jun 13 19:45:32 2023 daemon.err insmod: module is already loaded - pppoe
Tue Jun 13 19:45:32 2023 daemon.info pppd[7241]: Plugin pppoe.so loaded.
Tue Jun 13 19:45:32 2023 daemon.info pppd[7241]: PPPoE plugin from pppd 2.4.9
Tue Jun 13 19:45:32 2023 daemon.notice pppd[7241]: pppd 2.4.9 started by root, uid 0

still no internet working

Timeout waiting for PADO packets means no network link to the ISP.

  • Make sure that eth1 is actually the port connected to the modem. Unplug the cable between the modem and the router, the log should no longer show this: eth1: link up (100Mbps/Full duplex) until you plug it back in.
  • The modem must be connected to an active DSL line. Most modems have a DSL status light and in most cases a good connection turns the light on steady, not blinking.
  • Confirm that VLAN assignment is correct. Connecting a laptop with wireshark directly to the modem may show tagged packets coming from the modem.
1 Like

It does not have a modem, but a small box with no lights, where the fiber comes and a RJ45 comes out, the ISP gave me a fritz box router to connect the RJ45 cable, which works. I will try what you just suggested.
I was connected to the wan port on my router.
Logs after unplugging the cable:

Tue Jun 13 20:14:18 2023 daemon.info hostapd: wlan0: STA ac:12:03:96:ba:cc IEEE 802.11: authenticated
Tue Jun 13 20:14:18 2023 daemon.info hostapd: wlan0: STA ac:12:03:96:ba:cc IEEE 802.11: associated (aid 1)
Tue Jun 13 20:14:18 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED ac:12:03:96:ba:cc
Tue Jun 13 20:14:18 2023 daemon.info hostapd: wlan0: STA ac:12:03:96:ba:cc WPA: pairwise key handshake completed (RSN)
Tue Jun 13 20:14:18 2023 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED ac:12:03:96:ba:cc
Tue Jun 13 20:14:19 2023 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.129 ac:12:03:96:ba:cc
Tue Jun 13 20:14:19 2023 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.129 ac:12:03:96:ba:cc computer

Change modem to bridge

No, my ISP gives me the freedom to use directly only my router and I finally did it, with the help from this guy: https://inv.vern.cc/watch?time_continue=9&v=zMze7luKmBg&embeds_referring_euri=https%3A%2F%2Fforum.gl-inet.com%2F&source_ve_path=Mjg2NjY&feature=emb_logo

I had setup anoher router the other day a GL.inet AP1300, but using their fork of openwrt, which sucks. So today I put my hands on the x750 again and it worked more or less with your suggestion:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde6:764b:84db::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1.835'
        option proto 'pppoe'
        option username 'xxxxxxxxxxxxxxxxxxxxxxx'
        option password 'xxxxxxxxxxxxxxxxxxxx'
        option ipv6 '0'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

As someone notice I was creating another interface unecessarly, I just needed to change lan settings to pppoe.Thank you all for the help.
One question I have though, why leave ipv6 off? as "option ipv6 '0'", I ask out of curiosity, even because my ISP does not support it

I simply copied and pasted your configuration from Post No. 1 - so I'm not sure why you had it set to 0. I'd personally set it to 1.

1 Like