Configure Home Hub 5A with LEDE as a WiFi extender

Hi All
Pretty simple request for you guys I'm sure, but could anyone tell me if it's possible, and give me instructions on how to set up my BT Home Hub 5A running LEDE 17.01.4 firmware as a WiFi extender please?
My network consists of a Zyxel 3925 as a bridge modem, connected to a PC running Opnsense for my router, which is connected to an Asus AC86U as my wireless access point and where I would be connecting the LEDE Home Hub 5 to.
I'd be very grateful for any advice / help on this.
Many thanks in advance.

An easier (and more reliable) option would be using WDS (4addr) instead, but that would require using LEDE (well, at least nl80211 based wlan drivers with hostapd, basically mainline linux drivers) all APs that are supposed to talk to each other via WDS.

Many thanks for the reply and link, much appreciated.
One other question, do you know if the LAN ports would still function as normal with the HH5A running LEDE configured as a WiFi extender?

Yes, the incoming wireless network will be available on the LAN ports as well.

Awesome, however I forgot to mention that the HH5A I want to use as a WiFi extender will be connected to my router via an ethernet cable. Does the guide still apply?

If your HH5A will be wired to your main wifi router using ethernet cable, then in fact you will want to configure the HH5A as a Wireless Access Point, not as a WDS Wireless Extender/Repeater which does not require a cable connection.

See section 9.6 of the PDF guide hosted on ebilan forum for configuiring a simple WAP.
LEDE Installation Guide for HH5A on ebilan forum

Brilliant, thank you for that info Bill, much appreciated!

Hi Bill
Just wondering if you could help me out with something.
I've setup the HH5A as a WAP, however I've checked the wireless overview and neither the 2.4 or 5.0 GHz bands are enabled. I'm presuming these would have to be enabled to create the wifi signals from the HH5A? Thing is I want the wifi signals from the HH5A to use the same SSID and passwords for my main router. Any ideas how I would go about doing this?

From the Network -> Wireless page, under 'Wireless Overview', have you clicked on 'Edit' buttons to edit the wireless configuration of each radio accordingly?

Then press 'Enable' button for each radio as the radios are disabled by default.

The above steps are not described in any detail in the guide because I've always assumed the reader knows how to configure basic wireless settings on 'any' wifi router. I may consider adding some basic information in a future release of the guide.

Cheers for that info Bill.
It did occur to me to try that out, and I've managed to set it up, I just needed it clarified for me. My only issue now are the LAN ports don't work as they should. I have a PS3 and PSTV to remote play my PS4 in the bedroom, where incidentally I've located the HH5A. I prefer using wired connections for these devices, unfortunately there seems to be a NAT issue linked to UPnP. Just found a thread with info about this so should be easy enough to get it up and running properly.
Many thanks

I'm no expert, but if you are just using the yellow LAN ports on the HH5A and (changed HH5a IP address, and turned off DHCP server, with one of the LAN ports wired to your Asus router, it is not clear why you would be having upnp/NAT issues with your wired PS3, because the gigabit switch in the HH5A is not doing any 'routing'.

I presume your PS3 works fine wired direct to the Asus router.

I previously used an ethermet switch and the PS3 and PSTV worked fine then. There is a UPnP package for the HH5A which I wasn't sure if I would need to install on LEDE. However, I've just realised that I should try and configure the PS3 again, as the internet connection settings were as they were for the switch. I'll give that a go before I start messing with installing packages.

The HH5A in basic WAP mode is a direct substitute for your existing switch. In theory, you should not need to change anything on PS3, nor do you need to install any packages because the HH5A is NOT performing any routing function, because you are not using the yellow WAN or DSL ports.

Any upnp or NAT issues would be down to how your main router is configured.

Check the IP address of your PS3 stays the same regardless of whether you use your existing switch, or wired to the HH5A. The IP address will be the one assigned presumably by your Opensense router or may be Asus without knowing how it is configured.

But I am using the yellow LAN ports on the HH5A for the PS3 and PSTV consoles, or at least thats what I want to use. I do have internet connection to the PS3 as I can access the internet on its browser, but when I configure the PS3 internet connection I get UPnP not available and NAT type 3, even if I try to manually set UPnP to enabled and set NAt type 2. IP address stays the same for the PS3 whether I use the switch or the HH5A.
My network is setup as follows:
Phone line to modem on
Modem to Opnsense router, Opnsense on
Opnsense router to Asus in AP mode, Asus on
Asus to HH5A, HH5A on
I'm pretty sure the IP range of the Opnsense box is set to - 100
Don't know if any of that helps??

Deleted earlier reply after carefully re-reading your last two responses.

Basically, there were no uPnP/NAT issues with previous switch.

This is puzzling.

I presume the assigned to the modem is just for administrating the modem. ie. you are not routing through to get to internet.

Modem is set as for admin purposes and for line stats, I'm not using it for any routing.
Too be honest I don't actually know if the UPnP / NAT issue was there before putting the HH5A into the equation, but I get the same when I tried using the ethernet switch a moment ago, so I'm assuming it has been there. If that being the case then I have to look at the opnsense and asus to see where the problem lies. I've got a feeling it could be opnsense, as I've only had that setup in the last few weeks. I've got a mate who is more familiar with opnsense so I'll see what he has to say.
I'll let you know if I find anything out, cheers for your help so far Bill, really appreciate your time and efforts!

Found out it's more than likely an Opnsense issue with UPnP, it's not enabled or installed on default Opnsense build. There is a UPnP plugin I have to install and that should sort it out.
Cheers for the help Bill, much appreciated!

I'm not sure why you would need UPnP if the necessary ports are forwarded correctly.

UPnP is a security risk.