Configure 1und1 ISP

Hi Folks, after hours of searching and trying i'm not able to get a connection with my TP-Link Archer AC1750 C7 and my ISP 1und1. I've installed the actual version of Openwrt 23.05.2
This is my actual configuration and i'm not getting a connect and i have no VDSL. This is my configuration:

 root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fe80::/8'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2t 3t 4t 5t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 1t'
	option vid '2'

config interface '1und1'
	option proto 'pppoe'
	option device 'eth0.2'
	option username '1und1/xxxxxx-xxx@online.de'
	option password 'xxxxxxxxxx'
	option ipv6 'auto'

Hope that anybody can give my any advice.
Thanks in advance

Mark

There are several 1und1 threads here, have you read them ?

https://openwrt.org/docs/guide-user/network/wan/isp-configurations#germany

Just to be explicit, you do have an external -dedicated- VDSL modem in place?

From there on, there are two orthogonal strategies - both valid, just doing things in a different stacking order:

  • letting the VDSL modem do the tagging
  • doing the tagging on your router

(I personally favour the later - and it appears that you might have tried to do that as well, so that's my assumption from here on).

Your /etc/config/network looks rather 'uncommon' for either of these approaches - and I would suggest resetting the device first (firstboot) and starting up with a fresh default config (only doing minimal changes). frollic has already given you good advice for that, but just to provide a few pointers that are definitively wrong:

I kind of doubt you really want all LAN ports to be tagged (so probably '0t 2 3 4 5').

I'm pretty confident that you need VLAN 7 on WAN, not 2 (see frollic's examples).

You have defined two (well, three) conflicting interfaces for your wan - wan, wan6 and 1und, this will cause issues. Don't invent your own 1und1 interface (unless you have a very specific reason to), just keep wan/ wan6 and modifiy wan to use pppoe (change protocol in luci or the contents of your 1und1 interface).

Please, don't try to fix your current config, really start over fresh (there are more issues, I'm just raising the ones that should help you starting from a fresh default config).

2 Likes

Yes, i read several of them and tried different configurations but with no success

Maybe my fault i'm using a 1und1 50/10 MBit DSL, so it could be possible that it's VDSL, i don't know - is only 16/x MBit ADSL? I used over years a Fritzbox 7490 but i want to have more "freedom" in my configuration. So my TP-Link Archer should be able build a connection via WAN Interface.
I'm an absolute Openwrt newbie

Mark

ADSL2+ goes up to 24/3.5 MBit/s in theory, but I'm not aware of any commercial deployments beyond 16/1 MBit/s, 25+ MBit/s are by definition VDSL (VDSL, VDSL2, VDSL2+vectoring, etc.).

It isn't, not without the help of a dedicated VDSL modem, but you don't mention anything about that - which makes me suspicious that you don't have any. Your Fritz!Box 7490 includes a VDSL2+vectoring/ profile 17b modem, the archer c7 is only a wifi router, it does not sport modem capabilities itself.

2 Likes

Deutsche Telekom actually uses the following maximal Sync limits* for ADSL2+ with AnnexJ
Download 21.440 Mbps
Upload: 3.648 Mbps
But you likely need to live inside the DSLAM to get that high a sync...

*) These are revealed in the public documents for the different BSA options, that Telekom needs to offer its competitors in Vectoring areas.

So we all agree... the link should be running at VDSL2.

+1.

1 Like

Thanks a lot for this information, it was my vault to expect that the TP-Link is able to establish this connection. So i'll think about to place my Fritzbox as the router before the TP-Link or i'll investigate for a router that include a VDSL-Modem.

Thanks to all

Some models of AVM's FritzBox 7530/7520 can be used as VDSL2 modem routers under OpenWrt. These can be gotten second hand for 50-60EUR (last time I looked). But first research which exact version you need (I think for the 7520 you need the old form factor with the 2 smallish antenna 'fins', as the newer ones contain a different SoC that will not work with OpenWrt, IIRC).

One quick and dirty hack that might work with your existing gear is:

  1. factory reset the 7490
  2. then enable PPPoE passthrough (if that is not enabled by default), but do NOT configure the PPPoE credentials in the Fritzbox.
  3. configure PPPoE in your OpenWrt router

Not sure about where to set VLAN7 in that mode though...

1 Like

Emphasis on some models (there are at least 6 different ones by now). The AX variants are not supportable (Broadcom) and I have no real ideal about the v2 variants of either.

1 Like