Configuration Problem with OpenWrt as router and seperate LTE Modem

Please, i need some urgent help, because my old configuration which is wokijng at the moment will stopp working because of a running out LTE Contract:
My old Confif was a Netgear NETGEAR WNDR3700v4 with openwrt used as a router and a lte Stick connected with the USB port working as a seperate modem:
The Stick is configurated as the following:
Stick1:


And Stick2:
stick2
On the router in luci i can see, the following interfaces:

If i loook in the configuration off the wan interface:

Hardware Interface for the Stick (usb-Port) ist:

The Other thing ist the configuration of the LANPORT:

And the physical Interface of the Lanport:

The Configuration of the wan is:

Physical connections are:

If i configure my new B628s the same the E3372 Stick was configurated, an put it in the Wan Port, the internet does not work.
i figur out that the configuration is just for the usb port and not the wann port:
what to i have to change here (puting the cable on the wan port shows me that it is port nummber 5:

Please help me i have no F***** idea whats wrong and what i have to do.
Why does it work with an usb Connections put not with a cable connection??

Thanks in Advance for an answer a noob understands :slight_smile:
Have a nice Day and sorry for my bad englisch!
Kind regards.

Has someone an idea? :worried:

I am not sure I understand what is the problem here.
You have one Netgear WNDR3700v4 router, which has the Huawei USB dongle e3372 plugged in working as WAN connection.
The B628s is some Huawei router if I am not mistaken.
What you would want is to configure the wan interface on eth1, which is done already. Verify that the IP address you used in wan interface is fine, although I can see packets going in and out.
I am not sure what is the lanport interface doing there. Also why have you created multiple vlans on eth0 and assigned them on the lan interface? The switch looks a bit messed up. Better start from scratch if you are not sure what have you changed there.

I am very thankfull for your answer and as a first step i completly deleted the lanport Interface, you where right, the e3372 usb stick and the whole network worked without it!
Everytime i put of the usb device and put one the B618s with the settings above the internet is not working. im completly devasted, do you have a hint whtas going wrong?

If you are not experienced with multiple wans, I would suggest to first configure just the wan interface to the B618s and not plug in the e3372.
After you verify that everything is correct you could try to use the e3372 as backup link with mwan3.

Actually I want to replace the stick and use the new router (b618) over the wanport as a bridge... to i have to use 2 interfaces as configured now?

i thought that i just plug of the usb device and put on the B618 using as a bridge with the same settings the usb stick hat, but i does not work, i think it is because the wan Port on the netgear has to be changed, but on which device, here the screen of the configuration working now with the usb stick.
Thank you very much for your help!

That most probably won't work.
Use the B618 normally as a router and connect the wan port of 3700 to the lan of B618.

Instead of posting screenshots better login with with SSH and post here the output of the following command:
uci export network; uci export firewall

oh sorry i a really no expert, i just downloaded CMDER, when i opened it the programm asked me if it can download something with a warning, i denied it and now i dont no how to loggin because just the command you gave does not work...
Ok i did it. should i post the configuration with the usb Stick (working, old, i want to change) or with the B618 on the wan port?

ok here is the woeking config protocol i want to change:

root@OpenWrt:~# uci export network; uci export firewall
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd79:77c2:b60a::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr 'a4:2b:8c:08:9c:64'
        option ipaddr '192.168.0.1'
        option gateway '192.168.8.1'
        option dns '8.8.8.8 8.8.4.4'
        option _orig_ifname 'eth0.1 wlan0 wlan1'
        option _orig_bridge 'true'
        option ifname 'eth0.1 eth0.2'

config interface 'wan'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.8.100'
        option netmask '255.255.255.0'
        option gateway '192.168.8.1'
        option dns '8.8.8.8 8.8.4.4'
        option ifname 'eth1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option mirror_source_port '0'
        option mirror_monitor_port '0'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1t 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 1t'

config route

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option drop_invalid '1'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'REJECT'
        option forward 'REJECT'
        option network 'wan6 lanport wan b618 b618S'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'newzone'
        option output 'ACCEPT'
        option network ' '
        option input 'REJECT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option dest 'lan'
        option src 'wan'

config redirect
        option target 'DNAT'
        option proto 'tcp udp'
        option name 'vnc_WZ'
        option src_dport '5501'
        option dest_port '5501'
        option dest 'lan'
        option src 'wan'
        option dest_ip '192.168.0.207'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option dest_port '5501'
        option name 'vnc'
        option dest 'lan'
        option proto 'tcp udp'
        option dest_ip '192.168.0.207'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option src_dport '8888'
        option dest_port '8888'
        option name 'webcam1'
        option dest_ip '192.168.0.207'
        option enabled '0'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option src_dport '8081'
        option dest_port '8081'
        option name 'webcam2'
        option dest_ip '192.168.0.207'
        option enabled '0'

config redirect
        option target 'DNAT'
        option src 'newzone'
        option dest 'lan'
        option proto 'tcp udp'
        option enabled '0'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option dest_ip '192.168.0.207'
        option name 'vnc_wz2'
        option src_dport '5601'
        option dest_port '5601'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'tcp udp'
        option name 'realvnc2'
        option dest_ip '192.168.0.207'
        option dest_port '5601'
        option dest 'lan'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option src_dport '9'
        option dest_ip '192.168.0.207'
        option dest_port '9'
        option name 'teamviewer wol'

config rule
        option enabled '1'
        option target 'ACCEPT'
        option src 'wan'
        option dest 'lan'
        option name 'teamviewer wol'
        option dest_ip '192.168.0.207'
        option dest_port '9'

When you plug in the USB modem, the driver creates a virtual eth port eth1. This was really a connection via USB-- though to software it looks like Ethernet. There is no physical Ethernet at eth1.

If you're now using physical Ethernet for the WAN, that would be eth0.2. The switch is configured so that eth0.1 is the 4 LAN ports, and eth0.2 is the WAN port. The "mother" interface eth0 also exists, but nothing should be attached to it.

In general if you reset the router to default configuration it will be a DHCP client on the WAN Ethernet, which should Just Work with a device like the B618, though you may need to change the LAN IP if the default 192.168.1.1/24 range overlaps with what the B618 uses.

You can then fine-tune the setup with the DMZ and firewall rules for incoming connections, if your new phone company allows them.

here is the proocol with the B628 on the wan port:

option src 'wan'
        option dest 'lan'
        option name 'teamviewer wol'
        option dest_ip '192.168.0.207'
        option dest_port '9'

root@OpenWrt:~# --------- root@OpenWrt:~#
-ash: ---------: not found
root@OpenWrt:~# uci export network; uci export firewall
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd79:77c2:b60a::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr 'a4:2b:8c:08:9c:64'
        option ipaddr '192.168.0.1'
        option gateway '192.168.8.1'
        option dns '8.8.8.8 8.8.4.4'
        option _orig_ifname 'eth0.1 wlan0 wlan1'
        option _orig_bridge 'true'
        option ifname 'eth0.1 eth0.2'

config interface 'wan'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.8.100'
        option netmask '255.255.255.0'
        option gateway '192.168.8.1'
        option dns '8.8.8.8 8.8.4.4'
        option ifname 'eth1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option mirror_source_port '0'
        option mirror_monitor_port '0'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1t 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 1t'

config route

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option drop_invalid '1'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'REJECT'
        option forward 'REJECT'
        option network 'wan6 lanport wan b618 b618S'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'newzone'
        option output 'ACCEPT'
        option network ' '
        option input 'REJECT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option dest 'lan'
        option src 'wan'

config redirect
        option target 'DNAT'
        option proto 'tcp udp'
        option name 'vnc_WZ'
        option src_dport '5501'
        option dest_port '5501'
        option dest 'lan'
        option src 'wan'
        option dest_ip '192.168.0.207'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option dest_port '5501'
        option name 'vnc'
        option dest 'lan'
        option proto 'tcp udp'
        option dest_ip '192.168.0.207'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option src_dport '8888'
        option dest_port '8888'
        option name 'webcam1'
        option dest_ip '192.168.0.207'
        option enabled '0'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option src_dport '8081'
        option dest_port '8081'
        option name 'webcam2'
        option dest_ip '192.168.0.207'
        option enabled '0'

config redirect
        option target 'DNAT'
        option src 'newzone'
        option dest 'lan'
        option proto 'tcp udp'
        option enabled '0'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option dest_ip '192.168.0.207'
        option name 'vnc_wz2'
        option src_dport '5601'
        option dest_port '5601'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'tcp udp'
        option name 'realvnc2'
        option dest_ip '192.168.0.207'
        option dest_port '5601'
        option dest 'lan'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option src_dport '9'
        option dest_ip '192.168.0.207'
        option dest_port '9'
        option name 'teamviewer wol'

config rule
        option enabled '1'
        option target 'ACCEPT'
        option src 'wan'
        option dest 'lan'
        option name 'teamviewer wol'
        option dest_ip '192.168.0.207'
        option dest_port '9'

Thank you for your advice above, i will try that, and if it doenst work will do a complete new setup!

According to the device page, there is an eth1 interface.
https://openwrt.org/toh/netgear/wndr3700

Yes that network config you posted has several problems.

  • Take eth0.2 out of LAN and put it in WAN instead. Get rid of eth1 entirely since no longer using USB modem.
  • Use DHCP on the WAN. Do not set gateway or DNS in either the WAN or the LAN sections. It should pick them up via DHCP. If you want a third-party DNS configure it in the WAN section.
  • All of the _orig_ lines are artifacts of using LuCI. They do not do anything and you can just remove them.

Yes trying to make sense of that for the V4. The AR9344 internal PHY is 10/100, so I thought it had a 6 port external gigabit switch. OP's switch config looks like it has been tampered with and broken as well.

did all you recommendet but it did not work and i had to go back to the old settings and putting on the usb-stick.
The Protokoll with the B628s on the wann port was the following:
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd79:77c2:b60a::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr 'a4:2b:8c:08:9c:64'
        option ipaddr '192.168.0.1'
        option gateway '192.168.8.1'
        option _orig_ifname 'eth0.1 wlan0 wlan1'
        option _orig_bridge 'true'
        option ifname 'eth0.1'

config interface 'wan'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.8.100'
        option netmask '255.255.255.0'
        option gateway '192.168.8.1'
        option ifname 'eth0.2'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option mirror_source_port '0'
        option mirror_monitor_port '0'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1t 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 1t'

config route

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option drop_invalid '1'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'REJECT'
        option forward 'REJECT'
        option network 'wan6 lanport wan b618 b618S'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'newzone'
        option output 'ACCEPT'
        option network ' '
        option input 'REJECT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option dest 'lan'
        option src 'wan'

config redirect
        option target 'DNAT'
        option proto 'tcp udp'
        option name 'vnc_WZ'
        option src_dport '5501'
        option dest_port '5501'
        option dest 'lan'
        option src 'wan'
        option dest_ip '192.168.0.207'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option dest_port '5501'
        option name 'vnc'
        option dest 'lan'
        option proto 'tcp udp'
        option dest_ip '192.168.0.207'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option src_dport '8888'
        option dest_port '8888'
        option name 'webcam1'
        option dest_ip '192.168.0.207'
        option enabled '0'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option src_dport '8081'
        option dest_port '8081'
        option name 'webcam2'
        option dest_ip '192.168.0.207'
        option enabled '0'

config redirect
        option target 'DNAT'
        option src 'newzone'
        option dest 'lan'
        option proto 'tcp udp'
        option enabled '0'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option dest_ip '192.168.0.207'
        option name 'vnc_wz2'
        option src_dport '5601'
        option dest_port '5601'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'tcp udp'
        option name 'realvnc2'
        option dest_ip '192.168.0.207'
        option dest_port '5601'
        option dest 'lan'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option src_dport '9'
        option dest_ip '192.168.0.207'
        option dest_port '9'
        option name 'teamviewer wol'

config rule
        option enabled '1'
        option target 'ACCEPT'
        option src 'wan'
        option dest 'lan'
        option name 'teamviewer wol'
        option dest_ip '192.168.0.207'
        option dest_port '9'

Thanks for all your help but now i am realy devastet, if my complete reset of the router wont work i even can not reach the web....
Thanks in Advance!

Test that you can reach the web by plugging your PC directly into the B618. If that does not work you need to resolve that before trying to set up the WNDR3700.

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
option mirror_source_port '0'      # Remove this line.
option mirror_monitor_port '0'     # Remove this line.

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 1t 2 3 4'  # likely should be '0t 2 3 4'  (but what happened to port 5?)

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'
option ports '0t 1t'    # likely should be '0t 1'

This switch configuration was wrong, but I don't know exactly how to fix it without a map of the WNDR3700v4.

How can i test that? direct copy-past in CMDER after root login?
Can i directly copy-Paste with your Comments?

Install nano on the router and use it to edit config files.

The only software you should need on the PC is a regular SSH client such as PuTTY, Tera Term, or the ssh that is built into late Windows 10.