Config igmpproxy to allow multicast udp from WAN to LAN

I assigned 10.0.0.100 to the WAN port and its connected to PC1 which has 10.0.0.50 which sends a stream 239.1.1.1:1234

I reset the router and copied this into igmpproxy config:

config igmpproxy
        option quickleave 1

config phyint
        option network wan
        option zone wan
        option direction upstream
        list altnet 0.0.0.0/0

config phyint
        option network lan
        option zone lan
        option direction downstream

Then I saved it and rebooted the router and I still can't view the stream.

Try quickleave 0.

Ok I tried . not working

The switch you are using in your test setup, does it have igmp snooping? Is it a managed switch? Are the upstream PC and the downstream router on the same vlan and able to talk to each other?

239.1.1.1 does not satisfy the 224.0.0.0/0 rule that igmpproxy automatically creates. Please send the multicast stream to an address that does. 224.x.x.x would be easiest :slight_smile:

1 Like

i removed the switch for testing. so i'm connected directly to the WAN. I will try a different address thanks

1 Like

I now tried 224.1.1.1:1234
still not working. when opening the stream i can see IGMPv2 in wireshark but the stream won't start.

Please use valid multicast IP addresses!

  • and put quickleave back to the default value if you have not done so

so which should i use ? do I need to enable igmp snooping on my router ?
quickleave has been set to 1

A valid IP. I don't know what your multicast server is doing - I assume streaming video. An IP from the adhoc block should work.

No one has mentioned it yet except you. We're suggesting you get igmpproxy setup first.; but you seem distracted with snooping and firewalls.

all I have done was installing igmpproxy and replaced the lines in /etc/config/igmpproxy with those posted above. So is it correctly setup now ?

Is your multicast working!?!?

no of course its not working. what do you mean ?

Again, you refused to answer me. We cant help if you keep making guesses - or forcing us to make them.

  • If not explain clearly what happened.
  • Also, you never said if you fixed the wrong multicast IP
  • What software are you using to run a multicast server
  • Explain its setup

If you're using VLC, I'll setup and test your exact config myself.

I'm using VLC. Select videofile, select stream UDP Legacy 233.252.0.0 onport 1234.
Opening with VLC udp://@233.252.0.0:1234
I used an AdHoc Block 3 Address
My Setup is just as I said. Just a PC on WAN and another PC on LAN. No Internet Connection.

:man_facepalming:

This isn't multicast - it's unicast. Why don't you setup multicast if you want the OpenWrt community to assist with igmpproxy???

From: https://wiki.videolan.org/Documentation:Streaming_HowTo/Easy_Streaming/

  • UDP : Stream in unicast by providing an address in the 0.0.0.0 - 223.255.255.255 range or in multicast by providing an address in the 224.0.0.0 - 239.255.255.255 range. It is also possible to stream to IPv6 addresses. Note: This will only work with the TS encapsulation method.

Also see:

https://wiki.videolan.org/Documentation:Streaming_HowTo/Advanced_streaming_with_samples,_multiple_files_streaming,_using_multicast_in_streaming/

Not sure this is valid, can the last two octets be 0? try 233.252.0.1

1 Like

Sorry thats completely new to me . So I need to use RTP ? because I tried multicasting in bridged mode and it worked with UDP.

If you were in bridge mode, you weren't multicasting.

@mickey84, I really think you need to review the VLC documentation on setting up a multicast stream.

  • I don't feel comfortable assisting with the non-OpenWrt portions of your setup (in fact, it's off topic)
  • It's also clear you have not setup your multicast stream correctly yet, so there's nothing for me to setup and test using igmpproxy at this time

See:

I tried exactly like in th video. I also tried different addresses and ports. It's not working.