Compiling 23.05 error

Any reason that I can compile 22.03.5 fine but yet when I compile 23.05 I get this error below? Looks like some sort of /libs/wolfssl error? Is there some library I would need? Any information would help, thank you!

sr/lib/pkgconfig/.pc /home/wtiadmin/OpenWRTNew/tmp/stage-wolfssl/usr/lib/pkgconfig
find /home/wtiadmin/OpenWRTNew/tmp/stage-wolfssl -name '
.la' | xargs -r rm -f;
if [ -f /home/wtiadmin/OpenWRTNew/staging_dir/target-mipsel_24kc_musl/packages/wolfssl.regular.list ]; then /home/wtiadmin/OpenWRTNew/scripts/clean-package.sh "/home/wtiadmin/OpenWRTNew/staging_dir/target-mipsel_24kc_musl/packages/wolfssl.regular.list" "/home/wtiadmin/OpenWRTNew/staging_dir/target-mipsel_24kc_musl"; fi
if [ -d /home/wtiadmin/OpenWRTNew/tmp/stage-wolfssl ]; then (cd /home/wtiadmin/OpenWRTNew/tmp/stage-wolfssl; find ./ > /home/wtiadmin/OpenWRTNew/tmp/stage-wolfssl.files); SHELL= flock /home/wtiadmin/OpenWRTNew/tmp/.staging-dir.flock -c ' mv /home/wtiadmin/OpenWRTNew/tmp/stage-wolfssl.files /home/wtiadmin/OpenWRTNew/staging_dir/target-mipsel_24kc_musl/packages/wolfssl.regular.list && cp -fpR /home/wtiadmin/OpenWRTNew/tmp/stage-wolfssl/* /home/wtiadmin/OpenWRTNew/staging_dir/target-mipsel_24kc_musl/; '; fi
rm -rf /home/wtiadmin/OpenWRTNew/tmp/stage-wolfssl
touch /home/wtiadmin/OpenWRTNew/staging_dir/target-mipsel_24kc_musl/stamp/.wolfssl.regular_installed
make[3]: Leaving directory '/home/wtiadmin/OpenWRTNew/package/libs/wolfssl'
time: package/libs/wolfssl/regular/compile#116.47#14.65#91.27
make[2]: Leaving directory '/home/wtiadmin/OpenWRTNew'
make[1]: *** [package/Makefile:123: /home/wtiadmin/OpenWRTNew/staging_dir/target-mipsel_24kc_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/wtiadmin/OpenWRTNew'
make: *** [/home/wtiadmin/OpenWRTNew/include/toplevel.mk:233: world] Error 2

Are you using multi thread compilation? Make -j ?
If so, the actual error is likely much earlier in the log.
Run single threaded to see the actual error.

2 Likes

than you very much! ya, now it shows something wrong with .js in the luci-mod-status page.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.