Compile with new kernel

A recent commit introduced kernel 4.9 support for ar71xx target
https://github.com/lede-project/source/commit/7bbf4117c6fe4b764d9d7c62fb2bcf6dd93bff2c

I have a TP-LINK WR841ND that is ar71xx.

I pulled, compiled and flashed, but with uname -a i receive 4.4.91.

So, how can I compile the firmware with 4.9 kernel?

Check file

less target/linux/ar71xx/Makefile

for

KERNEL_PATCHVER:=4.9

thank you!
Do you know why it is not editable from make menuconfig?

Because generally there is just one supported kernel major version for a target.

There are several versions only during version bump testing phase. Then it is assumed that if you want to change it, you need to understand the build system well enough to be able to edit the correct file by yourself.