Compilation fail for the oui UI library (bpi openwrt version)

Hello,
I've been dwelling on this for days now and i hope someone can help me with this as i am very new to openwrt.
So i tried to compile an openwrt image for bananapi including the oui UI library from github:

but the compilation keeps failing with this error:

Collected errors:

 * satisfy_dependencies_for: Cannot satisfy the following dependencies for oui-rpc-core:
 * 	lua-cjson * 
 * opkg_install_cmd: Cannot install package oui-rpc-core.
package/Makefile:64: recipe for target 'package/install' failed
make[2]: *** [package/install] Error 255
make[2]: Leaving directory '/home/oledcomm/bpi-r2_lede'
package/Makefile:106: recipe for target '/home/oledcomm/bpi-r2_lede/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.package_install' failed
make[1]: *** [/home/oledcomm/bpi-r2_lede/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.package_install] Error 2
make[1]: Leaving directory '/home/oledcomm/bpi-r2_lede'
/home/oledcomm/bpi-r2_lede/include/toplevel.mk:207: recipe for target 'world' failed
make: *** [world] Error 2

Knowing i already installed lua and lua-cjson package on my ubuntu machine and the library seem to get the lua package well but not the lua-cjson.
I asked the oui library developer on github but he said it's not related to his library (with no further explanations).
if it can help i use a 17.10 ubuntu system to compile

I ended up solving the problem :slight_smile:
if it can help anyone i switched my Openwrt os version to 18.06.2 and the Oui library worked well on that.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.