Compilation Error: staging_dir/host/bin/usign No Such File

#1

Hello,
I am a beginner here, and while trying to compile a minimal firmware i ran into this issue:
openwrt-error

I can't find anything about it on google & forums so i am asking on this forum.

0 Likes

#2

usign should be downloaded after make at some point

  • What repo did you clone from?

Do you have the correct items added to your ~/.bashrc

  • Execute the following if not:
    --- EDIT: Not needed, see @hnyman's post below ---

  • Re-sync buildroot, run menuconfig, then try make again

    • Save before exiting menuconfig, even if you didn't change anything
      git pull && ./scripts/feeds update -a && ./scripts/feeds install -a
      make MENUCONFIG_COLOR=blackbg menuconfig && make V=s
      
0 Likes

#3

I have never added anything to .bashrc, so those items might help, but they should not be required or even needed.

1 Like

#4

It should be enough to run the make commands from the cloned repo directory, so your error seems peculiar.

Normal clone?
Normal/usual Linux host variant, nothing exotic or ancient?

0 Likes

#5

When did this change, as it used to be a prereq in the Build System Usage wiki?

  • It was removed from the Build System Usage wiki as of revision 1482081157, whereas in all versions prior (revision 1481380145 and earlier), it was a prereq
    • Reasoning given [~/.bashrc additions] in the wiki was
      "The build spawns multiple shells, some of which expect the toolchain binaries to be present in the PATH."
0 Likes

#6

No idea what has been recently in the wiki, but I have been building Openwrt/LEDE since 2011 and have so far never set the .bashrc

I have simply created a new virtual Ubuntu host every three months, installed the prerequisite packages, cloned the main repo and that has been enough for building the firmware.

0 Likes

#7

Good to know =]

I can remove some lines from my Ubuntu lede-build.sh then =]

0 Likes

#8

Yeah, the benefit and problem with wikis is that everybody can edit them, so sometimes the advice goes too deep or has items tweaked toward somebody's own preferences or system peculiarities.

Ps. you can see my own build script collection at Build scripts that document changes and enable easy re-creation of build environment
"newBuildroot.sh" creates the whole repo with patches into a clean Ubuntu host, and no changes are done to PATH and other variables.

0 Likes

#9

I had no experience compiling before I began compiling OpenWrt in 2015, so I relied heavily on the Build System Install, Usage, and recently the Build Environment, wikis to get me started.

  • Since I run multiple VMs which use Bash, I have a master bashrc that I copy between all, editing when need be, and I've never tried building without those in my bashrc. It never occurred to me to check and see if any of the information had changed in the Build System Usage wiki.

Thanks for your thread link, it's quite informative =] I have a couple of questions about your newBuildroot.sh, however I'll ask them in your thread.

  • Nvm, found the answers in your WNDR3700 build thread
0 Likes

#10

Well, i think it was just my fault.

The clone was normal and i am using ubuntu xenial and LSW (windows bash). I tried multiple times both ways and i got the same error. Also i didn't say that this happened only in the x86_64 configuration.

Finally, i noticed the package usign was not checked in menuconfig. I hope i unchecked it without noticing and it is not something more complex.
(I didn't even know it is a package that has to be compiled)

Thank you at least for giving me some ideas :smile:

0 Likes