¿Como instalar OpenWrt C50 por primera vez?

Greetings people from the forum,

Excuse me, I do not speak English so the translation will be done by Google.

I bought a new Archer C50 V1 and tried to install the OpenWRT.

The firmware in particular is ArcherC50v1-squashfs-factory-eu.bin from the address http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/

Try two ways from the web of the original firmware via firmware upgrade, it did not work, apparently the router was entering BootLoop, solve it (Debrick) by cutting with DD the original TPLink firmware and using the recovery method via TFTP.
Then I used the same OpenWRT firmware (as it was downloaded) and I used the recovery method via TFTP but it was worse, now the router sent an orange light and then it turned off completely, I could not bring it back to life so I took the hand of the guarantee and accepted the change.

Now I have a C50 again I would like to know how to install this OpenWRT for the first time to this router ?.

Thank you very much for your help

Saludos gente del foro,

He comprado un Archer C50 V1 nuevo y trate de instalar el OpenWRT.

El firmware en concreto es ArcherC50v1-squashfs-factory-eu.bin de la direccion http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/

Trate por dos maneras desde la web del firmware original via firmware upgrade, no funciono, aparentemente el router se entraba en BootLoop, lo solucione (Debrick) recortando con DD el firmware original de TPLink y usando el metodo recovery via TFTP.
Luego use el mismo firmware de OpenWRT (tal cual lo descargue) y use el metodo recovery via TFTP pero fue peor, ahora el router mandaba una luz naranja y luego se apagaba por completo, no pude volverlo a la vida asi que heche mano de la garantia y aceptaron el cambio.

Ahora tengo nuevamente un C50 quisiera saber ¿como se instala por primera vez el OpenWRT a este router?.

Muchas gracias por su ayuda

When writing in your native language, please always provide an english translation.
This way other users all around the world can take part in the discussion and possibly benefit from the outcome, without having to use a translator.

Follow the official guide
TP-Link Archer C50

Other Guide
Installing OpenWRT in TPLink Archer C50

Thanks for the help, sorry but I do not speak English, so the translation will google it.

The two links make use of the TFTP method but speak of a file "ArcherC50V1_tp_recovery.bin from web-ui" that is old, since it is built by a user, currently OpenWRT v18.06.1 is supposed to have official support to C50 v1, but As I said the file ArcherC50v1-squashfs-factory-eu.bin produces a brick via TFTP, where I get (or how do I build?) the recovery file of version 18.06.1 of OpenWRT for C50

Gracias por la ayuda, disculpen pero no hablo ingles, asi que la traduccion la hara google.

Los dos links hacen uso del metodo TFTP pero hablan de un archivo "ArcherC50V1_tp_recovery.bin from web-ui" que es antiguo, ya que es construido por un usuario, actualmente OpenWRT v18.06.1 se supone que tiene soporte oficial al C50 v1, pero como ya dije el archivo ArcherC50v1-squashfs-factory-eu.bin produce un brick via TFTP, donde consigo (o ¿como construyo?) el archivo recovery de la version 18.06.1 de OpenWRT para C50

You can indicate which model and version of roouter you have
Puedes indicar que modelo y versión de router tienes


My router is an Archer C50 V1 EU, it has the latest TPLink firmware

Thanks for the help.


Mi router es un Archer C50 V1 EU, tiene el ultimo firmware de TPLink

Gracias por la ayuda.

You already checked this topic in the forum
LEDE on TP-Link Archer C50, but the install Instructions is in polish

Well, I was able to update my new Archer C50 to OpenWRT, I'll show you how:

  1. First I started from an Archer C50v1 EU with TPLINK stock firmware (the last version as I could verify).
  2. Then update to OpenWRT using TFTP recovery, using the firmware ArcherC50V1_tp_recovery.bin (https://mega.nz/#!fFAmHBiA!cHmp9pE5z3r9T3C2wuM665QzEx7DiF04Xf1MBbqI_9g) which is from Chaos Calmer version 15.05, I do not know if there will be a more recent version of the recovery ( 11/20/2018).
  3. Then use the firmware of the official OpenWRT page ArcherC50v1-squashfs-sysupgrade.bin (http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/) to update via LuCi (web) the firmware.

With those steps I have everything ready, remember step 2 is done through RECOVERY TFTP and with a firmware for recovery not what is published on the official website of OPENWRT.

Greetings and thanks to all.

Bueno, ya pude actualizar mi nuevo Archer C50 a OpenWRT, paso a indicarles como:

  1. En primer yo parti de un Archer C50v1 EU con firmware stock TPLINK (la ultima version segun pude verificar).
  2. Luego actualice a OpenWRT mediante recovery TFTP, usando el firmware ArcherC50V1_tp_recovery.bin (https://mega.nz/#!fFAmHBiA!cHmp9pE5z3r9T3C2wuM665QzEx7DiF04Xf1MBbqI_9g) que es de la version Chaos Calmer 15.05, ignoro si habra una version mas reciente del recovery (20/11/2018).
  3. Luego utilice el firmware de la pagina oficial de OpenWRT ArcherC50v1-squashfs-sysupgrade.bin (http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/) para actualizar via LuCi (web) el firmware.

Con esos pasos ya tengo todo listo, recuerden el paso 2 se hace mediante RECOVERY TFTP y con un firmware para recovery no el quue se publica en la pagina oficial de OPENWRT.

Saludos y gracias a todos.

@ TheRoot
I can confirm that your procedure worked for me as well on my C50 V1 EU-version.

Thanks a lot!

I'd like to know the same.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.