Communication between zones

Hello,

I’m new to this forum. I just got a used Netgear R6100 router and installed OpenWRT on it. I have at the moment built my system in a way where my Netgear is attached to ISP router via ethernet cable. Now I’m trying to setup as follows (see first picture below): basically I want to have two wireless networks, one for my IoT (192.168.2.1) devices and the other one for Home (192.168.1.1). The one for the IoT devices shouldn’t have access to the Internet but it should be accessible from Home network. Home network should have access to the Internet.

I have managed to setup two wireless networks but haven’t found a way to even ping between them. I tried to open it up through firewall settings but have not succeeded. How should this be configurated? Should I take into consideration subnet masks? I have read quite many posts where there has been told how to do similar scenarios with the command line but I would really appreciate if there could be a way to do this through LuCI. I have also added pictures of my firewall settings and of the first of all thing I’m trying to achieve aka get a ping going between the networks.

Thanks for your time in advance!

Samu

1 Like

And here is the second picture

And the third

are the wireless APs assigned to an interface? You should create an interface for the iot wireless and assing it to the iot firewall zone

Please post here the output of the following commands, copy and paste the whole block:

uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro ls tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro ls tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*

Please use the "Preformatted text </>" button for logs, scripts, configs and general console output.
grafik
Please edit your post accordingly. Thank you! :slight_smile:

I SSH into the router and took the logs you asked for. Hope these are right ones and will help solving this problem. Thanks, Samu

login as: root


BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.2, r10947-65030d81f3
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# uci export network; uci export wireless; \
>
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd76:202d:16d8::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config interface 'IoT'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'xxxxxxxx'
        option ssid 'Home'
        option encryption 'psk2'

config wifi-iface 'wifinet2'
        option ssid 'IoT'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'ap'
        option network 'IoT'
        option key 'xxxxxxx'

root@OpenWrt:~# uci export dhcp; uci export firewall; \
> head -n -0 /etc/firewall.user; \
> ip -4 addr ; ip -4 ro ls tab all ; ip -4 ru; \
> ip -6 addr ; ip -6 ro ls tab all ; ip -6 ru; \
> ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*
package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'IoT'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'IoT'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option input 'ACCEPT'
        option forward 'REJECT'
        option name 'IoT'
        option output 'ACCEPT'

config forwarding
        option dest 'lan'
        option src 'IoT'

config forwarding
        option dest 'IoT'
        option src 'lan'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
9: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.2.1/24 brd 192.168.2.255 scope global wlan1-1
       valid_lft forever preferred_lft forever
ip: invalid argument 'ls' to 'ip'
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::deef:9ff:fef2:4b70/64 scope link
       valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd76:202d:16d8::1/60 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::deef:9ff:fef2:4b70/64 scope link
       valid_lft forever preferred_lft forever
8: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::deef:9ff:fef2:4b70/64 scope link
       valid_lft forever preferred_lft forever
9: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::dcef:9ff:fef2:4b70/64 scope link
       valid_lft forever preferred_lft forever
ip: invalid argument 'ls' to 'ip'
0:      from all lookup local
32766:  from all lookup main
4200000001:     from all iif lo lookup unspec 12
4200000006:     from all iif br-lan lookup unspec 12
4200000009:     from all iif wlan1-1 lookup unspec 12
lrwxrwxrwx    1 root     root            16 Feb 27 21:05 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            32 Feb 27 21:12 /tmp/resolv.conf
-rw-r--r--    1 root     root             0 Feb 27 21:05 /tmp/resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.auto <==

Could you please run again a couple of commands which failed?
ip -4 ro
Also let's see the firewall configuration iptables-save -c
So far I can't spot anything wrong.

login as: root


BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.2, r10947-65030d81f3
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# ip -4 ro
192.168.1.0/24 dev br-lan scope link  src 192.168.1.1
192.168.2.0/24 dev wlan1-1 scope link  src 192.168.2.1
root@OpenWrt:~# iptables-save -c
# Generated by iptables-save v1.8.3 on Thu Feb 27 21:15:24 2020
*nat
:PREROUTING ACCEPT [980:139215]
:INPUT ACCEPT [296:19310]
:OUTPUT ACCEPT [17:1396]
:POSTROUTING ACCEPT [17:1396]
:postrouting_IoT_rule - [0:0]
:postrouting_lan_rule - [0:0]
:postrouting_rule - [0:0]
:postrouting_wan_rule - [0:0]
:prerouting_IoT_rule - [0:0]
:prerouting_lan_rule - [0:0]
:prerouting_rule - [0:0]
:prerouting_wan_rule - [0:0]
:zone_IoT_postrouting - [0:0]
:zone_IoT_prerouting - [0:0]
:zone_lan_postrouting - [0:0]
:zone_lan_prerouting - [0:0]
:zone_wan_postrouting - [0:0]
:zone_wan_prerouting - [0:0]
[980:139215] -A PREROUTING -m comment --comment "!fw3: Custom prerouting rule ch                                                      ain" -j prerouting_rule
[980:139215] -A PREROUTING -i br-lan -m comment --comment "!fw3" -j zone_lan_pre                                                      routing
[0:0] -A PREROUTING -i eth0 -m comment --comment "!fw3" -j zone_wan_prerouting
[17:1396] -A POSTROUTING -m comment --comment "!fw3: Custom postrouting rule cha                                                      in" -j postrouting_rule
[2:376] -A POSTROUTING -o br-lan -m comment --comment "!fw3" -j zone_lan_postrou                                                      ting
[0:0] -A POSTROUTING -o eth0 -m comment --comment "!fw3" -j zone_wan_postrouting
[0:0] -A zone_IoT_postrouting -m comment --comment "!fw3: Custom IoT postrouting                                                       rule chain" -j postrouting_IoT_rule
[0:0] -A zone_IoT_prerouting -m comment --comment "!fw3: Custom IoT prerouting r                                                      ule chain" -j prerouting_IoT_rule
[2:376] -A zone_lan_postrouting -m comment --comment "!fw3: Custom lan postrouti                                                      ng rule chain" -j postrouting_lan_rule
[980:139215] -A zone_lan_prerouting -m comment --comment "!fw3: Custom lan prero                                                      uting rule chain" -j prerouting_lan_rule
[0:0] -A zone_wan_postrouting -m comment --comment "!fw3: Custom wan postrouting                                                       rule chain" -j postrouting_wan_rule
[0:0] -A zone_wan_postrouting -m comment --comment "!fw3" -j MASQUERADE
[0:0] -A zone_wan_prerouting -m comment --comment "!fw3: Custom wan prerouting r                                                      ule chain" -j prerouting_wan_rule
COMMIT
# Completed on Thu Feb 27 21:15:24 2020
# Generated by iptables-save v1.8.3 on Thu Feb 27 21:15:24 2020
*mangle
:PREROUTING ACCEPT [1250:160997]
:INPUT ACCEPT [566:41092]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [469:35967]
:POSTROUTING ACCEPT [469:35967]
[0:0] -A FORWARD -o eth0 -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comm                                                      ent "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
COMMIT
# Completed on Thu Feb 27 21:15:24 2020
# Generated by iptables-save v1.8.3 on Thu Feb 27 21:15:24 2020
*filter
:INPUT ACCEPT [0:0]
:FORWARD DROP [0:0]
:OUTPUT ACCEPT [0:0]
:forwarding_IoT_rule - [0:0]
:forwarding_lan_rule - [0:0]
:forwarding_rule - [0:0]
:forwarding_wan_rule - [0:0]
:input_IoT_rule - [0:0]
:input_lan_rule - [0:0]
:input_rule - [0:0]
:input_wan_rule - [0:0]
:output_IoT_rule - [0:0]
:output_lan_rule - [0:0]
:output_rule - [0:0]
:output_wan_rule - [0:0]
:reject - [0:0]
:syn_flood - [0:0]
:zone_IoT_dest_ACCEPT - [0:0]
:zone_IoT_dest_REJECT - [0:0]
:zone_IoT_forward - [0:0]
:zone_IoT_input - [0:0]
:zone_IoT_output - [0:0]
:zone_IoT_src_ACCEPT - [0:0]
:zone_lan_dest_ACCEPT - [0:0]
:zone_lan_forward - [0:0]
:zone_lan_input - [0:0]
:zone_lan_output - [0:0]
:zone_lan_src_ACCEPT - [0:0]
:zone_wan_dest_ACCEPT - [0:0]
:zone_wan_dest_REJECT - [0:0]
:zone_wan_forward - [0:0]
:zone_wan_input - [0:0]
:zone_wan_output - [0:0]
:zone_wan_src_REJECT - [0:0]
[125:8508] -A INPUT -i lo -m comment --comment "!fw3" -j ACCEPT
[444:32704] -A INPUT -m comment --comment "!fw3: Custom input rule chain" -j inp                                                      ut_rule
[36:3420] -A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comme                                                      nt "!fw3" -j ACCEPT
[1:52] -A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m comment --comme                                                      nt "!fw3" -j syn_flood
[408:29284] -A INPUT -i br-lan -m comment --comment "!fw3" -j zone_lan_input
[0:0] -A INPUT -i eth0 -m comment --comment "!fw3" -j zone_wan_input
[0:0] -A FORWARD -m comment --comment "!fw3: Custom forwarding rule chain" -j fo                                                      rwarding_rule
[0:0] -A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment                                                       "!fw3" -j ACCEPT
[0:0] -A FORWARD -i br-lan -m comment --comment "!fw3" -j zone_lan_forward
[0:0] -A FORWARD -i eth0 -m comment --comment "!fw3" -j zone_wan_forward
[0:0] -A FORWARD -m comment --comment "!fw3" -j reject
[125:8508] -A OUTPUT -o lo -m comment --comment "!fw3" -j ACCEPT
[349:28379] -A OUTPUT -m comment --comment "!fw3: Custom output rule chain" -j o                                                      utput_rule
[346:27657] -A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --co                                                      mment "!fw3" -j ACCEPT
[3:722] -A OUTPUT -o br-lan -m comment --comment "!fw3" -j zone_lan_output
[0:0] -A OUTPUT -o eth0 -m comment --comment "!fw3" -j zone_wan_output
[0:0] -A reject -p tcp -m comment --comment "!fw3" -j REJECT --reject-with tcp-r                                                      eset
[0:0] -A reject -m comment --comment "!fw3" -j REJECT --reject-with icmp-port-un                                                      reachable
[1:52] -A syn_flood -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m limit --lim                                                      it 25/sec --limit-burst 50 -m comment --comment "!fw3" -j RETURN
[0:0] -A syn_flood -m comment --comment "!fw3" -j DROP
[0:0] -A zone_IoT_forward -m comment --comment "!fw3: Custom IoT forwarding rule                                                       chain" -j forwarding_IoT_rule
[0:0] -A zone_IoT_forward -m comment --comment "!fw3: Zone IoT to lan forwarding                                                       policy" -j zone_lan_dest_ACCEPT
[0:0] -A zone_IoT_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3                                                      : Accept port forwards" -j ACCEPT
[0:0] -A zone_IoT_forward -m comment --comment "!fw3" -j zone_IoT_dest_REJECT
[0:0] -A zone_IoT_input -m comment --comment "!fw3: Custom IoT input rule chain"                                                       -j input_IoT_rule
[0:0] -A zone_IoT_input -m conntrack --ctstate DNAT -m comment --comment "!fw3:                                                       Accept port redirections" -j ACCEPT
[0:0] -A zone_IoT_input -m comment --comment "!fw3" -j zone_IoT_src_ACCEPT
[0:0] -A zone_IoT_output -m comment --comment "!fw3: Custom IoT output rule chai                                                      n" -j output_IoT_rule
[0:0] -A zone_IoT_output -m comment --comment "!fw3" -j zone_IoT_dest_ACCEPT
[3:722] -A zone_lan_dest_ACCEPT -o br-lan -m comment --comment "!fw3" -j ACCEPT
[0:0] -A zone_lan_forward -m comment --comment "!fw3: Custom lan forwarding rule                                                       chain" -j forwarding_lan_rule
[0:0] -A zone_lan_forward -m comment --comment "!fw3: Zone lan to wan forwarding                                                       policy" -j zone_wan_dest_ACCEPT
[0:0] -A zone_lan_forward -m comment --comment "!fw3: Zone lan to IoT forwarding                                                       policy" -j zone_IoT_dest_ACCEPT
[0:0] -A zone_lan_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3                                                      : Accept port forwards" -j ACCEPT
[0:0] -A zone_lan_forward -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[408:29284] -A zone_lan_input -m comment --comment "!fw3: Custom lan input rule                                                       chain" -j input_lan_rule
[0:0] -A zone_lan_input -m conntrack --ctstate DNAT -m comment --comment "!fw3:                                                       Accept port redirections" -j ACCEPT
[408:29284] -A zone_lan_input -m comment --comment "!fw3" -j zone_lan_src_ACCEPT
[3:722] -A zone_lan_output -m comment --comment "!fw3: Custom lan output rule ch                                                      ain" -j output_lan_rule
[3:722] -A zone_lan_output -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[408:29284] -A zone_lan_src_ACCEPT -i br-lan -m conntrack --ctstate NEW,UNTRACKE                                                      D -m comment --comment "!fw3" -j ACCEPT
[0:0] -A zone_wan_dest_ACCEPT -o eth0 -m conntrack --ctstate INVALID -m comment                                                       --comment "!fw3: Prevent NAT leakage" -j DROP
[0:0] -A zone_wan_dest_ACCEPT -o eth0 -m comment --comment "!fw3" -j ACCEPT
[0:0] -A zone_wan_dest_REJECT -o eth0 -m comment --comment "!fw3" -j reject
[0:0] -A zone_wan_forward -m comment --comment "!fw3: Custom wan forwarding rule                                                       chain" -j forwarding_wan_rule
[0:0] -A zone_wan_forward -p esp -m comment --comment "!fw3: Allow-IPSec-ESP" -j                                                       zone_lan_dest_ACCEPT
[0:0] -A zone_wan_forward -p udp -m udp --dport 500 -m comment --comment "!fw3:                                                       Allow-ISAKMP" -j zone_lan_dest_ACCEPT
[0:0] -A zone_wan_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3                                                      : Accept port forwards" -j ACCEPT
[0:0] -A zone_wan_forward -m comment --comment "!fw3" -j zone_wan_dest_REJECT
[0:0] -A zone_wan_input -m comment --comment "!fw3: Custom wan input rule chain"                                                       -j input_wan_rule
[0:0] -A zone_wan_input -p udp -m udp --dport 68 -m comment --comment "!fw3: All                                                      ow-DHCP-Renew" -j ACCEPT
[0:0] -A zone_wan_input -p icmp -m icmp --icmp-type 8 -m comment --comment "!fw3                                                      : Allow-Ping" -j ACCEPT
[0:0] -A zone_wan_input -p igmp -m comment --comment "!fw3: Allow-IGMP" -j ACCEP                                                      T
[0:0] -A zone_wan_input -m conntrack --ctstate DNAT -m comment --comment "!fw3:                                                       Accept port redirections" -j ACCEPT
[0:0] -A zone_wan_input -m comment --comment "!fw3" -j zone_wan_src_REJECT
[0:0] -A zone_wan_output -m comment --comment "!fw3: Custom wan output rule chai                                                      n" -j output_wan_rule
[0:0] -A zone_wan_output -m comment --comment "!fw3" -j zone_wan_dest_ACCEPT
[0:0] -A zone_wan_src_REJECT -i eth0 -m comment --comment "!fw3" -j reject
COMMIT
# Completed on Thu Feb 27 21:15:24 2020
root@OpenWrt:~#

Do you mind trying changing all instances of IoT to all-lower-case iot and see if this will solve it.

2 Likes

I don't see any iptables rule to send traffic from INPUT/FORWARD/OUTPUT chain to zone_IoT_*
Run the fw3 restart and check the beginning for any errors.
It is possible that mixed capitals and small characters in interface name can cause the issue.

2 Likes

Hi guys! The problem has been solved. It was the capital letters, as you suggested. Now everything is working as it is supposed to. I'm gradually starting to grow my love/hate relationship with this software. Thanks for the help!

2 Likes

Come oooon xD, that would have driven crazy before I could figure it out :smile:

So the interface and zone names should be lower case

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.