Comfast cf-e5 lte modem

I bought this comfast with an integrated lte module. I have compiled and added only luci as extra. after a reset, openwrt works. but I can't get the lte modem to work, I have tried 3 sim.what there is to install to make the modem part work?

  • Is this LTE modem carrier locked?
  • If so, are you using a SIM from that company?

  • Also, can you confirm that the carriers whose SIMs you're using - offers their service on a listed band.
  • It seems there may be different cellular modules in the device, depending on carrier/region, verify your EC25 modem is for your region

See, to start https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle

1 Like

yes my version is for europe bands . the strange here is that after uqmi command, it say connected, but no internet access. so that's why now i
reseted it to default. and i'll like understand the packages needed.

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-data-status
"connected"
root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
{
        "type": "lte",
        "rssi": -83,
        "rsrq": -17,
        "rsrp": -121,
        "snr": -80
}
root@OpenWrt:~# 

...and your Interface settings?

i resetted it again i'll start again. i really like know the protocol to use and the right packages to install. every guide is about usb devices.

EC25 IS usb device... uqmi (you already have it), in network config set proto to qmi

config 'interface' 'wan'
  option 'proto' 'qmi'
  option 'device' '/dev/cdc-wdm0'
  option 'pincode' '1234' #<<<- set yours
  option 'apn' 'internet' #<<<- set yours

this is really driving me crazy, i tried that but it's not working. so i need edit the wan interface? no wwan interface needed? also before i plugged the card into the comfast i disabled the pin with my phone. could be that the problem?

wan, wwan or mobile/lte/sthelse - it does not matter if you configure firewall later. If you don't have a pin, you just don't do the pincode option.

i'm really confuse, i reinstalled the comfast firmware and still not working. i have no idea what to do

Please install the latest OpenWrt and luci-proto-qmi, add QMI interface from Luci.
Make sure you put correct APN in the settings.
Navigate to this interface Firewall Settings and assign to WAN zone.

i reinstalled openwrt, installed luci-proto-qmi, i get an ipv4 address, also after i create a wwan interface qmi cellular, the sistem create an interface called wwan_4 Virtual dynamic interface (DHCP client) , but i can't even edit this interface, it's not in red like the others interface, it's white and it's the interface that get the ipv4 addres

you don't need to edit anything

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdfb:6488:ac05::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth1'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config interface 'wwan2'
	option proto 'dhcp'

config interface 'wwan'
	option proto 'qmi'
	option device '/dev/cdc-wdm0'
	option apn 'web.ho-mobile.it'
	option auth 'none'

This means it's likely not in a firewall zone. I'm apprehensive to make a suggestion if it's working though; but you could simply add it to WAN (as long as everything is still set to defaults).

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6 wwan2 wwan'

config forwarding
	option src 'lan'
	option dest 'wan'
root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
{
        "type": "lte",
        "rssi": -85,
        "rsrq": -16,
        "rsrp": -114,
        "snr": 52
}
root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-data-status
"connected"
root@OpenWrt:~# 

Why you keep posting all this information?
Your modem is "connected", you have "the interface that get the ipv4 addres" - what is your problem now? I see none.

1 Like

not working, no internet access