ComFast CF-926AC V2 with OpenWrt?

I purchased an adapter, ComFast CF-926AC V2 (MT7612U chip with in-kernel 4.19+ drivers) to be used with a Raspberry Pi 4B.

To make sure the adapter is functional, I installed RaspiOS Lite (64bits) and the new wlan1 interface is detected right away on a clean install, no need for any drivers:

# ip a show wlan1
11: wlan1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether e0:e1:a9:17:37:2f brd ff:ff:ff:ff:ff:ff

# inxi -N
Network:   Device-1: MediaTek MT7612U 802.11a/b/g/n/ac Wireless Adapter type: USB driver: mt76x2u

Next, I installed openwrt-22.03.2-bcm27xx-bcm2711-rpi-4-squashfs-factory.img.gz for Pi 4B and configured the initial setup (wwan and wireless to update the OS):

/etc/config/network

# cat /etc/config/network
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd2:5e70:072e::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '10.10.100.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option force_link '1'

config interface 'wwan'
	option proto 'dhcp'
	option peerdns '0'
	option dns '1.1.1.1'

Set option input to ACCEPT for wan zone in /etc/config/firewall:

# grep "option name 'wan'" -B1 -A8 /etc/config/firewall
config zone
	option name 'wan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'
	list network 'wan6'
	list network 'wwan'

OS update, note the weird output for 0e8d:2870 which is the MediaTek MT7612U WiFi adapter:

# opkg update
# opkg install kmod-mt76x2u kmod-usb3 usbutils
# reboot

# lsusb
Bus 001 Device 003: ID 0e8d:2870 Љ Љ
Bus 002 Device 001: ID 1d6b:0003 Linux 5.10.146 xhci-hcd xHCI Host Controller
Bus 001 Device 002: ID 2109:3431  USB2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.146 xhci-hcd xHCI Host Controller

# dmesg | grep 'usb 1-1.2'
[    1.501429] usb 1-1.2: new high-speed USB device number 3 using xhci_hcd
[    1.682515] usb 1-1.2: New USB device found, idVendor=0e8d, idProduct=2870, bcdDevice= 0.01
[    1.690868] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    1.698181] usb 1-1.2: Product: Љ
[    1.701581] usb 1-1.2: Manufacturer: Љ
[    1.705410] usb 1-1.2: SerialNumber: Љ

The WiFi adapter wlan1 is missing:

# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether e4:5f:01:a0:55:36 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether e4:5f:01:a0:55:37 brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.16/27 brd 192.168.2.31 scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::e65f:1ff:fea0:5537/64 scope link
       valid_lft forever preferred_lft forever
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether e4:5f:01:a0:55:36 brd ff:ff:ff:ff:ff:ff
    inet 10.10.100.1/24 brd 10.10.100.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fdd2:5e70:72e::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::e65f:1ff:fea0:5536/64 scope link
       valid_lft forever preferred_lft forever

I'm stuck, I don't know how to proceed. Thank you for your help.

You might need modeswitch Usb-mode.json Github repository to mantain an updated file