Comcast/WRT1900ACS only half of expected speed

I am at my wits end.

I have Internet service from Comcast, and a Motorola MB6800 cable modem. Using a direct, wired connection between my PC and modem, I get about 175MB/s which is what Comcast says we should have. I add the Linksys WRT1900ACS in the path and the speed drops down to about 80-90MB/s.

What is strange is that earlier this year, we were getting 150MB/s from Comcast, which is/was our advertised rate. At some point during the year, and I don't know when, the speed dropped by a factor of two. I'm just now trying to find out why.

I had previously been running this firmware, installed on the date shown:

Aug 19  2018 openwrt-18.06.1-mvebu-cortexa9-linksys-wrt1900acs-squashfs-sysupgrade.bin
Jan 30  2019 openwrt-18.06.2-mvebu-cortexa9-linksys-wrt1900acs-squashfs-sysupgrade.bin
Jul  04 2019 openwrt-18.06.4-mvebu-cortexa9-linksys-wrt1900acs-squashfs-sysupgrade.bin

I don't know what could have changed that broke things. I tried the latest developer snapshot, but I can't seem to go backward to a previous 18.06.xx release - Luci won't let me log in, but my ssh connection is working fine.

I've disabled the WiFi ports in the router. I've pulled out all the clients except for this PC. I am not running SQM presently, because I did a clean install of the developer snapshot.

Here's a copy of my network configuation:

Hostname:  LEDE
Model:  Linksys WRT1900ACS
Architecture:  ARMv7 Processor rev 1 (v7l)
Firmware Version:  OpenWrt SNAPSHOT r11189-33dd522f24 / LuCI Master (git-19.283.61921-dd6818e)
Kernel Version:  4.19.78
root@LEDE:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd42:8399:e947::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6'

Any suggestions as to what I can try to debug this? Thanks!!!!

I forgot to mention, I ran "top" on the router while running Speedtest, and the processor hardly blinked.

Have you checked that your modem is actually connected to your 1900ACS via "gigabit ethernet" and not "fast ethernet". I had a case where my modem did a fallback to 100Mbps at some point due some energy saving options (was called AutoGreen Ethernet or something like that). I was able to disable that option and never had this problem again...

1 Like

Have you tried enabling hardware flow offloading? I have it enabled and on an almost the same router I'm getting at least 150MB/s thru the wireguard tunnel.

150 MB /s is impossible, do you mean 150 Mb /s ?

1 Like

Yes, tried both on and off. No difference. It's not the cable modem that's the problem. I believe there is something funky going on in the router.

Yes, running GB ethernet.

I was able to flash the Linksys factory firmware. Buffer bloat is terrible, but I'm getting close to 200Mbs through the router.


You could try flash a build of davidc502 which are based on the latest/recent snapshots: Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Btw, have you tried to perform a reset and test the speed with openwrt (maybe your config got messy)?

1 Like