Collected errors: * satisfy_dependencies_for


#1

Hello!

How are you?
Do you guys know when I build my own firmware on the 18.06.2 tag and I get the Collected errors: * satisfy_dependencies_for, when I build for 18.06.1 is working 100%?
Besides on the http://downloads.openwrt.org/releases/18.06.2/targets/ramips/mt7621/ there is a D-LINK DIR860L B1 firmware, how can come?


#2

The error is:

 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-cfg80211:
 *      iw
 * opkg_install_cmd: Cannot install package kmod-cfg80211.

What the CONFIG_BUILDBOT=y mean?
#3

It's not at all clear from your post what you're doing, but I'm guessing you're building your own firmware, flashing it, then trying to install packages by name.

Unless you're changed the URL for the package repositories to one you host and placed the packages you've built on the server for that URL, you won't be retrieving your packages, but those of the /etc/opkg/distfeeds.conf

Note that overriding them will require a file sorts alphabetically after distfeeds.conf (customfeeds.conf sorts before)


#4

@jeff, the problem is that this error is when it happens here (at the end, so after it built everything and it tries to create the firmware the D-LINK DIR860L B1 firmware):

IGNORE_ERRORS=1 make V=s # -j$CORES˛

So it is before I upgrade! It is during the build! When I copy the config.seed for the related target it builts!!!! But here is what I do and it gives this error of this:
https://pages.corifeus.com/github/openwrt-insomnia/docs/create-from-scratch.html#build-all-packages

The related forum post is this:


#5

The only thing that is different from the default is that enables MIPS FPU emulator, is that could give an error?


#6

I would enable generation of logs in advanced developer options (as I recall), especially as you're setting IGNORE_ERRORS. My guess is that "it built everything" isn't completely correct and that something along the way went wrong. The resulting logs are in ./logs of the root of the source tree.

CONFIG_BUILD_LOG=y

#7

I am doing a new built without BUILDBOT setting, after that I will try with the CONFIG_BUILD_LOG, thanks for the help!!!


#8

@jeff, so far i got this error:

docker@8e5a549f3782:/build/source/logs$ cat ./package/error.txt
   ERROR: package/feeds/packages/protobuf-c [host] failed to build.
docker@8e5a549f3782:/build/source/logs$

Is protobuf-c important?


#9

You should be able to see the specific error in the logs for the package, You should be able to search through the Makefile dependencies to see what it will break.


#10

@jeff : So do you think this is the problem? Is that a core package is not building and is required for like wifi etc? Is it a required package? protobuf-c ?


#11

If so , I will debug the build problem and fix it...


#12

so far i get these:

   ERROR: package/feeds/packages/protobuf-c [host] failed to build.
   ERROR: package/feeds/node/node-modbus failed to build.
   ERROR: package/feeds/packages/addrwatch failed to build.
   ERROR: package/feeds/packages/apcupsd failed to build.
   ERROR: package/feeds/packages/bonnie++ failed to build.
   ERROR: package/feeds/packages/clamsmtp failed to build.
   ERROR: package/feeds/packages/classpath failed to build.
   ERROR: package/feeds/packages/cmdpad failed to build.
   ERROR: package/feeds/packages/crtmpserver failed to build.

how could i find out which is important really?


#13

Many people only build the modules that they need, rather than trying to build all of them.

I think something is wrong with your build environment or config, as I've built apcupsd in the past locally.


#14

what is weird is that it build on 18.06.1 with no error.
what linux distro you are using and version?


#15

what a bummer, been able to build everything plus many nodejs packages and my own redis build, since LEDE and now with 18.06.2 is not generating the firmwares while almost all packages are built in 16 hours.
what bummer!
i have to wait until next version.
now i am testing Debian Testing repo instead of stable.
:confused:


#16
jeff@deb-devel:~/devel/openwrt-ea8300$ lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux 9.7 (stretch)
Release:	9.7
Codename:	stretch

works fine for the builds and packages I build, when properly configured. As I recall, the list of required host packages on the wiki was reasonably accurate.


#17

for some of packages like classpath, u must install

apt install openjdk-8* ecj java-wrappers nasm bzr libpcap-ng-dev

#18

what is weird is that these errors should not prevent building the firmwares.
the errors:


   ERROR: package/feeds/packages/protobuf-c [host] failed to build.
   ERROR: package/feeds/node/node-modbus failed to build.
   ERROR: package/feeds/packages/addrwatch failed to build.
   ERROR: package/feeds/packages/bonnie++ failed to build.
   ERROR: package/feeds/packages/clamsmtp failed to build.
   ERROR: package/feeds/packages/classpath failed to build.
   ERROR: package/feeds/packages/cmdpad failed to build.
   ERROR: package/feeds/packages/crtmpserver failed to build.
   ERROR: package/feeds/packages/grilo-plugins failed to build.
   ERROR: package/feeds/packages/hamlib failed to build.
   ERROR: package/feeds/packages/jool failed to build.
   ERROR: package/feeds/packages/lcd4linux failed to build (build variant: full).
   ERROR: package/feeds/packages/lcdgrilo failed to build.
   ERROR: package/feeds/packages/libartnet failed to build.
   ERROR: package/feeds/packages/libmraa failed to build.
   ERROR: package/feeds/packages/libupm failed to build.
   ERROR: package/feeds/packages/loudmouth failed to build.
   ERROR: package/feeds/packages/nail failed to build.
   ERROR: package/feeds/packages/oath-toolkit failed to build.
   ERROR: package/feeds/packages/opencv failed to build.
   ERROR: package/feeds/packages/psqlodbc failed to build.
   ERROR: package/feeds/packages/quassel-irssi failed to build.
   ERROR: package/feeds/packages/rxtx failed to build.
   ERROR: package/feeds/packages/softethervpn [host] failed to build.
   ERROR: package/feeds/packages/softethervpn failed to build.
   ERROR: package/feeds/packages/v4l2rtspserver failed to build.
   ERROR: package/feeds/packages/wifidog failed to build (build variant: tls).

#19

i save this, thanks for this plus package!


#20

The big problem is that the required packages are built properly, but at the end of the make it tries to generate the basic firmware and then it tries to auto install those packages (kmod-cfg80211 and iw) and then is says Cannot satisfy the following dependencies problem.
How can it say Cannot satisfy the following dependencies, when it just freshly built all packages and the required packages are built (there are a few errored, but those are not part of this problem!).

SO WEIRD!