Collected errors: * satisfy_dependencies_for

I'm trying to enable the USB stick "TP-Link Archer T1U Mediatek MT7610U"

This package are installed:

No 5Ghz network appears, only a 2.5 Ghz radio is present.

unable to initialize libusb: -99

If i try to install
"kmod-usb2" or "kmod-usb-uhci"

Installing kmod-usb2 (4.14.44-1) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb2:
 * 	kernel (= 4.14.44-1-0eb37872cdac1ad98e2c814d0b5be3a7) * 	kernel (= 4.14.44-1-0eb37872cdac1ad98e2c814d0b5be3a7) * 
 * opkg_install_cmd: Cannot install package kmod-usb2.

Installing kmod-usb-uhci (4.14.44-1) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-uhci:
 * 	kernel (= 4.14.44-1-0eb37872cdac1ad98e2c814d0b5be3a7) * 
 * opkg_install_cmd: Cannot install package kmod-usb-uhci.

Installing kmod-usb-ohci (4.14.44-1) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-ohci:
 * 	kernel (= 4.14.44-1-0eb37872cdac1ad98e2c814d0b5be3a7) * 
 * opkg_install_cmd: Cannot install package kmod-usb-ohci.

I'm guessing from memories of your previous post that you are compiling your own images, yes?

If so, the snapshot repositories for kernel modules are likely not compatible with the kernel that you've compiled (though the user-space packages probably are).

You probably either need to build the kmod(s) into your image, or build them as modules and either manually copy them to the device and install them, or host them yourself on an appropriate server and modify the contents of /etc/okpg/ to point to that server. As I recall, the contents of that directory are read in alphabetically so that if you want your repo to have precedence over the upstream repo, it needs to be in a file with a name that is "after" distfeeds.conf

Custom files can be added to images in the files/ directory of the build system. the files/ directory corresponds to the mounted root on the device.

So if I activate them in "make menuconfig" they should work ?
Can you tell me what package I have to make in order to enable 5GHZ for usb stick ?

Maybe it's the same problem I had with the "image builder"
That many modules were missing or were not compatible.

When you run your own build environment, it's your responsibility to select the packages you need built, either to directly include into your firmware or as modules for later.

It would take hours and hours to build every module and package so just the minimum are selected. For many people, it is easy enough to add the module you need with make menuconfig and have it in a new firmware version in just a few minutes.

I don't know the status of the MT7610U drivers in OpenWRT. A quick search on Google led to this 2017 bug report that suggested that at least a year ago, the general Linux support for 5 GHz wasn't very good. I keep seeing all kinds of posts here on MediaTek support, so things may have changed significantly since then.

Usually the Cannot satisfy the following dependencies for... kernel... is referencing that packages have been updated due to an updated kernel version, and if receiving these while:

  • Using opkg, it means the firmware must be updated

  • Using the Build System, it means the build environment needs to be cleaned of remnants compiled for the old kernel version.
    • It's extremely rare for a package dependency to be related to actual dependencies not being selected, as this would infer the repo's makefile's are broken.
1 Like

My kernel is up-to-date, I just downloaded it and compiled it.
I think packages on opkg are old.

I have compiled the following modules and now the USB works, but does not load the driver.

Kernel module --> 
	Usb Support --> 
Utility -->

--> lsusb
Bus 001 Device 003: ID 2357:0105

--> cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  4 Spd=480  MxCh= 0
D:  Ver= 2.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=2357 ProdID=0105 Rev= 1.00  <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
S:  Manufacturer=MediaTek
S:  Product=WiFi
S:  SerialNumber=1.0
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=160mA
I:* If#= 0 Alt= 0 #EPs= 8 Cls=ff(vend.) Sub=02 Prot=ff Driver=(none)

No. But the kmod packages in the snapshot repo are meant to be installed to the firmware image compiled at the same time as the kmods. There is strict checksumming regarding e.g. kernel options, included modules etc.

You can't install kmods from the repo to a private build.
(If you are knowledgeable enough, you can override the checksumming with opkg options, but then you are intentionally willing to risk installing incompatible kmods and bricking the device.)

If you are already compiling the kernel, then just included the needed nods in the image.

But usb diver ?
How I can understand way usb driver aren't loaded.

For repository.
Can I disable check, on Lucy software ?
Or, if I enable "all package" check on menuconfig, can I recover all compiled package and put it on git hub ?
And config opkg for use git hub ?

Since the software is under GPL and/or other licenses, if you post it publicly, you would need to meet all the requirements of those licenses. GPL is particularly onerous in this regard. I'd recommend a private, local server if you want to host your own packages.

You need to determine which packages you need and either build them into your image, or build them as modules. If as modules, you can transfer them to your router's file system and install them in the proper order manually or host them on a local (no outside-world access) and add the URL of that repository as I described above.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.