CLOSED: Opkg_install_cmd: Cannot install package mtd

update: it's working now.

encountered an issue when using the imagebuilder. seems like something has changed on June 1 since i was able to generate the images the night before on may 31. i'm using this

this is the error:

Collected errors:
 * opkg_install_cmd: Cannot install package mtd.
Makefile:134: recipe for target 'package_install' failed
make[2]: *** [package_install] Error 255
Makefile:100: recipe for target '_call_image' failed
make[1]: *** [_call_image] Error 2
Makefile:175: recipe for target 'image' failed
make: *** [image] Error 2

It's doing it again today 6th June 2018. Do'h.

Source code log tells the reason:

mtd: mark as nonshared to fix FS#484;a=commit;h=46d7ced9d1e104693a9f995bfe8a6e28ac82b592

As a result of that, the "mtd" package has moved from the "base" packages download repo to images downloads / packages subdir.

Not quite sure, how imagebuilder handles that move from one place to another, but likely you need to delete the temporary package database. e.g. clear the work directory, tmp and also hidden dot-starting files from tmp

In any case, this thread by @wrtboy is about master snapshots , while @bluewavenet likely talks about 17.01 like in his other thread about this. In 17.01 the same change was done on June 5th.

i agree they are not exactly the same scenario. i usually utilize community builds e.g. hnyman, davidc502 since it's convenient but there is no community build for the netgear wndr4300sw. i usually use the ar71xx nand imagebuilder from either the master or stable to create an image for wndr4300 then modify the image's header and checksum so the wndr4300sw would accept the image. this was my first time encountering an error when using an imagebuilder and in this case it was from the master. fortunate for me, it worked the next time i run imagebuilder hence i've decided to close the thread.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.