[CLOSED] Bug - no further response on report

Hello all,

A few months ago, I made the following bug report:


I have an IPENCAP tunnel that stopped appearing on LuCI at: Realtime Graph > Traffic - upon the installation of LEDE 17.01. I was able to see these IPENCAP tunnels on the GUI in 15.05.

I was asked to provide some results from the CLI, and then it was assuemd that the interface was not listed in the various outputs - but it was included in the output. Any followup would be greatly appreciated.

The issue was solved with https://github.com/openwrt/luci/commit/4201282559d85988990c8f48f4075bed5f785c2f - Seems I forgot to update the bug.

1 Like

I appreciate your work, thanks.

I upgraded luci and luci-base, I still cannot see tunnel traffic.

I'll wait til v18, unless there's something I missed (because, I don't really want to go against the recommendation of the upgrading of packages supplied in the firmware).

The fix has not yet been backported to stable.

1 Like

Still not showing on 18.06.0.

Is the device showing in lua -lluci.util -lluci.sys -e 'luci.util.dumptable(luci.sys.net.devices())' now?

The problem is that tunl0 is on the list of ignored devices because it is usually a dummy netdev spawned by the iptunnel kernel driver. Any chance to rename your IP encap interface to something not called tunl[0-9] ?

It always did.

LLEACHII commented on 20.07.2017 17:40


The missing device does appear, it is tunl0 , it's the device with a address.

Since I'm not sure why you want the output, it's difficult to assist.

I'll try that.

This is going to take more. The scrips don't raise the tunnel now using "ampr0."

root@OpenWrt:~# ip tunnel add ampr0
cannot determine tunnel mode (ipip, gre, vti or sit)
root@OpenWrt:~# ip tunnel add ampr0 mode ipip
add tunnel "tunl0" failed: File exists
root@OpenWrt:~# ip tunnel change ampr0 mode ipip ttl 64 tos inherit pmtudisc
get tunnel "ampr0" failed: No such device

It appears IPIP tunnels can only be named 'tunlx' on OpenWrt. I'm unable to stand up an interface using other naming schemes.

Therefore, I have no way to test the bugfix...and technically, the fix never solved the original problem (as it seems that code was introduced to ignore interfaces named tunlx - in the first place).

The workaround still applies - browse to http://<SERVER_IP>/cgi-bin/luci/admin/status/realtime/bandwidth?dev=tunl0

Sorry to revive this thread; but I just noticed that this workaround still works, but LuCI no longer displays the path as a hint.

Hope this helps someone.

It's more so necessary to recall, especially if tunlx is an unmanaged Interface, as TX/RX stats no longer display no the interface page either.

The workaround no longer appears to work.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.