Cloning Archer C7v5 configuration (18.06.1 and 18.06.5)

I have an TP-Link Archer C7v5 with OpenWrt 18.06.1, r7258-5eb055306f and want to setup another C7v5 with a very similar configuration. The difference is IP-address and hostname. Can I change the config-files of the old router and change the IP-address and the hostname in the config files?

The new router was flashed with

So the difference is 18.06.1 and 18.06.5.

Between point releases, there shouldn't be any configuration differences; but to be on the safe side I'd upgrade your existing 18.06.1 installation as well (there's a reason 18.06 is at .5 right now).

Then, back up your settings (either through LuCI or sysupgrade). You can then open that tarball on your client (if you're on Windows, us e.g. 7-Zip) and edit what you want, then recompress.

Easier though is to 'restore' the backup tarball on the target device over SSH (again through sysupgrade), then adjust the configuration files manually, make sure your wireless settings have the right hardware paths in them (you generate a wireless config first and back that up to compare or adjust later), and finally, after that's done, you can reboot your target device.


(Uploading an uncompressed tar file is “fine”, especially as the default tar on OpenWrt may not “understand” the compression method.)


Thanks, that made me "brave" to use another method and it looks like it worked. I try to avoid flashing, when editing 3 files does the same.

config/network stores the ip-address

config/system stores the hostname

config/wireless stores the ssid (2 new entries,1 for 2.4 and 1 for 5GHz)

So I copied with scp the whole config-directory from the old router to my pc, edited the above and copied it to the new router.

Reboot via ssh and it looks like it works. This is a wireless bridge-configuration and I can connect to and surf with my mobile phone.

Be careful, if your notebook can connect to different networks and uses the strongest automatically. Suddenly I could not connect to the new router anymore, this was the reason.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Glad it worked but you should really look into the sysupgrade command. Takes care of a lot for you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.