Clients connecting at 802.11n over 5 GHz - Netgear R7800

I have two Netgear R7800s running OpenWrt 21.02.3, with ath10k (non-CT) firmware on both, and a TP-Link Archer C7 v5, also running non-CT firmware. I have the same issues with CT firmware as well, but I switched to non-CT on all my APs because of better stability.

Smartphones and tablets connecting to the 5 GHz band have no issues connecting at full speed (866 Mbps, VHT80, 802.11ac).

However, there are 3 laptops with Intel AX200 WiFi cards that all show the same behaviour with the 5 GHz band and connect at 300 Mbps, HT40, 802.11n instead.

I've tried with 3 different driver versions for the Intel card, including the latest Intel Drivers which were released just a few days ago. I have the same problem every time.

The same laptops can connect at full-speed when using the stock firmware on the NG routers, however with OpenWrt they connect at 802.11n instead.

Screenshots of OpenWrt Web UI and Windows 10 WiFi settings are shown below. I have made no changes to the default Intel WiFi driver settings and I just did a clean install of Windows 10 on this particular laptop.

My R7800's WiFi config has also been pasted below. That's how it's configured on both APs.

Can't seem to figure out what's causing this and whether it's an Intel issue or an OpenWrt issue.

Windows10

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option htmode 'VHT80'
        option channel '149'
        option txpower '23'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Chinar-5GHz'
        option encryption 'psk2+ccmp'
        option key
        option ieee80211w '2'
        option wpa_disable_eapol_key_retries '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option txpower '23'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Chinar'
        option encryption 'psk2+ccmp'
        option key
        option ieee80211w '2'
        option wpa_disable_eapol_key_retries '1'

The Ipad (smartphone and tablet) used the 80 Mhz channel width, while the Intel card used the 40 Mhz channel widht. Usually the bigger channel width improve the speed.

for AC 40Mhz would be 433Mhz not 300Mhz

Not 100% sure but related to this I think.

Try changing to channel 36 and see if the intel card connects at higher speeds. I would have thought any issues about detecting the regulatory domain would have been fixed since this linked report above (in openwrt, intel drivers, and/or windows 10). But I don't know for sure. Assuming you get higher speeds on channel 36, then start looking at which component (openwrt, windows, or intel or combinations of both) might be responsible.

HTH

EDIT on the R7800 command line, the output of

iw reg get

might be helpful.

Also, I think you may have to choose a different channel (i.e. 155153) depending on your location - at least in a place like China it looks like channels 100-144 are prohibited from use there so centering an 80 MHz width at 149 might lead to trouble. Sorry, I only have limited knowledge about this.

EDIT1 openwrt should "auto" center based on the width your client can connect at. I.e. setting channel 36 and 80 MHz width on openwrt, clients capable of connected at 80 MHz width are actually centered at channel 42. I would expect that same for setting channel 149 and 80 MHz width but you could try 153 just to see what happens.

1 Like

That was an interesting thread. You'd think Intel / Windows would have fixed the problem by now considering it's been 2 years, but apparently not.

Switching to Channel 36 results in the same behaviour as my previous setup with Channel 149.

iw reg get output:

root@H80-R7800-2:~# iw reg get
global
country US: DFS-FCC
        (2400 - 2472 @ 40), (N/A, 30), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5730 - 5850 @ 80), (N/A, 30), (N/A), AUTO-BW
        (5850 - 5895 @ 40), (N/A, 27), (N/A), NO-OUTDOOR, AUTO-BW, PASSIVE-SCAN
        (57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#1
country US: DFS-FCC
        (2400 - 2472 @ 40), (N/A, 30), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5730 - 5850 @ 80), (N/A, 30), (N/A), AUTO-BW
        (5850 - 5895 @ 40), (N/A, 27), (N/A), NO-OUTDOOR, AUTO-BW, PASSIVE-SCAN
        (57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
        (2400 - 2472 @ 40), (N/A, 30), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5730 - 5850 @ 80), (N/A, 30), (N/A), AUTO-BW
        (5850 - 5895 @ 40), (N/A, 27), (N/A), NO-OUTDOOR, AUTO-BW, PASSIVE-SCAN
        (57240 - 71000 @ 2160), (N/A, 40), (N/A)
1 Like

If you have the same symptoms on channel 36 then I'm not sure and perhaps there is some other issue. Hopefully another user will have seen this before.

1 Like

Tried multiple different channels yesterday (36, 149, 153) and the Intel based laptops all have the same issues regardless.

This seems to have happened recently, possibly a bug introduced in one of Windows 10's cumulative updates and coincidentally occurred around the same time I switched to OpenWrt because ever since I did, none of the laptops can connect to any 5 GHz network at full speed.

I tried with a Synology RT2600ac and an TP-Link Archer AX10, both running stock firmware and the same issue occurs with both of those devices as well. In fact, if I set the Synology router to disable 802.11n on the 5 GHz band and force 'AC' only, Windows shows a 'Cant connect to this network' error message after entering the password.

Initially I thought it may have been the fact that none of my OpenWrt APs are providing 802.11d regulatory information, so I enabled that under the Wireless interface settings, but it made no difference whatsoever.

I came across several threads with the same issue and none of them have a solution since there is no way to disable Intel's stupid LAR feature on Windows. Intel and MSFT are both unhelpful and their support reps have the same copy-pasted answer in every thread that discusses this.