Clients can't route out intermittently, router still connected, reboot required AT&T

I've tried searching for this but, it's difficult to come up with good search terms and I haven't found any useful results so, if this has been covered, please point me to a thread and accept my apologies in advance.

I've got a couple of AT&T accounts running on OpenWRT devices, one is a prepaid account on a MOFI 4500 and the other is an unlimited plan from a corporate account on a WE826 running Open Rooter. Both accounts are experiencing the same issue and it's beginning to drive me nuts.

The prepaid account has been running for a few years now on the same hardware with no recent configuration changes or firmware updates. Up until a few months ago, it was rock solid and just worked. Then out of nowhere, we started having issues where network clients could ping an address like but, they wouldn't get any DNS resolution and not other traffic would pass. I tried disconnecting and reconnecting the modem but, the only solution to the problem would be to reboot the router. Sometimes after a reboot it would work for days, sometimes just a few hours, there really wasn't any rhyme or reason to it. Recently, in the last month, this issue has become much more frequent. I thought maybe I had hardware problems but, I don't anymore because...

We have another rural location that needed Internet setup so I got the second AT&T account and the WE826. It's using a Quectel EM25 (I have a Sierra MC7455 coming) and I just recently got it running. I'm running essentially the default configuration, all I did was set the password and the APN. With this one, when I start doing something more bandwidth intensive, like watching Amazon Prime or Netflix, I get about 30 minutes or so and then none of the clients can access the Internet. If I log into the router though, it can ping outside addresses, traceroute works fine and it's resolving names with no problem so it's just not passing inside traffic for some reason. Again, I can try to disconnect/reconnect the modem but, the only thing that gets it working again is a reboot.

So, I don't know if there is something I'm missing in OpenWRT that I can at least better troubleshoot what's going on or change to help prevent this. Both of these accounts are hotspot accounts but, I've got the TTL set to 65 anyway. I've tried setting up the connection monitoring on the WE826 to get it to reboot itself but, since it never loses connection itself, that doesn't work, it has to be rebooted manually. I'm at a loss as to what to try or where to look. I suspect AT&T is doing something to me, I don't know how to even verify that's the case so I can go to my reseller and complain to him to get him to fix it.

I welcome any help anyone can provide. It's extremely annoying to have to reboot the router 3 or 4 times to watch a single movie.

I've messed with this some and I think I've made some headway. First, the MC7455 that I ordered arrived so I got that installed. It's connecting on B4 and aggregating on B12 with better speed. The EC25 was connecting on B2 and staying there. When the Sierra switches to B2, my speed gets really poor and I start having problems so, I think my issue is just that I've been connecting on a less desirable band.

I'd like to lock the MC7455 to B4 and B12 only, I'm reading some posts but, it's about as clear as mud to me at this point. It's not really directly OpenWRT but, if anyone has some advice on band locking the MC7455, I would appreciate it.

Directly related to OpenWRT, once I know the correct AT commands to lock the bands I want, where/how do I put them into my config so that they'll persist through reboots?

Thanks in advance.

I think so too.

So changing bands didn't help. I got the Sierra switched to MBIM now and I'll see if that works. If not, I think what's going on is that AT&T is shutting down the hotspot on their end when I start having significant data use, despite the fact that I'm paying for an actual hotspot account. What daemon does the actual hotspot in OpenWRT? firewall?

If I can figure that out and just restart the daemon to force the hotspot active again, and it works, then I can just schedule a cron job to restart that daemon every 20 minutes or so. Hopefully the connection stays solid on MBIM but, if not, I'll start experimenting with restarting the daemons that make sense to see if I can get it routing again.