Clients are isolated when working with dynamic vlan

Hi All,

I have an weird problem when enabling dynamic vlan configuration on openwrt (tried both 19.0.7 and 21.02.2).

When the configuration is enabled the wireless clients seems to be isolated and can not communicate with each other, while wired clients are able to access the wireless clients without a problem.

I tried enabling hairpin mode on the wlan1.10 interface of the bridge, but still the same behavior.
Other than that everything is working fine.
Configuration snippets are bellow:

/etc/config/network

config interface 'vlan10'
        option proto 'static'
        option ip6assign '60'
        option type 'bridge'
        option gateway 'XXXX'
        list dns 'XXX'
        list ipaddr 'XXXXX'
        option ifname 'eth0.10'


config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 5 4'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5t'
        option vid '10'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 5t'
        option vid '11'

/etc/config/wireless

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option encryption 'wpa2'
        option auth_secret 'XXXXX'
        option auth_server 'XXXXX'
        option dynamic_vlan '2'
        option vlan_tagged_interface 'eth0'
        option vlan_naming '0'
        option vlan_bridge 'br-vlan'
        option ssid 'XXXX'

Any help would be highly appreciated.

1 Like

do you have any resolution about your issue ?
i got this exact problem too.

Unfortunately no, I started adding logs to the kernel to debug the issue but didnt get around to finish it.
Ended up ditching dynamic vlans and using two separate SSID's instead.

If you find a solution I would love to know.

@regae After some fiddling looks like I found a solution.. I stumbled upon https://www.mail-archive.com/ath10k@lists.infradead.org/msg13386.html , and it says that using a different ath10k firmware solves the issue, I downloaded it from https://github.com/kvalo/ath10k-firmware/blob/master/QCA4019/hw1.0/3.6/firmware-5.bin_10.4-3.6-00140 , replaced the one under /lib/firmware/ath10k/QCA4019/hw1.0/ and rebooted the device, and it started working.

Note: I tested it on 22_03 but I am sure that it will work on earlier version as well (as the mentioned thread is from a year ago).

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.