Client Device settings in /etc/config/network

Three questions....

(1) I'm following the steps for OpenWrt Project: Client Device - Connecting to an existing network.

OpenWrt Project: Network basics /etc/config/network lists several lines in the table saying, "Only valid for type 'bridge'" but I can't find a documentation page that indicates what else 'option type' can be set to.

Current config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd6d:3643:a29f::/48'

config interface 'lan'
        #option type 'bridge'
        option ifname 'eth0'
        option proto 'dhcp'
        option netmask '255.255.255.0'
        #option ip6assign '60'

(2) Do I need 'option netmask' since the device will get its IP address via DHCP?

(3) Could someone point me to the docs that explain the use of 'option ula_prefix'? When I search this site, it turns up lots of example /etc/config/network entries but I can't seem to find a page that explains what it is for. It looks IPv6 related.

My two cents:

  1. If the interface is going to obtain a connection via DHCP, you only need the "ifname" and "proto" lines. Add the "bridge" line only if you plan to bridge it to a wireless access point (typical for a dumb access point configuration).

  2. Yes, that parameter is IPv6 related, just leave it like that and forget about it.

Thanks @eduperez!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.