ClearFog Base SFP settings for Internet Access

Hello can anyone help me, i have on my ClearFog Base running OpenWRT 19.07.3.

I can't make my sfp module run for my internet access...
and i don't know how to configure wan interface

i have got 3 things from my provider/ISP

Vlan ID: 10
Username: 22xxxxxxxxxxxx@ppp.brennercom.net (example)
Password: 1111111111 (example)

under OpenWRT the show three eth ports eth0,eth1 and eth2
(the clearfog base board has 2x eth port, 1x sfp port)

i think
eth0 is the LAN port right
eth2 is the LAN port left
and for that i I believe eth1 is the sfp port (but i am not sure)

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf6:2f1a:502a::/48'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'
	option ifname 'eth0'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

config interface 'WAN'
	option proto 'pppoe'
	option ipv6 'auto'
	option ifname 'eth1'

/etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'WAN'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

Change this into eth1.10 to enable vlan tagging.
Linux is case sensitive OS, so I suggest to delete the 'WAN' interface you created and create 'wan' from the beginning. When you are asked to select the physical interface from the drop down list, go to the bottom and enter the above value, then press enter. The rest is simple to configure.

I changed that, but nothing happened. You can enter here the correct configuration? where descibed where i must enter the VLAN ID 10 and the user and password of my provider

Go to Luci Network -> Interface and create a new interface. Name it 'wan', protocol pppoe and from the drop down list go to Custom and enter eth1.10
Proceed to add the username and password, assign it to wan firewall zone (if not already), and Save/Apply.

ok now i have set this in the network config and firewall

how should I now address the sfp module on eth1? and where should I enter vlan id 10 of my ISP/provider

etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf6:2f1a:502a::/48'

config interface 'lan'
	option ifname 'eth0'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option ifname 'eth1.10'
	option proto 'pppoe'
	option ipv6 'auto'
	option username '22xxxxxxxxxxxx@ppp.brennercom.net'
	option password '1111111111'

etc/config/firewall

config defaults
	option syn_flood '1'
	option output 'ACCEPT'
	option forward 'REJECT'
	option input 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option network 'lan'
	option forward 'REJECT'

config zone
	option name 'wan'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option input 'ACCEPT'

config forwarding
	option src 'lan'
	option dest 'wan'

etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

I am not sure what the question is here. You have configured wan interface to be pppoe and use eth1 interface with vlan 10 tagging. Other than that you don't have to do anything else in OpenWrt. I don't know if your ISP modem needs any special configuration.
In any case make sure the SFP is indeed eth1 interface. Check with dmesg | grep eth1

dmesg | grep eth1

give me this

[    0.938881] mvneta f1030000.ethernet eth1: Using random mac address 92:4e:8e:xx:xx:xx
[    5.033267] mvneta f1030000.ethernet eth0: renamed from eth1
[    5.083186] mvneta f1034000.ethernet eth1: renamed from eth2
[    5.256263] mvneta f1034000.ethernet eth1: configuring for SGMII/sgmii link mode
[    5.264099] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   11.174708] mvneta f1034000.ethernet eth1: configuring for SGMII/sgmii link mode
[   11.182217] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   11.189976] IPv6: ADDRCONF(NETDEV_UP): eth1.10: link is not ready

I tried as you told me but nothing work

i have at home another modem/router all in one. the name is Technicolor DGA4132 (TIM HUB) running openwrt 15.05 stock from manufacturer. this router has also an SFP Port.
And with this settings..the Internet connection work.

this is the config from my technicolor

#etc/config/network

config device 'waneth4'
	option type '8021q'
	option name 'waneth4'
	option macaddr 'A4:91:B1:XX:XX:XX'
	option ifname 'eth4'
	option ipv6 '0'
	option vid '10'

config device 'wanptm0'
	option type '8021q'
	option name 'wanptm0'
	option macaddr 'A4:91:B1:XX:XX:XX'
	option ifname 'ptm0'
	option vid '835'
	option ipv6 '0'

config interface 'wan'
	option auto '1'
	option proto 'pppoe'
	option demand '0'
	option macaddr 'A4:91:B1:XX:XX:XX'
	option ipv6 '0'
	option reqopts '1 3 6 15 26 33 42 51 121 249'
	option keepalive_adaptive '0'
	option dns_metric '0'
	option ifname 'waneth4'
	option username 'xxxxxxxxxxx@ppp.brennercom.net'
	option password 'xxxxxxxxxxxx'
	list dns '208.67.222.222'
	list dns '208.67.220.220'
	option peerdns '0'

config config 'config'
	option wan_mode 'pppoe'

config interface 'sfptag'
	option proto 'static'
	option ifname 'eth4'
	option netmask '255.255.255.0'
	option ipaddr '192.168.10.1'

#etc/config/dhcp

config dnsmasq 'dnsmasq'
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option strictorder '1'
	option dhcpscript '/lib/dnsmasq/dhcp-event.sh'
	list hostname 'dsldevice'
	option allservers '1'
	option addmac '0'
	list dhcp_option_force 'tag:cpewan-id,vi-encap:3561,6,"4132"'
	list dhcp_option_force 'tag:cpewan-id,vi-encap:3561,5,"CP1846RAACR"'
	list dhcp_option_force 'tag:cpewan-id,vi-encap:3561,4,"A491B1"'

config odhcpd 'odhcpd'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'lan'
	option interface 'lan'
	option start '2'
	option limit '254'
	option leasetime '21600s'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '0'
	option ra_mininterval '200'
	option ra_maxinterval '600'
	option ra_lifetime '1800'
	option ra_hoplimit '64'
	option force '1'
	option ignore '0'

config dhcp 'wlnet_b_24'
	option interface 'wlnet_b_24'
	option start '2'
	option leasetime '1h'
	option force '1'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '0'
	option ra_mininterval '200'
	option ra_maxinterval '600'
	option ra_lifetime '1800'
	option ra_hoplimit '64'
	option ra_max_mtu '1480'
	option limit '125'

config dhcp 'wlnet_b_5'
	option interface 'wlnet_b_5'
	option start '130'
	option leasetime '1h'
	option force '1'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '0'
	option ra_mininterval '200'
	option ra_maxinterval '600'
	option ra_lifetime '1800'
	option ra_hoplimit '64'
	option ra_max_mtu '1480'
	option limit '125'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config dhcp 'wan6'
	option interface 'wan'
	option ignore '1'

config dhcp 'wwan'
	option interface 'wwan'
	option ignore '1'

config relay 'relay'

config opassthrud 'opassthrud'
	option passthruscript '/lib/dhcpopassthrud/dnsmasq.sh'
	option options_needed '0'

config dnsrule
	option dnsset 'voip'
	option policy 'if1_mwan'

config dhcp 'voip'
	option interface 'voip'
	option ignore '1'

config dhcp 'voip6'
	option interface 'voip'
	option ignore '1'

#etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option drop_invalid '1'

config zone 'lan'
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option mtu_fix '1'
	option wan '0'

config zone 'wan'
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	list network 'wwan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'DROP'
	option masq '1'
	option conntrack '1'
	option mtu_fix '1'
	option wan '1'

config forwarding 'lan_wan'
	option src 'lan'
	option dest 'wan'

I don't see any specific output that points eth1 as the SFP port.
There are some renames there, so make sure with one is used eventually.
Last two lines show eth1: link is not ready this could be a hint that the interface is wrong or the cable is not plugged in.

They are not doing something different, albeit in a more complicated way.

One more thing, which image are you running? Since there is no OpenWrt image to download, did you compile it yourself or downloaded it from solid, as mentioned in the device page?

the output that i have sendet you was without the modul pluged in, i send you later a output with the modul in.

that's not true, I have the image from here

https://downloads.openwrt.org/releases/19.07.3/targets/mvebu/cortexa9/openwrt-19.07.3-mvebu-cortexa9-solidrun_clearfog-base-a1-squashfs-sdcard.img.gz

on the forum here i have found a thread that several peoples the have problem since 19.07 with the ClearFog Pro because the et0 eth1 eth2 is not correct set with the image, maybe with my ClearFog Base the is the same

Apparently they changed the target from armada to cortexa9, so the page is outdated and I was wrong.

It would be hard to test without the SFP plugged in.

find out which port is used by the sfp modul.
i would recommend you to plugout/plugin the sfp module and check what dmesg says. then you should be able to know which device to use for the tagging and the user/pass configuration

you can look with this data what is wrong? and where the sfp module is linked

#dmesg (without SFP modul)

root@OpenWrt:/# dmesg
[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.14.180 (builder@buildhost) (gcc version 7.5.0 (OpenWrt GCC 7.5.0 r11063-85e04e9f46)) #0 SMP Sat May 16 18:32:20 2020
[    0.000000] CPU: ARMv7 Processor [414fc091] revision 1 (ARMv7), cr=10c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[    0.000000] OF: fdt: Machine model: SolidRun Clearfog Base A1
[    0.000000] Memory policy: Data cache writealloc
[    0.000000] On node 0 totalpages: 524288
[    0.000000] free_area_init_node: node 0, pgdat c0931440, node_mem_map eeff9000
[    0.000000]   Normal zone: 1536 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 196608 pages, LIFO batch:31
[    0.000000]   HighMem zone: 327680 pages, LIFO batch:31
[    0.000000] random: get_random_bytes called from 0xc08008bc with crng_init=0
[    0.000000] percpu: Embedded 11 pages/cpu s14860 r8192 d22004 u45056
[    0.000000] pcpu-alloc: s14860 r8192 d22004 u45056 alloc=11*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 522752
[    0.000000] Kernel command line: root=PARTUUID=1090e50c-02 rootfstype=auto rootwait console=ttyS0,115200
[    0.000000] Bootloader command line not present
[    0.000000] PID hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[    0.000000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Memory: 2071132K/2097152K available (6144K kernel code, 199K rwdata, 816K rodata, 1024K init, 233K bss, 26020K reserved, 0K cma-reserved, 1310720K highmem)
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
[    0.000000]     vmalloc : 0xf0800000 - 0xff800000   ( 240 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xf0000000   ( 768 MB)
[    0.000000]     pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
[    0.000000]     modules : 0xbf000000 - 0xbfe00000   (  14 MB)
[    0.000000]       .text : 0xc0008000 - 0xc0700000   (7136 kB)
[    0.000000]       .init : 0xc0800000 - 0xc0900000   (1024 kB)
[    0.000000]       .data : 0xc0900000 - 0xc0931d40   ( 200 kB)
[    0.000000]        .bss : 0xc0931d40 - 0xc096c198   ( 234 kB)
[    0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000]  RCU restricting CPUs from NR_CPUS=4 to nr_cpu_ids=2.
[    0.000000] RCU: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=2
[    0.000000] NR_IRQS: 16, nr_irqs: 16, preallocated irqs: 16
[    0.000000] L2C-310 enabling early BRESP for Cortex-A9
[    0.000000] L2C-310 full line of zeros enabled for Cortex-A9
[    0.000000] L2C-310 D prefetch enabled, offset 1 lines
[    0.000000] L2C-310 dynamic clock gating enabled, standby mode enabled
[    0.000000] L2C-310 Coherent cache controller enabled, 16 ways, 1024 kB
[    0.000000] L2C-310 Coherent: CACHE_ID 0x410054c9, AUX_CTRL 0x56070001
[    0.000007] sched_clock: 64 bits at 800MHz, resolution 1ns, wraps every 4398046511103ns
[    0.000016] clocksource: arm_global_timer: mask: 0xffffffffffffffff max_cycles: 0xb881274fa3, max_idle_ns: 440795210636 ns
[    0.000029] Switching to timer-based delay loop, resolution 1ns
[    0.000149] Ignoring duplicate/late registration of read_current_timer delay
[    0.000156] clocksource: armada_370_xp_clocksource: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 76450417870 ns
[    0.000275] Calibrating delay loop (skipped), value calculated using timer frequency.. 1600.00 BogoMIPS (lpj=8000000)
[    0.000282] pid_max: default: 32768 minimum: 301
[    0.000336] Mount-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000342] Mountpoint-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000535] CPU: Testing write buffer coherency: ok
[    0.000547] CPU0: Spectre v2: using BPIALL workaround
[    0.000644] CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
[    0.000755] Setting up static identity map for 0x100000 - 0x100060
[    0.000828] mvebu-soc-id: MVEBU SoC ID=0x6828, Rev=0xA
[    0.000902] mvebu-pmsu: Initializing Power Management Service Unit
[    0.000946] Hierarchical SRCU implementation.
[    0.001127] smp: Bringing up secondary CPUs ...
[    0.001240] Booting CPU 1
[    0.001392] CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
[    0.001394] CPU1: Spectre v2: using BPIALL workaround
[    0.001441] smp: Brought up 1 node, 2 CPUs
[    0.001446] SMP: Total of 2 processors activated (3200.00 BogoMIPS).
[    0.001449] CPU: All CPU(s) started in SVC mode.
[    0.002965] VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4
[    0.003017] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.003024] futex hash table entries: 512 (order: 3, 32768 bytes)
[    0.003072] pinctrl core: initialized pinctrl subsystem
[    0.003381] NET: Registered protocol family 16
[    0.003929] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.004379] cpuidle: using governor ladder
[    0.004535] mvebu-pmsu: CPU hotplug support is currently broken on Armada 38x: disabling
[    0.004543] mvebu-pmsu: CPU idle is currently broken on Armada 38x: disabling
[    0.010774] SCSI subsystem initialized
[    0.010936] libata version 3.00 loaded.
[    0.011013] usbcore: registered new interface driver usbfs
[    0.011037] usbcore: registered new interface driver hub
[    0.011059] usbcore: registered new device driver usb
[    0.011744] clocksource: Switched to clocksource arm_global_timer
[    0.012071] NET: Registered protocol family 2
[    0.012311] TCP established hash table entries: 8192 (order: 3, 32768 bytes)
[    0.012349] TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
[    0.012410] TCP: Hash tables configured (established 8192 bind 8192)
[    0.012457] UDP hash table entries: 512 (order: 2, 16384 bytes)
[    0.012481] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[    0.012560] NET: Registered protocol family 1
[    0.012575] PCI: CLS 0 bytes, default 64
[    0.013604] Crashlog allocated RAM at address 0x3f00000
[    0.013689] workingset: timestamp_bits=30 max_order=19 bucket_order=0
[    0.015257] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.015266] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.016532] bounce: pool size: 64 pages
[    0.016542] io scheduler noop registered
[    0.016546] io scheduler deadline registered (default)
[    0.016989] armada-38x-pinctrl f1018000.pinctrl: registered pinctrl driver
[    0.017356] GPIO line 19 (phy1-reset) hogged as output/low
[    0.018128] mv_xor f1060800.xor: Marvell shared XOR driver
[    0.072180] mv_xor f1060800.xor: Marvell XOR (Descriptor Mode): ( xor cpy intr )
[    0.072292] mv_xor f1060900.xor: Marvell shared XOR driver
[    0.142149] mv_xor f1060900.xor: Marvell XOR (Descriptor Mode): ( xor cpy intr )
[    0.142308] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.142992] console [ttyS0] disabled
[    0.163058] f1012000.serial: ttyS0 at MMIO 0xf1012000 (irq = 23, base_baud = 15625000) is a 16550A
[    0.767124] console [ttyS0] enabled
[    0.790868] f1012100.serial: ttyS1 at MMIO 0xf1012100 (irq = 24, base_baud = 15625000) is a 16550A
[    0.801316] loop: module loaded
[    0.804792] ahci-mvebu f10a8000.sata: AHCI 0001.0000 32 slots 2 ports 6 Gbps 0x3 impl platform mode
[    0.813870] ahci-mvebu f10a8000.sata: flags: 64bit ncq sntf led only pmp fbs pio slum part sxs
[    0.822994] scsi host0: ahci-mvebu
[    0.826531] scsi host1: ahci-mvebu
[    0.830000] ata1: SATA max UDMA/133 mmio [mem 0xf10a8000-0xf10a9fff] port 0x100 irq 45
[    0.837947] ata2: SATA max UDMA/133 mmio [mem 0xf10a8000-0xf10a9fff] port 0x180 irq 45
[    0.846021] ahci-mvebu f10e0000.sata: AHCI 0001.0000 32 slots 2 ports 6 Gbps 0x3 impl platform mode
[    0.855096] ahci-mvebu f10e0000.sata: flags: 64bit ncq sntf led only pmp fbs pio slum part sxs
[    0.864179] scsi host2: ahci-mvebu
[    0.867711] scsi host3: ahci-mvebu
[    0.871180] ata3: SATA max UDMA/133 mmio [mem 0xf10e0000-0xf10e1fff] port 0x100 irq 46
[    0.879126] ata4: SATA max UDMA/133 mmio [mem 0xf10e0000-0xf10e1fff] port 0x180 irq 46
[    0.896650] m25p80 spi1.0: w25q32 (4096 Kbytes)
[    0.901690] libphy: Fixed MDIO Bus: probed
[    0.906119] libphy: orion_mdio_bus: probed
[    0.910966] mvneta_bm f10c8000.bm: Buffer Manager for network controller enabled
[    0.919735] mvneta f1070000.ethernet eth0: Using random mac address 8a:5f:ac:08:ff:80
[    0.928586] mvneta f1030000.ethernet eth1: Using random mac address ee:26:64:ec:4f:3b
[    0.937437] mvneta f1034000.ethernet eth2: Using random mac address 0e:7d:53:5f:88:4d
[    0.945455] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.952002] ehci-pci: EHCI PCI platform driver
[    0.956478] ehci-platform: EHCI generic platform driver
[    0.961790] ehci-orion: EHCI orion driver
[    0.965901] orion-ehci f1058000.usb: EHCI Host Controller
[    0.971322] orion-ehci f1058000.usb: new USB bus registered, assigned bus number 1
[    0.978957] orion-ehci f1058000.usb: irq 41, io mem 0xf1058000
[    1.011725] orion-ehci f1058000.usb: USB 2.0 started, EHCI 1.00
[    1.017876] hub 1-0:1.0: USB hub found
[    1.021646] hub 1-0:1.0: 1 port detected
[    1.025933] xhci-hcd f10f8000.usb3: xHCI Host Controller
[    1.031265] xhci-hcd f10f8000.usb3: new USB bus registered, assigned bus number 2
[    1.038829] xhci-hcd f10f8000.usb3: hcc params 0x0a000990 hci version 0x100 quirks 0x0000000000010010
[    1.048093] xhci-hcd f10f8000.usb3: irq 48, io mem 0xf10f8000
[    1.054045] hub 2-0:1.0: USB hub found
[    1.057814] hub 2-0:1.0: 1 port detected
[    1.061845] xhci-hcd f10f8000.usb3: xHCI Host Controller
[    1.067174] xhci-hcd f10f8000.usb3: new USB bus registered, assigned bus number 3
[    1.074686] xhci-hcd f10f8000.usb3: Host supports USB 3.0  SuperSpeed
[    1.081167] usb usb3: We don't know the algorithms for LPM for this host, disabling LPM.
[    1.089435] hub 3-0:1.0: USB hub found
[    1.093208] hub 3-0:1.0: 1 port detected
[    1.097325] usbcore: registered new interface driver usb-storage
[    1.103748] armada38x-rtc f10a3800.rtc: registered as rtc0
[    1.109385] i2c /dev entries driver
[    1.113116] pca953x 0-0020: 0-0020 supply vcc not found, using dummy regulator
[    1.120956] GPIO line 496 (pcie1.0-clkreq) hogged as input
[    1.126739] GPIO line 499 (pcie1.0-w-disable) hogged as output/low
[    1.133133] GPIO line 501 (usb3-current-limit) hogged as input
[    1.139250] GPIO line 502 (usb3-power) hogged as output/high
[    1.145201] GPIO line 507 (m.2 devslp) hogged as output/low
[    1.161314] (NULL device *): hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
[    1.172943] ata2: SATA link down (SStatus 0 SControl 300)
[    1.173709] orion_wdt: Initial timeout 171 sec
[    1.179011] ata1: SATA link down (SStatus 0 SControl 300)
[    1.183654] sdhci: Secure Digital Host Controller Interface driver
[    1.194987] sdhci: Copyright(c) Pierre Ossman
[    1.214190] ata3: SATA link down (SStatus 0 SControl 300)
[    1.219624] ata4: SATA link down (SStatus 0 SControl 300)
[    1.261722] mmc0: SDHCI controller on f10d8000.sdhci [f10d8000.sdhci] using ADMA
[    1.269230] sdhci-pltfm: SDHCI platform and OF driver helper
[    1.275618] marvell-cesa f1090000.crypto: CESA device successfully registered
[    1.283187] NET: Registered protocol family 10
[    1.289160] Segment Routing with IPv6
[    1.292868] NET: Registered protocol family 17
[    1.297334] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.311802] 8021q: 802.1Q VLAN Support v1.8
[    1.316057] Registering SWP/SWPB emulation handler
[    1.322083] mvebu-pcie soc:pcie: /soc/pcie/pcie@2,0: reset gpio is active low
[    1.386158] mmc0: new high speed MMC card at address 0001
[    1.391786] mmcblk0: mmc0:0001 8GTF4R 7.28 GiB
[    1.396374] mmcblk0boot0: mmc0:0001 8GTF4R partition 1 4.00 MiB
[    1.402365] mmcblk0boot1: mmc0:0001 8GTF4R partition 2 4.00 MiB
[    1.408329] mmcblk0rpmb: mmc0:0001 8GTF4R partition 3 512 KiB, chardev (250:0)
[    1.416102]  mmcblk0: p1 p2
[    1.461730] usb 2-1: new high-speed USB device number 2 using xhci-hcd
[    1.672228] usb-storage 2-1:1.0: USB Mass Storage device detected
[    1.678420] scsi host4: usb-storage 2-1:1.0
[    2.721923] scsi 4:0:0:0: Direct-Access     MXT-USB  Storage Device   1109 PQ: 0 ANSI: 0 CCS
[    2.731041] sd 4:0:0:0: [sda] 31116288 512-byte logical blocks: (15.9 GB/14.8 GiB)
[    2.738739] sd 4:0:0:0: [sda] Write Protect is off
[    2.743554] sd 4:0:0:0: [sda] Mode Sense: 03 00 00 00
[    2.743662] sd 4:0:0:0: [sda] No Caching mode page found
[    2.748987] sd 4:0:0:0: [sda] Assuming drive cache: write through
[    2.760626]  sda: sda1
[    2.763593] sd 4:0:0:0: [sda] Attached SCSI removable disk
[    4.321717] pcie1.0: reset completed in 100000us
[    4.326416] mvebu-pcie soc:pcie: PCI host bridge to bus 0000:00
[    4.332360] pci_bus 0000:00: root bus resource [io  0x1000-0xfffff]
[    4.338643] pci_bus 0000:00: root bus resource [mem 0xe0000000-0xe7ffffff]
[    4.345538] pci_bus 0000:00: root bus resource [bus 00-ff]
[    4.351050] pci 0000:00:02.0: [11ab:6828] type 01 class 0x060400
[    4.351136] PCI: bus0: Fast back to back transfers disabled
[    4.356730] pci 0000:00:02.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    4.364790] PCI: bus1: Fast back to back transfers enabled
[    4.370289] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    4.370300] pci 0000:00:02.0: PCI bridge to [bus 01]
[    4.375391] libphy: SFP I2C Bus: probed
[    4.379829] random: fast init done
[    4.384156] armada38x-rtc f10a3800.rtc: setting system clock to 2020-06-09 12:17:46 UTC (1591705066)
[    4.394861] EXT4-fs (mmcblk0p2): INFO: recovery required on readonly filesystem
[    4.402199] EXT4-fs (mmcblk0p2): write access will be enabled during recovery
[    4.423005] EXT4-fs (mmcblk0p2): recovery complete
[    4.428726] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
[    4.436861] VFS: Mounted root (ext4 filesystem) readonly on device 179:2.
[    4.444224] Freeing unused kernel memory: 1024K
[    4.526991] init: Console is alive
[    4.530467] init: - watchdog -
[    4.567890] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.576461] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.584020] init: - preinit -
[    4.643903] mvneta f1070000.ethernet tmp0: renamed from eth0
[    4.650186] random: procd: uninitialized urandom read (4 bytes read)
[    4.693173] mvneta f1030000.ethernet eth0: renamed from eth1
[    4.733105] mvneta f1034000.ethernet eth1: renamed from eth2
[    4.773087] mvneta f1070000.ethernet eth2: renamed from tmp0
[    4.831346] random: jshn: uninitialized urandom read (4 bytes read)
[    4.847559] random: jshn: uninitialized urandom read (4 bytes read)
[    4.885936] mvneta f1034000.ethernet eth1: configuring for SGMII/sgmii link mode
[    4.893775] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[    7.935820] mount_root: mounting /dev/root
[    7.940704] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[    8.037817] EXT4-fs (mmcblk0p1): mounted filesystem without journal. Opts: (null)
[    8.087975] urandom-seed: Seeding with /etc/urandom.seed
[    8.110498] procd: - early -
[    8.113426] procd: - watchdog -
[    8.711759] procd: - watchdog -
[    8.714994] procd: - ubus -
[    8.721650] urandom_read: 3 callbacks suppressed
[    8.721653] random: ubusd: uninitialized urandom read (4 bytes read)
[    8.768109] random: ubusd: uninitialized urandom read (4 bytes read)
[    8.774561] random: ubusd: uninitialized urandom read (4 bytes read)
[    8.781119] procd: - init -
[    8.852653] kmodloader: loading kernel modules from /etc/modules.d/*
[    8.860772] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    8.862803] urngd: v1.0.2 started.
[    8.874575] ip_tables: (C) 2000-2006 Netfilter Core Team
[    8.881339] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[    8.895863] random: crng init done
[    8.897669] xt_time: kernel timezone is -0000
[    8.899280] random: 1 urandom warning(s) missed due to ratelimiting
[    8.905778] PPP generic driver version 2.4.2
[    8.914920] NET: Registered protocol family 24
[    8.920170] kmodloader: done loading kernel modules from /etc/modules.d/*
[   10.742649] mvneta f1030000.ethernet eth0: PHY [f1072004.mdio-mii:01] driver [Marvell 88E1510]
[   10.754306] mvneta f1030000.ethernet eth0: configuring for phy/sgmii link mode
[   10.761990] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   14.002085] mvneta f1030000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[   14.009950] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

#dmesg (with SFP modul)

root@OpenWrt:/# dmesg
[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.14.180 (builder@buildhost) (gcc version 7.5.0 (OpenWrt GCC 7.5.0 r11063-85e04e9f46)) #0 SMP Sat May 16 18:32:20 2020
[    0.000000] CPU: ARMv7 Processor [414fc091] revision 1 (ARMv7), cr=10c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[    0.000000] OF: fdt: Machine model: SolidRun Clearfog Base A1
[    0.000000] Memory policy: Data cache writealloc
[    0.000000] On node 0 totalpages: 524288
[    0.000000] free_area_init_node: node 0, pgdat c0931440, node_mem_map eeff9000
[    0.000000]   Normal zone: 1536 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 196608 pages, LIFO batch:31
[    0.000000]   HighMem zone: 327680 pages, LIFO batch:31
[    0.000000] random: get_random_bytes called from 0xc08008bc with crng_init=0
[    0.000000] percpu: Embedded 11 pages/cpu s14860 r8192 d22004 u45056
[    0.000000] pcpu-alloc: s14860 r8192 d22004 u45056 alloc=11*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 522752
[    0.000000] Kernel command line: root=PARTUUID=1090e50c-02 rootfstype=auto rootwait console=ttyS0,115200
[    0.000000] Bootloader command line not present
[    0.000000] PID hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[    0.000000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Memory: 2071132K/2097152K available (6144K kernel code, 199K rwdata, 816K rodata, 1024K init, 233K bss, 26020K reserved, 0K cma-reserved, 1310720K highmem)
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
[    0.000000]     vmalloc : 0xf0800000 - 0xff800000   ( 240 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xf0000000   ( 768 MB)
[    0.000000]     pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
[    0.000000]     modules : 0xbf000000 - 0xbfe00000   (  14 MB)
[    0.000000]       .text : 0xc0008000 - 0xc0700000   (7136 kB)
[    0.000000]       .init : 0xc0800000 - 0xc0900000   (1024 kB)
[    0.000000]       .data : 0xc0900000 - 0xc0931d40   ( 200 kB)
[    0.000000]        .bss : 0xc0931d40 - 0xc096c198   ( 234 kB)
[    0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000]  RCU restricting CPUs from NR_CPUS=4 to nr_cpu_ids=2.
[    0.000000] RCU: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=2
[    0.000000] NR_IRQS: 16, nr_irqs: 16, preallocated irqs: 16
[    0.000000] L2C-310 enabling early BRESP for Cortex-A9
[    0.000000] L2C-310 full line of zeros enabled for Cortex-A9
[    0.000000] L2C-310 D prefetch enabled, offset 1 lines
[    0.000000] L2C-310 dynamic clock gating enabled, standby mode enabled
[    0.000000] L2C-310 Coherent cache controller enabled, 16 ways, 1024 kB
[    0.000000] L2C-310 Coherent: CACHE_ID 0x410054c9, AUX_CTRL 0x56070001
[    0.000006] sched_clock: 64 bits at 800MHz, resolution 1ns, wraps every 4398046511103ns
[    0.000016] clocksource: arm_global_timer: mask: 0xffffffffffffffff max_cycles: 0xb881274fa3, max_idle_ns: 440795210636 ns
[    0.000029] Switching to timer-based delay loop, resolution 1ns
[    0.000149] Ignoring duplicate/late registration of read_current_timer delay
[    0.000156] clocksource: armada_370_xp_clocksource: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 76450417870 ns
[    0.000274] Calibrating delay loop (skipped), value calculated using timer frequency.. 1600.00 BogoMIPS (lpj=8000000)
[    0.000282] pid_max: default: 32768 minimum: 301
[    0.000335] Mount-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000341] Mountpoint-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000534] CPU: Testing write buffer coherency: ok
[    0.000545] CPU0: Spectre v2: using BPIALL workaround
[    0.000642] CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
[    0.000750] Setting up static identity map for 0x100000 - 0x100060
[    0.000822] mvebu-soc-id: MVEBU SoC ID=0x6828, Rev=0xA
[    0.000897] mvebu-pmsu: Initializing Power Management Service Unit
[    0.000940] Hierarchical SRCU implementation.
[    0.001119] smp: Bringing up secondary CPUs ...
[    0.001232] Booting CPU 1
[    0.001384] CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
[    0.001386] CPU1: Spectre v2: using BPIALL workaround
[    0.001433] smp: Brought up 1 node, 2 CPUs
[    0.001438] SMP: Total of 2 processors activated (3200.00 BogoMIPS).
[    0.001441] CPU: All CPU(s) started in SVC mode.
[    0.002948] VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4
[    0.002999] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.003006] futex hash table entries: 512 (order: 3, 32768 bytes)
[    0.003055] pinctrl core: initialized pinctrl subsystem
[    0.003365] NET: Registered protocol family 16
[    0.003914] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.004410] cpuidle: using governor ladder
[    0.004565] mvebu-pmsu: CPU hotplug support is currently broken on Armada 38x: disabling
[    0.004573] mvebu-pmsu: CPU idle is currently broken on Armada 38x: disabling
[    0.010813] SCSI subsystem initialized
[    0.010972] libata version 3.00 loaded.
[    0.011051] usbcore: registered new interface driver usbfs
[    0.011076] usbcore: registered new interface driver hub
[    0.011098] usbcore: registered new device driver usb
[    0.011889] clocksource: Switched to clocksource arm_global_timer
[    0.012253] NET: Registered protocol family 2
[    0.012498] TCP established hash table entries: 8192 (order: 3, 32768 bytes)
[    0.012537] TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
[    0.012597] TCP: Hash tables configured (established 8192 bind 8192)
[    0.012646] UDP hash table entries: 512 (order: 2, 16384 bytes)
[    0.012671] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[    0.012747] NET: Registered protocol family 1
[    0.012762] PCI: CLS 0 bytes, default 64
[    0.013552] Crashlog allocated RAM at address 0x3f00000
[    0.013700] workingset: timestamp_bits=30 max_order=19 bucket_order=0
[    0.015289] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.015297] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.016552] bounce: pool size: 64 pages
[    0.016561] io scheduler noop registered
[    0.016565] io scheduler deadline registered (default)
[    0.017007] armada-38x-pinctrl f1018000.pinctrl: registered pinctrl driver
[    0.017366] GPIO line 19 (phy1-reset) hogged as output/low
[    0.018147] mv_xor f1060800.xor: Marvell shared XOR driver
[    0.072381] mv_xor f1060800.xor: Marvell XOR (Descriptor Mode): ( xor cpy intr )
[    0.072493] mv_xor f1060900.xor: Marvell shared XOR driver
[    0.132318] mv_xor f1060900.xor: Marvell XOR (Descriptor Mode): ( xor cpy intr )
[    0.132476] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.133161] console [ttyS0] disabled
[    0.153228] f1012000.serial: ttyS0 at MMIO 0xf1012000 (irq = 23, base_baud = 15625000) is a 16550A
[    0.757261] console [ttyS0] enabled
[    0.781004] f1012100.serial: ttyS1 at MMIO 0xf1012100 (irq = 24, base_baud = 15625000) is a 16550A
[    0.791445] loop: module loaded
[    0.794921] ahci-mvebu f10a8000.sata: AHCI 0001.0000 32 slots 2 ports 6 Gbps 0x3 impl platform mode
[    0.804000] ahci-mvebu f10a8000.sata: flags: 64bit ncq sntf led only pmp fbs pio slum part sxs
[    0.813119] scsi host0: ahci-mvebu
[    0.816692] scsi host1: ahci-mvebu
[    0.820165] ata1: SATA max UDMA/133 mmio [mem 0xf10a8000-0xf10a9fff] port 0x100 irq 45
[    0.828123] ata2: SATA max UDMA/133 mmio [mem 0xf10a8000-0xf10a9fff] port 0x180 irq 45
[    0.836196] ahci-mvebu f10e0000.sata: AHCI 0001.0000 32 slots 2 ports 6 Gbps 0x3 impl platform mode
[    0.845274] ahci-mvebu f10e0000.sata: flags: 64bit ncq sntf led only pmp fbs pio slum part sxs
[    0.854438] scsi host2: ahci-mvebu
[    0.857970] scsi host3: ahci-mvebu
[    0.861440] ata3: SATA max UDMA/133 mmio [mem 0xf10e0000-0xf10e1fff] port 0x100 irq 46
[    0.869395] ata4: SATA max UDMA/133 mmio [mem 0xf10e0000-0xf10e1fff] port 0x180 irq 46
[    0.886892] m25p80 spi1.0: w25q32 (4096 Kbytes)
[    0.891939] libphy: Fixed MDIO Bus: probed
[    0.896358] libphy: orion_mdio_bus: probed
[    0.901198] mvneta_bm f10c8000.bm: Buffer Manager for network controller enabled
[    0.909980] mvneta f1070000.ethernet eth0: Using random mac address 62:1b:3b:f1:2f:0f
[    0.918841] mvneta f1030000.ethernet eth1: Using random mac address ca:8d:84:4e:b3:85
[    0.927688] mvneta f1034000.ethernet eth2: Using random mac address ba:43:a4:87:07:e8
[    0.935711] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.942257] ehci-pci: EHCI PCI platform driver
[    0.946733] ehci-platform: EHCI generic platform driver
[    0.952044] ehci-orion: EHCI orion driver
[    0.956150] orion-ehci f1058000.usb: EHCI Host Controller
[    0.961570] orion-ehci f1058000.usb: new USB bus registered, assigned bus number 1
[    0.969207] orion-ehci f1058000.usb: irq 41, io mem 0xf1058000
[    1.011892] orion-ehci f1058000.usb: USB 2.0 started, EHCI 1.00
[    1.018046] hub 1-0:1.0: USB hub found
[    1.021816] hub 1-0:1.0: 1 port detected
[    1.026085] xhci-hcd f10f8000.usb3: xHCI Host Controller
[    1.031417] xhci-hcd f10f8000.usb3: new USB bus registered, assigned bus number 2
[    1.038977] xhci-hcd f10f8000.usb3: hcc params 0x0a000990 hci version 0x100 quirks 0x0000000000010010
[    1.048241] xhci-hcd f10f8000.usb3: irq 48, io mem 0xf10f8000
[    1.054203] hub 2-0:1.0: USB hub found
[    1.057973] hub 2-0:1.0: 1 port detected
[    1.062017] xhci-hcd f10f8000.usb3: xHCI Host Controller
[    1.067351] xhci-hcd f10f8000.usb3: new USB bus registered, assigned bus number 3
[    1.074863] xhci-hcd f10f8000.usb3: Host supports USB 3.0  SuperSpeed
[    1.081343] usb usb3: We don't know the algorithms for LPM for this host, disabling LPM.
[    1.089612] hub 3-0:1.0: USB hub found
[    1.093385] hub 3-0:1.0: 1 port detected
[    1.097499] usbcore: registered new interface driver usb-storage
[    1.103917] armada38x-rtc f10a3800.rtc: registered as rtc0
[    1.109556] i2c /dev entries driver
[    1.113285] pca953x 0-0020: 0-0020 supply vcc not found, using dummy regulator
[    1.121128] GPIO line 496 (pcie1.0-clkreq) hogged as input
[    1.126911] GPIO line 499 (pcie1.0-w-disable) hogged as output/low
[    1.133305] GPIO line 501 (usb3-current-limit) hogged as input
[    1.139422] GPIO line 502 (usb3-power) hogged as output/high
[    1.145372] GPIO line 507 (m.2 devslp) hogged as output/low
[    1.161489] (NULL device *): hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
[    1.162895] ata1: SATA link down (SStatus 0 SControl 300)
[    1.173892] orion_wdt: Initial timeout 171 sec
[    1.179134] ata2: SATA link down (SStatus 0 SControl 300)
[    1.183835] sdhci: Secure Digital Host Controller Interface driver
[    1.195173] sdhci: Copyright(c) Pierre Ossman
[    1.204296] ata4: SATA link down (SStatus 0 SControl 300)
[    1.209731] ata3: SATA link down (SStatus 0 SControl 300)
[    1.261894] mmc0: SDHCI controller on f10d8000.sdhci [f10d8000.sdhci] using ADMA
[    1.269403] sdhci-pltfm: SDHCI platform and OF driver helper
[    1.275937] marvell-cesa f1090000.crypto: CESA device successfully registered
[    1.283496] NET: Registered protocol family 10
[    1.289476] Segment Routing with IPv6
[    1.293188] NET: Registered protocol family 17
[    1.297656] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.312004] 8021q: 802.1Q VLAN Support v1.8
[    1.316235] Registering SWP/SWPB emulation handler
[    1.322275] mvebu-pcie soc:pcie: /soc/pcie/pcie@2,0: reset gpio is active low
[    1.356330] mmc0: new high speed MMC card at address 0001
[    1.361947] mmcblk0: mmc0:0001 8GTF4R 7.28 GiB
[    1.366536] mmcblk0boot0: mmc0:0001 8GTF4R partition 1 4.00 MiB
[    1.372525] mmcblk0boot1: mmc0:0001 8GTF4R partition 2 4.00 MiB
[    1.378498] mmcblk0rpmb: mmc0:0001 8GTF4R partition 3 512 KiB, chardev (250:0)
[    1.386271]  mmcblk0: p1 p2
[    1.461894] usb 2-1: new high-speed USB device number 2 using xhci-hcd
[    1.652396] usb-storage 2-1:1.0: USB Mass Storage device detected
[    1.658615] scsi host4: usb-storage 2-1:1.0
[    2.722092] scsi 4:0:0:0: Direct-Access     MXT-USB  Storage Device   1109 PQ: 0 ANSI: 0 CCS
[    2.731240] sd 4:0:0:0: [sda] 31116288 512-byte logical blocks: (15.9 GB/14.8 GiB)
[    2.738939] sd 4:0:0:0: [sda] Write Protect is off
[    2.743750] sd 4:0:0:0: [sda] Mode Sense: 03 00 00 00
[    2.743848] sd 4:0:0:0: [sda] No Caching mode page found
[    2.749173] sd 4:0:0:0: [sda] Assuming drive cache: write through
[    2.760766]  sda: sda1
[    2.763693] sd 4:0:0:0: [sda] Attached SCSI removable disk
[    4.321885] pcie1.0: reset completed in 100000us
[    4.326587] mvebu-pcie soc:pcie: PCI host bridge to bus 0000:00
[    4.332531] pci_bus 0000:00: root bus resource [io  0x1000-0xfffff]
[    4.338812] pci_bus 0000:00: root bus resource [mem 0xe0000000-0xe7ffffff]
[    4.345708] pci_bus 0000:00: root bus resource [bus 00-ff]
[    4.351219] pci 0000:00:02.0: [11ab:6828] type 01 class 0x060400
[    4.351306] PCI: bus0: Fast back to back transfers disabled
[    4.356900] pci 0000:00:02.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    4.364957] PCI: bus1: Fast back to back transfers enabled
[    4.370457] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    4.370468] pci 0000:00:02.0: PCI bridge to [bus 01]
[    4.375562] libphy: SFP I2C Bus: probed
[    4.380000] random: fast init done
[    4.384312] armada38x-rtc f10a3800.rtc: setting system clock to 2020-06-09 12:13:00 UTC (1591704780)
[    4.395012] EXT4-fs (mmcblk0p2): INFO: recovery required on readonly filesystem
[    4.402352] EXT4-fs (mmcblk0p2): write access will be enabled during recovery
[    4.423122] EXT4-fs (mmcblk0p2): recovery complete
[    4.428842] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
[    4.436978] VFS: Mounted root (ext4 filesystem) readonly on device 179:2.
[    4.444344] Freeing unused kernel memory: 1024K
[    4.507047] init: Console is alive
[    4.510513] init: - watchdog -
[    4.547566] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.556162] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.564078] init: - preinit -
[    4.623991] mvneta f1070000.ethernet tmp0: renamed from eth0
[    4.630274] random: procd: uninitialized urandom read (4 bytes read)
[    4.673364] mvneta f1030000.ethernet eth0: renamed from eth1
[    4.713302] mvneta f1034000.ethernet eth1: renamed from eth2
[    4.763273] mvneta f1070000.ethernet eth2: renamed from tmp0
[    4.821584] random: jshn: uninitialized urandom read (4 bytes read)
[    4.837822] random: jshn: uninitialized urandom read (4 bytes read)
[    4.876427] mvneta f1034000.ethernet eth1: configuring for SGMII/sgmii link mode
[    4.884254] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[    7.926090] mount_root: mounting /dev/root
[    7.930979] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[    8.028444] EXT4-fs (mmcblk0p1): mounted filesystem without journal. Opts: (null)
[    8.078182] urandom-seed: Seeding with /etc/urandom.seed
[    8.100812] procd: - early -
[    8.103748] procd: - watchdog -
[    8.709248] procd: - watchdog -
[    8.712489] procd: - ubus -
[    8.719128] urandom_read: 3 callbacks suppressed
[    8.719131] random: ubusd: uninitialized urandom read (4 bytes read)
[    8.765584] random: ubusd: uninitialized urandom read (4 bytes read)
[    8.772031] random: ubusd: uninitialized urandom read (4 bytes read)
[    8.778587] procd: - init -
[    8.845228] kmodloader: loading kernel modules from /etc/modules.d/*
[    8.853368] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    8.864464] urngd: v1.0.2 started.
[    8.864692] ip_tables: (C) 2000-2006 Netfilter Core Team
[    8.874941] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[    8.889497] xt_time: kernel timezone is -0000
[    8.894119] random: crng init done
[    8.896330] PPP generic driver version 2.4.2
[    8.897533] random: 1 urandom warning(s) missed due to ratelimiting
[    8.902292] NET: Registered protocol family 24
[    8.913516] kmodloader: done loading kernel modules from /etc/modules.d/*
[   10.712821] mvneta f1030000.ethernet eth0: PHY [f1072004.mdio-mii:01] driver [Marvell 88E1510]
[   10.728399] mvneta f1030000.ethernet eth0: configuring for phy/sgmii link mode
[   10.736070] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   14.002251] mvneta f1030000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[   14.010114] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

#ifconfig

root@OpenWrt:/# ifconfig
eth0      Link encap:Ethernet  HWaddr 3A:83:65:82:23:C5
          inet addr:192.168.0.50  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::3883:65ff:fe82:23c5/64 Scope:Link
          inet6 addr: fdf6:2f1a:502a::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1095 errors:0 dropped:106 overruns:0 frame:0
          TX packets:228 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:101097 (98.7 KiB)  TX bytes:12054 (11.7 KiB)
          Interrupt:39

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1025 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1025 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:93593 (91.3 KiB)  TX bytes:93593 (91.3 KiB)

It is not obvious from both the dmesg you posted. In both cases only eth0 comes up, which I suppose is one of the copper ethernet lan ports.
So if it is not eth1, SFP will be eth2.

at the moment eth1 is the right port and my local network is connected with that. the left ethernet port not work, but when i make a bridge

LAN => Edit => Physical Settings
eth0 and eth2

the left lan port work

so i don't think that eth2 is the sfp port

The when you plug in the cable in the SFP, you should see it coming up in dmesg and ifconfig -a

if i insert the module i get this error, what can be the problem here? I am currently on version 18.06.8. and here you can see that sfp is on eth2. but i get his error

root@OpenWrt:/# [   77.121857] random: crng init done
[   77.125270] random: 2 urandom warning(s) missed due to ratelimiting
[   77.572917] sfp sfp: module FS               SFP-GE-BX        rev A0   sn G1910080274      dc 12-11-19
[   77.582255] sfp sfp:   LC connector, encoding 8b10b, nominal bitrate 1.3Gbps +0% -0%
[   77.590016] sfp sfp:   1000BaseSX- 1000BaseLX- 1000BaseCX- 1000BaseT- 100BaseTLX- 1000BaseFX- BaseBX10- BasePX-
[   77.600134] sfp sfp:   10GBaseSR- 10GBaseLR- 10GBaseLRM- 10GBaseER-
[   77.606420] sfp sfp:   Wavelength 1310nm, fiber lengths:
[   77.611744] sfp sfp:     9µm SM    : 20000m
[   77.616026] sfp sfp:  62.5µm MM OM1: unsupported/unspecified
[   77.621784] sfp sfp:    50µm MM OM2: unsupported/unspecified
[   77.627545] sfp sfp:    50µm MM OM3: unsupported/unspecified
[   77.633306] sfp sfp:    50µm MM OM4: unsupported/unspecified
[   77.639066] sfp sfp:   Options: txdisable, txfault, los+
[   77.644392] sfp sfp:   Diagnostics: ddm, intcal, rxpwravg
[   77.649809] mvneta f1034000.ethernet eth2: validation of 802.3z/1000base-x with support 00000,00002440 failed: -22
[   78.432244] sfp sfp: module removed

From what I can see the SFP is single mode only. I am not sure why it failed the validation. Have you tested this SFP and it worked on another device already?
Did you unplug the SFP and the last message was displayed or was it automatically?
Do you see the eth2 in the list of interfaces if you run ifconfig -a ?

yes this SFP work in another device (TIM HUB DGA4132 running by stock openwrt 15.05), no i don't unpluged the sfp, yes it was automatically. Yes i see eth2 in the output ifconfig -a

for info: my ftth internet is Point to Point and not GPON

If the eth2 is visible in ifconfig -a then maybe it is not that bad.
Did you try to use it ?

config interface 'wan'
	option ifname 'eth2.10'
	option proto 'pppoe'
	option ipv6 'auto'
	option username '22xxxxxxxxxxxx@ppp.brennercom.net'
	option password '1111111111'
1 Like