Cisco ON100-K9_V02

I bought a Cisco onplus device, wanting to flash openwrt on it. It simply refuses to tftp the image from a tftp server. My situation is: pfsense firewall with dhcp option 66 and 150 pointing to tftp server. tftpd64 on win10 laptop with al firewall stuff of (i'm not really *nix experienced).

I've set the variable "serverip" with setenv to the tftp server. Before i did this, it always wanted to tftp the image from an unknown 66...* ip address. Now it says it wants to tftp the image from the proper ip addr. , but still gives an error: " file not found or no access".

To make things worse: i just found out that i have a ON100_K9_V02 device. It seems there is a version two onplus device? I'm lost in what to do next.

         __  __                      _ _
        |  \/  | __ _ _ ____   _____| | |
        | |\/| |/ _` | '__\ \ / / _ \ | |
        | |  | | (_| | |   \ V /  __/ | |
        |_|  |_|\__,_|_|    \_/ \___|_|_|
 _   _     ____              _
| | | |   | __ )  ___   ___ | |_
| | | |___|  _ \ / _ \ / _ \| __|
| |_| |___| |_) | (_) | (_) | |_
 \___/    |____/ \___/ \___/ \__|
 ** MARVELL BOARD: DB-88F6282A-BP LE

U-Boot 1.1.4 (Feb 22 2011 - 14:06:09) Marvell version: 3.5.9 - Cisco Plasma

U-Boot code: 00600000 -> 0067FFF0  BSS: -> 006D2340

Soc: 88F6282 A1CPU running @ 1600Mhz L2 running @ 533Mhz
SysClock = 400Mhz , TClock = 200Mhz

DRAM (DDR3) CAS Latency = 6 tRP = 6 tRAS = 15 tRCD=6
DRAM CS[0] base 0x00000000   size 256MB
DRAM CS[1] base 0x10000000   size 256MB
DRAM Total size 512MB  16bit width
Addresses 8M - 0M are saved for the U-Boot usage.
Mem malloc Initialization (8M - 7M): Done
NAND:512 MB
Flash:  0 kB

CPU : Marvell Feroceon (Rev 1)

Streaming disabled
Write allocate disabled

Module 0 is RGMII

USB 0: host mode
PEX 0: interface detected no Link.
PEX 1: interface detected no Link.
Net:   egiga0 [PRIME], egiga1
Hit any key to stop autoboot:  0
Plasma>>

I cannot find your device listed under the table of supported hardware.

https://openwrt.org/toh/start

Search for Cisco and model ON100

1 Like

Odd, I had to type the model number...

This leads you to v01, but you have

This is true, i mentioned this in first post. Up until today i didnt even know there was a V02. I found out this afternoon whilst inspecting what is printed on the bottom of the device (should have been the first thing i did...) , i havent found any differences up until now ,uboot screen looks the same. same cpu, same ram and flash, same board .

1 Like

I have the printenv output and full bootlog, how can i upload these to this thread?

Made a little progress; running tftpd on a win10 machine seems a bad idea. and old winxp laptop with tftpd32 gives a better result. problem now is that the on100 starts loading the image, but stops after a short while. device freezes.

Your issue may be that the hardware in the V2 is different than the V1.

Do you know the internal specs of the hardware?

Yes, i'm trying to find out if there is any difference.
cpu is marvell 88f6bk12
flash is hynix HY27UF084G2B
ram is 4x hynix H5TQ1G83DFR
nics 2x 88e1310-nnb2IMG_5741

cpu + underside board. still cant find any differences...IMG_5746 IMG_5743

Still trying to get that firmware file loaded. Keeps getting stuck at 61% . tftpd says it's waiting for an ack reply, the onplus is at that time unresponsive , can't cancel trough serial console, only thing left then is power cycle the device. Still not sure what is going wrong. Even when there is a difference in design with v01, i'm not even getting to the point of flasing the firmware, so i dont know if the v01 openwrt image would run. Anyone has any idea?

I've tryed tftpd32 on both win10 64bit machine and 32bit win.xp laptop. Both get stuck at 61% when loading firmware. I cant get the solarwinds tftp server to work. On both machines it installs fine, but cant started, whatever i try. The program starts, but as soon as i try to start the server it stops again. On both win10_64 and win-xp_32 .

solarwinds tft server was no succes; couldnt get it to start on numerous machines and various platforms. I did however succes in running tftpd32 on win10 laptop. With firewall off , running tftpd64 as administrator, the on100 does exactly what it did before: it loads the firmware exactly to 61%, then the on100 freezes. The tftp server gives the exact same error message: "timeout waiting for ack block ....."

As anyone ever succeeded in flashing the on100 device other then the person who initially got it to work and created the wiki entry?

Strange thing is that there are two ways explained how one should flash the device: first is to just flash one ~8mb image (which doesnt work), second is a two step flash, beginning with a initramfs-uimage file of about 3mb (that probably should work since tftp freezes at about 4mb), and a rootfs-ubi file. The wiki does not explain why these two different methods exist or which one should be used. I have no way of building the firmware for this device myself and i have a strong feeling that the wiki is not right.

https://openwrt.org/toh/cisco/cisco_on-100_k9_v01

Anyone. Is there maybe a way to get in contact with the guy who got this to work in the first place? Seems to me the wiki is not correct: it first mentions tftp-ing one big binary; further down the wiki it mentions two seperate files. But in the openwrt repository there is only one big binary to be found which doesnt work.

Well, since there is nobody who can/will help, i give up. I have no way of finding the guy who original "made this work", keep getting stuck uploading the firmware. For those who want to try this device, BEWARE! I do not see any difference between v1 and v1, bootloader output seems exactly the same. The wiki first mentions uploading one big firmware file, and later on two separate files. Those two file mentioned in the second part of the wiki cant be found, and as mentioned, the first one doesnt work. If anyone ever reads this and gets this to work, dont hesitate to reply to this thread. For archival purposes, this is about the cisco onplus ( original ON100-K9 V1 , my device is the ON100-K9 V2 ).

I've just installed the same hardware and it did work : Cisco ON100 K9 V02.

The wiki entry is almost ok. The two separate files thing is when you do build from the sources. Don't go this way, just go for the first option : downloading the firmware.

My two cents : don't use the firmware url given in the wiki - it's the snapshot version - go for the stable one here :
http://downloads.openwrt.org/releases/18.06.1/targets/kirkwood/generic/
there you want the : cisco_on100-squashfs-factory.bin

I've renamed this long file to "squashfs-factory.bin" and changed accordingly the commands in the U Boot command line to :

dhcp
setenv serverip 192.168.1.66
tftpboot ${loadaddr} squashfs-factory.bin
nand erase 0x0c0000 ${filesize}
nand write ${loadaddr} 0x0c0000 ${filesize}

As you see, my own PC (windows 7) which was running the TFTP server (in my case PumpKIN) has an IP address of 192.168.1.66 . Of course you will have to change this parameter to fit your own configuration.

There's however a typo that must be corrected in the wiki ( Cisco ON-100 k9_v01 ) : backslashes must be added to escape the semicolons in the line :

setenv bootcmd nand read ${loadaddr} 0x0c0000 0x540000; setenv bootargs; bootm

So the correct line should be :

setenv bootcmd nand read ${loadaddr} 0x0c0000 0x540000 \; setenv bootargs \; bootm
saveenv

But once again, it works with the V02, and you can check it easily in the pictures there :

https://openwrt.org/_detail/media/cisco/on100_base.jpg?id=toh%3Acisco%3Acisco_on-100_k9_v01

As you can see, the hardware used is indeed a V02, despite the topic name !!!

P.S. : One critical warning : when you'll install openwrt on your Cisco ON100-K9, take care to remove from your lan the device having the IP adress 192.168.1.1. It's the one that your OpenWrt device will assign to itself by default. So have, for example, a lan on the 192.168.1.xxx range and be careful to assign the router address to 192.168.1.254 (and set it as the gateway address on the other devices living on this lan, at least for the time of the Openwrt install).