Cisco Meraki MX64/MX65 image support

Thanks for the latest images Leo-PL
I was able to flash the MX64 A0 successfully. Everything seems to work but I need to build a version with luci.

I'm trying to compile. Sorry for the noobs questions, I'm just learning how to do it.
I just :
-git clone https://github.com/Leo-PL/openwrt/tree/meraki-mx65
I follow the quickstart of your git (execute feeds scripts).
When I do make menuconfig I can't see any mx65 related target (BCM95x) in the menu. I select the most similar target (BCM53xx) just to know if I correct installed the toolchain. and after compiling I can see the result in target in build_dir folder. (But just meraki_mr32 bcm53xx related target)
My goal is to learn how to compile mx65 with additional packages (Luci and mwan3)

bcm53xx is correct target. But then you have to select device in the next menu, it probably defaults to MR32. Here switch it to MX64 or MX65, or select "multiple devices" and select the right device there. Then the results are in bin subdirectory.

Hi,

I ran into the same problem but figured out the issue. You need to checkout meraki-mx65 to get the correct branch / tag. This is the sequence of commands I used:

git clone https://github.com/Leo-PL/openwrt.git
cd openwrt/
git checkout meraki-mx65
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig
make -j$(nproc) defconfig download clean world

If my images with luci and some other useful apps build and install OK I'll share them over here.

1 Like

That worked out OK and both my MX64 and MX65 are now running kernel 5.15 images with luci and some other useful apps.

The sysupgrade files can be downloaded from the link below. They assume you are already on the latest u-boot. They are based on kernel 5.15 so probably best to sysupgrade -n to not keep your previous settings.

https://we.tl/t-mU3ipQ2Qs4

Thank you so much!! You are my hero!!. I was stuck for a few days trying to figure out how to compile and I was even near to abandon.
Now I can choose Mx65 and I'm playing to include different packages.
The compilation always stopped building "tools/tar", but reading the log I can make it writing this before compiling:
FORCE_UNSAFE_CONFIGURE=1
export FORCE_UNSAFE_CONFIGURE

I don't know what happened, I had it turned off for a long time, I had the first version made available by clayface

I had done the installation correctly and was waiting for a more mature version, after almost 2 years I decided to call it to update, but it is like this.

What do you think has become rubbish?

Boot image format has changed since that - you probably need U-boot upgrade. See https://github.com/openwrt/openwrt/pull/3996#issuecomment-1816935540

wow, thank you so much! I'll test it out accordingly :smiley:

Hi!I am new at OpenWRT and just got one MX65 and run it well,
But I have some questions,

1: Is any one luci-upnp works fine??I`m install luci-upnp and minipnpc, then I can see upnp table at luci, but when I checked the ||Start UPnP and NAT-PMP service||, nothing works and nothing happend, is it anything wrong?

2: Is it possable to update kernel to 5.15.147?? cause some luci app needs the newer kernel but I`m not sure if MX65 can update to 5.15.147.

Hi.
Is the POE+ working fine with openWRT? Can someone make some WAN->LAN iperf3 test? What is usage % of CPU when is NAT on full speed?