Cifsd - in kernel daemon

LuCI an 19.07 and master moved some things to client side JS. It is unrelated to LuCI2 but borrows many features from it.

Ah oki i checked some of those new .js mods and the actual page seems similar enough. Yet i noticed those extra luci defaults and acl files under /root? Whats the deal with those, seems we need to define those now too if used with the .js stuff?

So i assume the .js stuff is the new way to-do luci and is preferred now (aka performance)?

The client side JS will communicate with the device solely through ubus-rpc, which is governed by extra ACLs which restrict the methods which can be invoked from an (authenticated) client.

ok thanks, will play around with this a bit and try to switch samba4 to it, so cifsd/samba4 use the same luci stuff.

PS: Except for the auto-docs ( is there a new docu for the stuff and do i use the same i18 scripts for the translation stuff?

Translations work exactly as before.

Sorry for my mistake.

And I can help porting samba4 to client side.

Thanks, trying to figure this out myself and if i can now somehow dynamically hide some share options (MacOS stuff). I also want to add some version info, so its easier to report the version/git-number on problems.

PS: Still not sure if i want to rename the "Network Shares" section per package (cifsd/samba4) since technically you could run both at the same time. What happens than, do we get two "Network Shares" entries or is the later overwriting the first?

1 Like

dynamically hide some share options

You can just don't add that option on render.

What happens than, do we get two "Network Shares" entries or is the later overwriting the first?

get two "Network Shares"

@lamelogin i just finished testing with 19.07 on my spare router and all worked fine, so PR are up and rdy for testing if merged.


Quick note: There is some luci/js code related problem/bug that prevents all the 'no' UCI options to-be written to the config. This means read only = no is not written anymore and as a result the shares are not write-able anymore.

As temp fix add option writeable = yes to your uci share config.

Very happy to see it getting merged into 19.07, thank you for your work (and jow for curating.)



Initial tests are looking good. No issues so far, I will try to stress it a little bit with some robocopy backups.

Device: Linksys WRT32X
OS: OpenWrt 19.07-SNAPSHOT r10752-1859391e9e

Actually, looks like the "option interface" isn't being respected? Note: this machine is acting as a wired Dumb Access Point.

root@machinex:~# netstat -an | egrep 445
tcp        0      **0**:445   *               LISTEN

root@machinex:~# ifconfig br-lan
br-lan    Link encap:Ethernet  HWaddr 62:38:E0:D0:02:A0
          inet addr:  Bcast:  Mask:

Tested the changes to the luci/js code and it works great. Can connect and write to the partition.
Interface is working now.

@Andy2244 awesome job and very fast fix. 6 hours after I mentioned it he fixed it!!!!

I usual use the master but glad it will make it to 19.07

Not a bug, see explanation here:

Any reason luci-app-cifsd is not part of the master of openwrt GitHub anymore? -- It is still in 19.07
I noticed today when I did a git pull to ge the lasted code.


I just upgraded to 19.07.0 on a Linksys WRT32X. I don't see the cifsd or the luci version of the package anymore. Did I mess something up?

root@xxx:~# opkg list | wc -l
root@xxx:~# opkg list | egrep -i cifsd
samba4-client - 4.11.4-1 - installs: cifsdd smbclient smbget  The smbclient program implements a simple ftp-like client for accessing SMB shares
root@xxx:~# cat /etc/opkg/distfeeds.conf
src/gz openwrt_core
src/gz openwrt_kmods
src/gz openwrt_base
src/gz openwrt_luci
src/gz openwrt_packages
src/gz openwrt_routing
src/gz openwrt_telephony

Yes, Smbd (Samba4 alternative, ex cifsd) package support thread