Chromecast on kids network

Hi, I use google transalate because I am not strong in english writing. read english no problem.

I've been trying for several weeks through this forum looking for a solution: connect chromecast(multicast) on interface wifi network kids.

Network structure ISP network (DHCP) to openwrt route lan (lan to lan)

i tried all kinds of things but fail or connect to chromecast: Chromecast across two subnets
impgproxy
smcroute

Maybe I forgot to set something?

config show
-------
DHCP
------

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'Gast'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'Gast'

config dhcp 'kids'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'kids'
        option ra 'server'
        option dhcpv6 'server'
        option ra_management '1'
        list dns '2a07:a8c0::a4:c29e'
        list dns '2a07:a8c1::a4:c29e'

------------
firewall
------------

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option masq '1'
        list network 'lan'
        list network 'kids'

config include
        option path '/etc/firewall.user'

config zone
        option network 'Gast'
        option forward 'REJECT'
        option name 'Gast'
        option output 'ACCEPT'
        option input 'REJECT'

config forwarding
        option dest 'lan'
        option src 'Gast'

config rule
        option dest_port '67-68'
        option src 'Gast'
        option name 'Gast DHCP'
        option target 'ACCEPT'
        list proto 'udp'

config rule
        option dest_port '53'
        option src 'Gast'
        option name 'Gast DNS'
        option target 'ACCEPT'

config rule
        option src 'Gast'
        option name 'Gast isolatie'
        option dest 'lan'
        option target 'DROP'
        list dest_ip '192.168.10.1/24'
        list proto 'all'

--------
network
-------

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd78:bdf3:5be2::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.10.1'
	list dns '195.130.130.11'
	list dns '1.1.1.1'
	list dns '195.130.130.139'
	list dns '1.0.0.1'
	option ipaddr '192.168.10.50'
	option igmp_snooping '1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t'
	option vid '2'

config interface 'Gast'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.2.1'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option type 'bridge'
	option ip6assign '60'

config interface 'kids'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.3.1'
	list dns '45.90.28.87'
	list dns '45.90.30.87'
	option ip6assign '60'
	option igmp_snooping '1'

----------
nextdns
----------

config nextdns 'main'
	option enabled '1'
	option setup_router '1'
	option report_client_info '1'
	option hardened_privacy '0'
	option log_queries '0'
	list listen 'localhost:53'
	option control '/var/run/nextdns.sock'
	option cache_max_age '0s'
	option auto_activate '0'
	option cache_size '0'
	option use_hosts '1'
	option max_ttl '0s'
	option detect_captive_portals '0'
	option bogus_priv '1'
	option timeout '5s'
	option config 'a4c29e'
	option log_query '0'

---------
Wifi
---------

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'JacobsSips'
	option key '***'
	option encryption 'psk2'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option country 'BE'
	option htmode 'HT20'
	option channel '3'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key '***'
	option ssid 'JacobsSips'
	option encryption 'psk2'

config wifi-iface 'wifinet2'
	option ssid 'JacobsSips Gast'
	option encryption 'psk2'
	option device 'radio1'
	option mode 'ap'
	option key 'gast1234'
	option network 'Gast'

config wifi-iface 'wifinet3'
	option ssid 'JacobsSips Kids'
	option encryption 'psk2'
	option device 'radio1'
	option mode 'ap'
	option key '***'
	option network 'lan kids'

-----
root@OpenWrtWoonkamer:/etc/config# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.c46e1fb85062       no              eth1.1
                                                        wlan0
                                                        wlan1
br-Gast         7fff.c66e1fb85062       no              wlan1-1
br-kids         7fff.c26e1fb85062       no              wlan1-2

With friendly greetings
Tom

If you're connecting LAN-LAN why the dhcp on the openwrt unit, if there's already one on the ISPs device?

Sure you don't want https://openwrt.org/docs/guide-user/network/wifi/dumbap ?

volg je voorstel oplossing is niet ideaal situatie.
ik wil kunnen gast netwerk(dhcp) en kids netwerk (dnsnext) kunnen instellen.
daarmee firewall uitschakelen is niet mogelijk.

english , please

Chromecast relies on multicast DNS, which uses broadcast packets which are not forwarded between networks by routers. You need a dedicated relay service such as avahi running on the router. I have not set this up myself, but you should be able to find information by searching these forums and the web generally.