CheckSum Error when attempting install on TP-Link RE650

I am attempting to use the TP-Link OEM firmware upgrade page to install the latest OpenWRT please candidate openwrt-21.02.0-rc3-ramips-mt7621-tplink_re650-v1-squashfs-factory.bin on my RE650 v1.

According to the Wiki ( it looks like this should be supported, however I am getting a firmware checksum error.

Are there any tips or guides for installing OpenWRT on the RE650?

According to the instructions in the commit, that should just work. However, in the meantime TP-Link might have issued newer firmwares with additional checks. Try downgrading the OEM firmware to an older version (preferably from around the time when support was added).

Thank you @Borromini. I have tried downgrading to the official RE650(UK)_V1_190521 as well as the RE650(UK)_V1_180719 firmwares but still face the same error.

Managed to work around the issue by installing the latest snapshot without LuCI openwrt-ramips-mt7621-tplink_re650-v1-squashfs-factory.bin instead one of the release candidates.

Unfortunately this required me to manually configure the dns and gateway before I was able to internet connectivity on the RE650 in /etc/config/network

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr ''
	option dns 'WAN DNS/ROUTER'
	option gateway 'WAN ROUTER'
	option netmask ''
	option ip6assign '60'

Finally I was install LuCI via the online guide -

opkg update
opkg install luci-ssl

That sounds weird. Do you have serial and do you know how to recover (no idea if the serial header is readily accessible on that model)? If so, then you could try a downgrade with sysupgrade to RC3 (without keeping settings) and see if that bricks. I'm seeing just a single commit for RE650 v1 device support in the logs, nothing else that should touch the installation process.

Hi @Borromini I can confirm that I experience the same behaviour as mentioned by @milmber when trying to install any of the 21.02.0-rc releases on my RE650 v1.