Checking my WWAN card on a ThinkPad T420

I have a ThinkPad T420 which has a
Sierra Wireless Inc Sierra Wireless MC8355 - Gobi 3000(TM) Module
and a SIM card slot. Should I be able to install OpenWrt and see if it works as a 3G router? If it does work, I'd think about replacing the card with a 4G card.

Using it as a router should work, but will not be optimal. The wifi card might not be usable as an ap, and there will be only one wifi radio in any case. But it should be fine as an ethernet to wwan router.

Replacing the wwan card is not possible without patching the bios. Lenovo whitelists the supported cards. This prevents any easy wwan card switch.

It can be fun recycling a laptop like this. But that is the only reason I see...

I had heard about whitelists and did try updating the BIOS in a ThinkPad X61, from which it never recovered...

But as it is now, should I be able to get it working as a 3G Router?

I've never configured a WWAN card on OpenWrt. Where should I look for guidance?

Yes, it should work as an ethernet to 3g router. See https://openwrt.org/docs/guide-user/network/wan/wwan/start

The wwan card is supported by the qmi_wwan driver.

1 Like

When the system boots should it identify my WWAN card?

When I boot FreeBSD it tells me I have a

ugen1.4: <Sierra Wireless Inc Sierra Wireless MC8355 - Gobi 3000(TM) Module> at usbus1

Should I see something similar in dmesg?

It will only say "New high speed USB device" without a kernel driver installed. Desktop OS has many drivers pre-installed. On OpenWrt you have to install them separately.

Does this look ok?


root@OpenWrt:~# dmesg | grep high
[    0.096173] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[    0.096176] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
[    0.096207] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    1.444857] usb 1-1: new high-speed USB device number 2 using ehci-pci
[    1.464850] usb 2-1: new high-speed USB device number 2 using ehci-pci
[    1.892855] usb 1-1.1: new high-speed USB device number 3 using ehci-pci
[    1.912829] usb 2-1.4: new high-speed USB device number 3 using ehci-pci
[    2.116771] usb 1-1.6: new high-speed USB device number 4 using ehci-pci

You can install usbutils then run lsusb to see more details of what is on the USB bus. But the best way is to look up the card name, or boot a desktop Linux and see which driver it runs.

Thanks, this is what lsusb shows me:-

root@OpenWrt:~# lsusb
Bus 002 Device 003: ID 1199:9013 Sierra Wireless Inc Sierra Wireless MC8355 - Gobi 3000(TM) Module
Bus 001 Device 004: ID 04f2:b221 Chicony Electronics Co., Ltd. Integrated Camera
Bus 001 Device 003: ID 1221:3234 USB2.0 Flash Disk
Bus 001 Device 002: ID 8087:0024  
Bus 001 Device 001: ID 1d6b:0002 Linux 5.4.111 ehci_hcd EHCI Host Controller
Bus 002 Device 002: ID 8087:0024  
Bus 002 Device 001: ID 1d6b:0002 Linux 5.4.111 ehci_hcd EHCI Host Controller

So I guess I need a driver for this Sierra MC8355 card...

I did a search and came up with this post:-

but can't really make much sense of it.
Any suggestions for an appropriate driver?

That's qmi_wwan and qcserial. OpenWrt packages kmod-usb-net-qmi-wwan and kmod-usb-serial-qualcomm

EDIT: wrt the thread you refer to: Do not follow that. You are quite right: It doesn't make sense. Force using the option driver for this modem is positively wrong. And the driver unregisteri issue is most likely due to a platform problem, and completely unrelated to the modem.

Thanks, done that now. Do I need to reboot to see if they are installed?

So now, do I need to enable the WAN interface in /etc/config/network ?

I'm looking at:-

Should I follow this example:-

config interface wan
#        option ifname  ppp0 # on some carriers enable this line
        option pincode 1234
        option device  /dev/ttyUSB0
        option apn     your.apn
        option service umts
        option proto   3gtype or paste code here

no, you should follow the qmi examples. Don't worry anout the "LTE". The configuration is independent of generation, and applies both to your 3G modem and to newer 5G modems.

Hmm, I see that the qmi instructions are really bad. Mixing all sorts of optional stuff, without actually showing a real working example config. And focusing on low-level debugging which you really shouldn't need to care about at all. Not sure I'm ready to rewrite it, though....

Something like this should work, I believe - completely untested:

config interface wan
        option proto  'qmi'
        option ifname 'wwan0'
        option device '/dev/cdc-wdm0'
        option pincode '1234'
        option apn 'your.apn'

You'll need to replace the pin code and apn with your values, obviously.

I'm not sure whether your modem supports dhcp or not. You may also have to add option dhcp 0 to the above.

EDIT: Not that you'll need the uqmi package for the above

1 Like

At what point can I try talking to the modem, ie not to the ISP, but to the modem itself? Presumably the modem will get an IP address from the ISP...

Can I tell if a SIM card is present?

After a reboot, dmesg tells me:-

[    8.529773] usbcore: registered new interface driver usbserial_generic
[    8.531076] usbserial: USB Serial support registered for generic
[    8.532877] xt_time: kernel timezone is -0000
[    8.535677] PPP generic driver version 2.4.2
[    8.536782] NET: Registered protocol family 24
[    8.542709] qmi_wwan 2-1.4:1.0: cdc-wdm0: USB WDM device
[    8.543946] qmi_wwan 2-1.4:1.0 wwan0: register 'qmi_wwan' at usb-0000:00:1d.0-1.4, WWAN/QMI device, 1a:9a:ae:ff:a7:be
[    8.545360] usbcore: registered new interface driver qmi_wwan
[    8.548188] usbcore: registered new interface driver qcserial
[    8.549277] usbserial: USB Serial support registered for Qualcomm USB modem
[    8.553630] qcserial 2-1.4:1.1: Qualcomm USB modem converter detected
[    8.554901] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB0
[    8.558690] qcserial 2-1.4:1.2: Qualcomm USB modem converter detected
[    8.560277] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB1
[    8.566601] qcserial 2-1.4:1.3: Qualcomm USB modem converter detected
[    8.568113] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB2
[    8.569961] kmodloader: done loading kernel modules from /etc/modules.d/*
[   10.292702] br-lan: port 1(eth0) entered blocking state
[   10.295826] br-lan: port 1(eth0) entered disabled state
[   10.299008] device eth0 entered promiscuous mode
[   13.166216] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Txtype 

ifconfig tells me:-

br-lan    Link encap:Ethernet  HWaddr 00:21:CC:C0:D4:DE  
          inet addr:192.168.1.82  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fdb0:d009:c150::1/60 Scope:Global
          inet6 addr: fe80::221:ccff:fec0:d4de/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:221 errors:0 dropped:0 overruns:0 frame:0
          TX packets:268 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:21372 (20.8 KiB)  TX bytes:125304 (122.3 KiB)

eth0      Link encap:Ethernet  HWaddr 00:21:CC:C0:D4:DE  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:221 errors:0 dropped:0 overruns:0 frame:0
          TX packets:275 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:25350 (24.7 KiB)  TX bytes:127004 (124.0 KiB)
          Interrupt:20 Memory:f2500000-f2520000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:56 errors:0 dropped:0 overruns:0 frame:0
          TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5943 (5.8 KiB)  TX bytes:5943 (5.8 KiB)

Shouldn't I expect the modem to provide an interface?

Did you set up a network of proto qmi like @bmork said?

You will of course need an active SIM card from a company that offers 3G service in your area. The SIM card slot should be under a panel in the bottom of the laptop either the same one that holds the modem or nearby.

Here is my /etc/config/network :-

config interface 'loopback'
<------>option ifname 'lo'
<------>option proto 'static'
<------>option ipaddr '127.0.0.1'
<------>option netmask '255.0.0.0'

config globals 'globals'
<------>option ula_prefix 'fdb0:d009:c150::/48'

config interface 'lan'
<------>option type 'bridge'
<------>option ifname 'eth0'
<------>option proto 'dhcp'
#<----->option ipaddr '192.168.1.1'
#<----->option netmask '255.255.255.0'
<------>option ip6assign '60'

config interface wan
        option proto  'qmi'
        option ifname 'wwan0'
        option dhcp    '0'
        option device '/dev/cdc-wdm0'
#        option pincode '1234'
        option apn 'your.apn'..

Sorry about the tabs...I've rebooted but haven't put in the apn yet. Just trying to take things one step at a time.

Is there anything I can run to check the status of the WAN card?

Since I'm stuck with this thing not knowing what to do I installed a copy of Windows 10 to see if I could actually make a connection somewhere... After installing a device driver for the modem I got the Network Connections folder up and it listed the Sierra Wireless MC8355 as a Mobile connection, but showed it as Not Connected. A SIM card which works on my WWAN router has been inserted but I can't get it to connect. I can't find anywhere to enter an APN etc. So at this point I can't tell if the modem has stopped functioning or maybe it is locked.

I do recall something about unlocking these modems some time ago but can't remember specifics.

Can anyone give me a clue?

From what I can gather the modem is locked by Verizon, so I've no idea how to get it unlocked.

I would have thought that there would some sort of command to query the status of the modem but haven't found anything.

The AT+CPIN? query will tell if the modem is carrier locked.