Chaos Calmer 15.05 to 18.06.1 Linksys 1900ACS unable to login

Hi,

I recently upgraded my Linksys 1900ACS to OpenWrt 18.06.1. On reboot the WiFi, WAN and connectivity was all working. Previously I had configured the Luci Web interface but found I wasn't able to connect after the upgrade (I assume as it needs re configuring).

I had previously setup a user separate to root and have the passwords for both saved in a password vault. When I attempt to SSH as the user to Openwrt the connection is closed as soon as I enter the password. If I attempt to login as root using ether the password I saved or the default one it fails to authenticate and after 3rd attempt disconnects me.

I tried putting it into Failsafe Mode as detailed on the Wiki by watching the LED and pressing the red reset button on boot up and also by running a packet capture as the device booted up looking for udp traffic on port 4919 but didn't see anything on either the "Internet" or "LAN 1" connections.

If anyone could give me some pointers I would really appreciate it.

Thanks
Martin

The config from 15.x to 18.x has probably changed enough to cause you problems.

Assuming that 18.06.1 "took", most routers have a "slow" flash (maybe twice a second) during the early boot phase. If you click the proper button a couple times as soon as you see the power light come on (after the boot loader "self-test" cycle, if any), then the light should start flashing more rapidly (maybe four times a second) when it enters failsafe mode. The "window" is only a few seconds long before the router continues into "normal" boot.

Assuming you're successful, the typical failsafe config is the LAN ports on 192.168.1.1/24. Manual configuration of your "desktop" interface on the same subnet should allow you to use ssh to access the router with root as the user.

If that's not successful, there are some IPv6 tricks out there as well.

Hi Jeff,

Thanks for the quick reply. I assume it "took" as wifi and WAN connectivity works (had to apply specific config for SKY fibre).

The challenge I have is knowing which button on the 1900ACS is the button, there are two, one for the WPS (Blue) and a recessed reset button (Red), I assumed it is the red reset button.

I also configured a PC with an IP in the range 192.168.1.0/24 and connected it up to the "internet" port on the Linksys while running tcpdump and didn't see the UDP packet mentioned.

Thanks
Martin

My bet would be on the WPS button instead.

Reading that you set up an additional user, I kind of guesstimate that you also set a non-default shell in the same go. Upgrading however removed this manually installed shell as part of the sysupgrade process, as it's not part of the OpenWrt images - so your users have no valid shell after the upgrade anymore. I strongly suggest to keep busybox ash as shell for root to avoid this issue.

Regardless of that, there will be considerable differences between 15.05.x and 18.06.x, which means starting from scratch (firstboot) is strongly recommended.

Hi slh,

Thanks, in case its useful for others I just waiting until the initial lights blipped then intermittently pressed the reset button and it restarted into failsafe mode.

I reset the root password and also the user password once I had SSH'd in. I also checked the /etc/passwd file and could see the user I created was set to the ash shell.

I reset the passwords using passwd and passwd username and then did a "reboot -f" but when it came back it still doesn't recognise the passwords.

Like you say due to the differences between the two I'll try going for firstboot (I think I can remember how to do sky config piece).

Thanks
Martin

Should probably be able to go back to the 15.05 partition and flash again if needed.

Run firstboot and start from scratch.

https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset?s[]=firstboot#factory_reset

Hi,

Thanks guys, I rebooted into failsafe and tried to run "fastboot" but it threw an error. I then ran mount_root command and re-ran the "fastboot" and a "reboot -f".

I've reconfigured the WAN interface for Sky (DHCP auth settings) and then setup the and interfaces from the backup I took and its all working again.

Thanks for your assistance.

Martin

Just for the avoidance if doubt, it's "firstboot", not "fastboot".

Thanks slh, I managed to pick that up from another post I read where another poster used the wrong term.