Channel selection is ignored in STA mode?

I've got two wifi APs with same ssid and same password but different channels (1 and 11). I want my router to connect to an AP on channel 1, but no matter which one I choose, it always connects to channel 11. I found this old ticket:
Does it seriously work like that to this day?

Use option bssid to enforce connection only to a particular AP among several with the same SSID. bssid is the MAC of the AP. I think this one-entry whitelist is the only way to control which AP the STA connects to. There's no way to select by channel or blacklist MAC(s).

1 Like

But then if that AP goes down, my router won't roam to the other one.
Crappy Asus repeater 1 - OpenWRT 0 lol

I'm not sure what all the travelmate package does but it may do what you are looking for.


Looks like it does, thanks. Now I've got main AP with specified BSSID at the top of the list and then just SSID below.

Unfortunately Travelmate doesn't work well as a repeater. It forces NAT, DHCP server etc. I probably would have to use a script like it says in the ticket. Too bad. can't set different channels on the same radio.

And you're correct that STA channel would be ignored, the Master dictates that. They have to be the same, or you need 2 radios.

All radios work like that. Problem is solved by hard-setting the Master's channel (I know you're using 2.4, but when 5.4, make sure it's not a DFS channel).

I think you misunderstood. I have two access points already connected via cable - the one I'm trying to setup is number three.

1 Like

that is because your router number three will connect to the router with stongest signal. so your router on channel 11 is closer to router number three.
try switch the channels of router one and router two

1 Like