Changing the LAN IP results in Luci never done loading (solved)

Got this weird issue on my Fritzbox 4040. To reproduce simply do a clean install and after first boot login to the website interface or ssh and change the LAN IP from to some other range like, reboot and try to login.

You will be able to login but Luci will be forever loading the interface. If I change the IP back and reboot Luci loads again. A real head scratcher.

I've tried it several times with snapshots, trunk and the .2 release. They all exhibit the same behaviour. Really odd. Everything works perfectly fine except for changing the LAN IP.

Anyone else also having this issue?

Tried from scratch again today, restored my backup and now everything loads again :relaxed:

You can either:

  • ssh to the router and change router's ip by editing /etc/config/network and then run /etc/init.d/network reload
  • change your computer ip when the countdown starts to one of the new subnet, access router through luci and it should say that changes were applied successfully, otherwise change some other setting with the new ip and press save and apply

Huh? What are you replying to? Like I said I did that and the IP did change but Luci would never be done loading. The spinner just kept spinning. But it's sorted now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.