Changing MAC for Meraki MR16 WAP

When I first flashed my unit, I forgot to change the MAC. I've now added a second MR16 unit in my house and spotted that they are using the same (presumably default) MAC addresses. Both units are running OpenWrt 22.03.3 r20028-43d71ad93e. I've tried to follow the instructions here but there is no "mac" partition. I had a couple of questions:

  1. What method should I now be using to modify the MAC ?
  2. Do I only need to modify the MAC for the wired eth port ? I'm wondering if this is used to generate the MACs for the two wireless interfaces ?

Thanks in advance

you can override it in the webui, network -> interfaces -> devices tab -> configure ...

trial and error ?

Thanks for this. Using LuCI I changed the MAC addresses for all interfaces: For br-lan and eth0 I used the MAC printed on the back of the device. For wlan0 and wlan1 I made a slight change to their existing MACs. Both sets of changes display fine in network->interfaces->devices and for good luck I saved then rebooted. Curiously however on the main status/overview screen, wlan0&1 still retain their original MAC addresses. So I'm a bit perplexed !

might be a bug. but the override usually works.

did you check the MAC on OS level, or through the webUI ?

SSH shows the same as LuCI.
"ip addr show" lists the two wlan interfaces using their original/unchanged MACs despite the fact that /etc/config/network contains config device entries for wlan0 & wlan1 with different MACs which I assigned using LuCI earlier. It appears openwrt is continuing to use MAC info stored in a flash partition and ignoring my changes (for wlan0 & 1).

1 Like

Ok I'll try this. Before I do though, I can see that /etc/wireless already has config wifi-iface statements for radio0, default_radio0, radio1 & default_radio1. Can you suggest whether I should be adding the MAC to radio0 or default_radio0 ? As an aside, why are there multiple tags/names for the same interface - eg. wlan0, radio0 & default_radio0 ?
Thanks for your patience.

You edit the MAC on the SSID you wish to change.

I'm unsure of what you mean.

Thanks - that worked for both my radios. I added an option macaddr statement to the config wifi-iface for default_radio0 and default_radio1 in /etc/config/wireless & rebooted.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.