Changing default subnet breaks Samba NetBIOS over VPN

Long story short, if I keep the router IP address default (, Samba works, VPN works, and I can access my Samba share over VPN by calling the hostname (LEDE), or the IP (
If I move the router IP to another subnet ( for example), I can no longer access my Samba share over VPN by hostname (LEDE), but by IP it still works (
From my point of view, this seems to be a problem with Samba behaviour when changing the default subnet... Are there any more changes that need to be done when you want to assign another IP to your router, other than just changing "option ipaddr ''" in /etc/config/network?

Many routers with openwrt/LEDE I use have different subnets and samba works fine everywhere.
Problems is not with smbd. It must be some sort of name resolution failure.
Name can be resolved by netbios or DNS
I always disable netbios daemon nmbd in /etc/init.d/samba because its not needed. When I access samba by "net use \router\share" client adds dns suffix and resolves "router.lan", then uses IP address to access samba share.
Can you ping router.lan ?

How do you disable this?
Why is it not needed?

The only thing someone might need netbios is ability to browse network (list of computers near me).
Its not required to resolve names.
All DHCP clients and router itself can be accessed by "name.suffix". OS append suffix automatically.
net use \router.lan\share will work without netbios

To disable netbios comment this

#   procd_open_instance
#   procd_set_param command /usr/sbin/nmbd -F
#   procd_set_param respawn
#   procd_set_param file /var/etc/smb.conf
#   procd_close_instance

If I use WINS server from Samba, do you know if disabling nmbd will affect this? I think it might.