Change interface settings


I just bought a Netgear R6250 and flashed the latest LEDE firmware successfully. I just tried to change the IP of the default br-lan interface from to over luci, unfortunately that didn't work and I lost the connection to the router, so I had to flash it again over tftp. I tried this several times, I don't know what I am missing here!
My second question is: I would like to have a wlan sub net, a lan sub net and guest wlan sub net and mange them over dhcp, and assign each of them to a specific vlan on the switch. How realistic is my approach?
Thanks for your advice!


Changing "" to "" should be pretty straightforward... perhaps you should explain exactly what you did, step by step. Also, I do not see anything on your second question that cannot be done.

@eduperez. Thanks for the reply! Well I logged in and: Network -> Interfaces -> Edit on LAN interface, changed the IP in general setup, setup the netmask and the gateway. After clicking save and apply I lost the connection. Thats all. I am connected to the router with a cable, the router is not connected to any further devices

Hey there.

My guess would be: You still have a DHCP lease from
Default leasetime of LEDE should be 12h, so I'd expect it to take up to 6h until your computer even asks to renew this IP. Only after doesn't offer an extension for that IP address, another DHCP server providing a different IP address is considered at all.

Suggestion: Renew your IP address manually. That's ipconfig renew /all on windows.


I considered that also, so I setup a static IP on my Linux "", but I can't even ping the router when I change it's IP to "", funny wise I can still ping the "", but can't login neither over telnet nor web GUI.

This has to be some stupid thing somewhere else... I cannot point anything wrong in what you are doing.

Stale arp entries? Did you try to take the interface down and then bring it back up? I used ifdown/ifup or disconnect via the network manager. In the worst case, you can reboot.

I just did all of this yesterday, but I did not have zeros in the IP addresss (not that it should matter). I did have to disable the interface and bring it back up.

I could resolve the issue by setting the dhcp lease time down to 2 minutes removed all dhcp lease files from /var/lib/dhcp/. Thanks everybody.
Now I am struggling with the reboot option over luci, the router hangs and does not come up, so I had to flash it again..

1 Like