Chacha-mips.ko' is missing

Ubuntu 24.04

git clone --branch v23.05.3 --depth 1 git://git.openwrt.org/openwrt/openwrt.git ./openwrt
cd ./openwrt
./scripts/feeds update -a
./scripts/feeds install -a

echo 'src-git amnezia https://github.com/yury-sannikov/awg-openwrt' >> feeds.conf.default

make menuconfig
Target for Xiaomi 4A Gigabyte Edition (not v2)
and select:
<M> amneziawg-tools
<M> kmod-amneziawg
<M> luci-proto-amneziawg

make download

make -j $(($(nproc)+1))

Completed with an error, Restarted in 1 thread with errors displayed
make -j1 V=s

make[3]: Entering directory '/home/vech/openwrt/package/firmware/linux-firmware'
make[3]: Nothing to be done for 'compile'.
make[3]: Leaving directory '/home/vech/openwrt/package/firmware/linux-firmware'
time: package/firmware/linux-firmware/compile#0.34#0.14#0.42
make[3]: Entering directory '/home/vech/openwrt/package/kernel/gpio-button-hotplug'
mkdir -p /home/vech/openwrt/staging_dir/target-mipsel_24kc_musl/root-ramips/stamp
SHELL= flock /home/vech/openwrt/tmp/.root-copy.flock -c 'cp -fpR /home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/gpio-button-hotplug/.pkgdir/kmod-gpio-button-hotplug/. /home/vech/openwrt/staging_dir/target-mipsel_24kc_musl/root-ramips/'
touch /home/vech/openwrt/staging_dir/target-mipsel_24kc_musl/root-ramips/stamp/.kmod-gpio-button-hotplug_installed
echo "kmod-gpio-button-hotplug" >> /home/vech/openwrt/staging_dir/target-mipsel_24kc_musl/pkginfo/gpio-button-hotplug.default.install
make[3]: Leaving directory '/home/vech/openwrt/package/kernel/gpio-button-hotplug'
time: package/kernel/gpio-button-hotplug/compile#0.42#0.20#0.58
make[3]: Entering directory '/home/vech/openwrt/package/kernel/linux'
mkdir -p /home/vech/openwrt/staging_dir/target-mipsel_24kc_musl/root-ramips/stamp

SHELL= flock /home/vech/openwrt/tmp/.root-copy.flock -c 'cp -fpR /home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/packages/.pkgdir/kernel/. /home/vech/openwrt/staging_dir/target-mipsel_24kc_musl/root-ramips/'
touch /home/vech/openwrt/staging_dir/target-mipsel_24kc_musl/root-ramips/stamp/.kernel_installed
ERROR: module '/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/linux-5.15.150/arch/mips/crypto/chacha-mips.ko' is missing.
make[3]: *** [modules/crypto.mk:517: /home/vech/openwrt/bin/targets/ramips/mt7621/packages/kmod-crypto-lib-chacha20_5.15.150-1_mipsel_24kc.ipk] Error 1
make[3]: Leaving directory '/home/vech/openwrt/package/kernel/linux'
time: package/kernel/linux/compile#1.85#0.35#2.15
    ERROR: package/kernel/linux failed to build.
make[2]: *** [package/Makefile:129: package/kernel/linux/compile] Error 1
make[2]: Leaving directory '/home/vech/openwrt'
make[1]: *** [package/Makefile:123: /home/vech/openwrt/staging_dir/target-mipsel_24kc_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/vech/openwrt'
make: *** [/home/vech/openwrt/include/toplevel.mk:232: world] Error 2

What is missing, all additional packages are installed according to the instructions from the documentation

https://openwrt.org/docs/guide-developer/toolchain/use-buildsystem
https://openwrt.org/docs/guide-developer/toolchain/install-buildsystem

did you add/enable it in your build recipe ?

No, where can I turn it on?

$ cat .config |grep -i chacha
CONFIG_DROPBEAR_CHACHA20POLY1305=y
# CONFIG_PACKAGE_kmod-crypto-chacha20poly1305 is not set
CONFIG_PACKAGE_kmod-crypto-lib-chacha20=m
CONFIG_PACKAGE_kmod-crypto-lib-chacha20poly1305=m
CONFIG_WOLFSSL_HAS_CHACHA_POLY=y

make menuconfig

Enabled the module

$ cat .config |grep -i chacha
CONFIG_DROPBEAR_CHACHA20POLY1305=y
CONFIG_PACKAGE_kmod-crypto-chacha20poly1305=m
CONFIG_PACKAGE_kmod-crypto-lib-chacha20=m
CONFIG_PACKAGE_kmod-crypto-lib-chacha20poly1305=m
CONFIG_WOLFSSL_HAS_CHACHA_POLY=y

the error remains

=m enables the package to be built, it does not imply it being installed into the resulting image (you want =y for that).

1 Like

I need them as modules

Then you know which package to install.