Ch340g adapter: strange characters

This looks more like a baud rate mismatch up until Linux takes over and reinitializes the serial port with the correct baud rate settings.

Can you press "Enter" once booted and end up in an OpenWrt-like firmware? Can you press "f" and "Enter" when the message appears to enter failsafe mode? In both cases, you might be able to just scp a sysupgrade image and flash it if the vendor didn't modify too much.

Apart from that: Why are you flashing using UART anyway and not using TFTP recovery?

I haven't managed to press enter or f effectively: I mean, I press them, but it doesn't seem to get recognized: at least for sure with minicom. With cu, I haven't been able to get so far again. With "screen", the terminal just blacks out.

So do you mean if I press enter effectively, am I inside ssh of Hotsplots firmware over the serial adapter ? Can I use SCP over the serial adapter? Or do you mean, once the router is set in a certain mode over the serial adapter, I have to use a regular ethernet cable and do normal things like setting static IP to connect?

I've tried once flashing OpenWRT firmware over Hotsplots' (I got their UAP), so I know it should work, if I at least get into the admin area of Hotsplots.

I wanted to use TFTP, of course, but the router refused to be in TFTP mode by pressing button etc. I tried with wireshark, I don't say I'm experienced in using it, but I think I figured out that my laptop was innocent, it's just the router. So I gave it up.

According to the Wiki, minicom doesn't work properly. I call screen like this: screen /dev/ttyUSB0 115200 and it's nowadays my preferred terminal client. In order to rule out the Mac, can you try another operating system? A small Linux in a virtual machine where you attach the USB-converter should work just fine.

Not SSH, over Serial. But yes, you should get a root prompt, that's what you get with OpenWrt by default. You can transfer data, but it's not very straight forward. You're better off with nc or scp once you have access.

According to the Wiki, you need to keep RESET pushed while plugging in power. You should see that reported on the UART console if you keep it attached.

Thank you for your reply!

I managed to get through beyond jumbled letters with 3 more things in addition to minicom: now cu, screen (direct on Mac Mojave) and, on Win8.1 inside Virtualbox, putty. And I didn't manage to press F or Enter or type tpl in any of them!!

I wonder where the problem is. Can a cheap/bad adapter cause this kind of problem, or, since the adapter is running, is it innocent? Is it the router that's bad? I can still try connecting with Raspi 4B, I can also borrow a win 8.1 laptop, but it takes already a lot of time to get to the point where I see something happening at all (turning on and off 30 times), I'm inclined to get more input before trying with these two things.

As for tftp, I know that

and I tried to see what happened if I do it while I'm on UART. Nothing happened;; This method seems to be not working for v2.1: all the success stories specific to v2.1 I saw use UART, so I guess something is wrong with normal tftp mode through pressing the reset.

I might try pressing WPS button instead:)

I haven't tried removing 3 LED's, as @Annick suggested above. I don't know how to do it.... that might improve low voltage?

p.s. as for

I tried with wrong baudrate to see how it looks like. It also comes out with jumbled letters, but a bit different, and slowly with little by little. I think my baudrate 115200 is right.

for the 3 leds I broke them or with a small screwdriver or with a small cutting pliers

May I ask you how you came up with this idea? What was your problem, and why breaking of LEDs was supposed to help with it?

A friend in post for Zyxel Multi M1 has a problem with a CP201X

As i had about ten of these adapters with CP201X i looked why block the start

The leds ( gadgets ) with their low value 330R resistors interfere with the RX/TX lines

Thanks a lot for your reply!

That sounds like relevant to my problem. I will give it a try. Yesterday I was trying to connect it over Raspberry pi, and then I realized that when I pull Tx wire and put it back, it suddenly starts going. So far no success in typing in f or Enter or anything, though. May be it's because Tx is blocked....
I also noticed that the voltage is quite different when I'm using USB port on my laptop, or raspberry pi. Raspberry pi seems to give more voltage: even when it's set for 3.3V, it goes almost 4V, and when I set it for 5V, it does reach 5V and a bit beyond. On my laptop, it hits barely 4V, even if I set it for 5V.

Just tried with smashing LEDs. Amazing: It doesn't stop at jumbled letters anymore, I don't have to turn on and off 30 times anymore, it flows ! Thank you, @Annick ! It saves me a lot of time.
However, no message "Autobooting..." shows up, and I still cannot type F or Enter either....

Should I borrow a Win 8.1 laptop, or better try another adapter?

1 Like

I use Putty with Wondiws 11

Just borrowed win 8.1 laptop and tried: the same thing, I can't type;;

Can you post the full log?

Some infos for debrick

type TPL and press ENTER, very fast!!!
We have one second to do this, it will interrupt the boot process.

@d687r02j8g I think it's like this every time, independent of whatever I use (cu, screen, putty, Raspi, etc)

Yes but now you've taken the LEDs out, it isn't jumbled anymore right?

When you connect TX to RX have you a normal functionnality ?

@d687r02j8g it is still jumbled at first. The difference after taking out LEDs is, it doesn't stop anymore, it always goes through pass the jumbled part. I tried to just type tpl+enter repeatedly upon turning the router on, but it doesn't seem to make any difference. I also tried different ways of producing "Enter" (fn-return, shift-return).
I found that Tx of the adapter got about 4V, it's high..... could a board fry just enough that Rx won't work?

I had no problem with these adapters except blocking at startup with the LEDs
I would be surprised if the RX input is destroyed
for the story of the 4 volts it's weird here without connecting anything I have about 3.3 volts on TX RX
with you well echo keyboard characters by connecting RX & TX

I'm not sure if I understood this: are you saying that I connect GRD to the GRD of the router, but connect RX and TX of the adapter together, and run cu or whatever, and type something, it should come back (i.e. will be typed on the screen), if TX and RX of the adapter are functional? And if that's the case, RX of the board is possibly dead, and otherwise, the adapter is bad?