CF-EW72-v2 issue using tagged uplink in dump ap mode

I like to use a comfast outdoor EW-72-v2 connected over the 'wan' port as uplink.
When using the untagged default wan interface everything is working, but using instead a tagged vlan I don't see any packets outgoing on that interface to the dhcp server.

ubus call system board
{
	"kernel": "5.15.162",
	"hostname": "OpenWrt",
	"system": "MediaTek MT7621 ver:1 eco:4",
	"model": "COMFAST CF-EW72 V2",
	"board_name": "comfast,cf-ew72-v2",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.4",
		"revision": "r24012-d8dd03c46f",
		"target": "ramips/mt7621",
		"description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
	}
}

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd85:ea3f:728a::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'br-wan'
	option proto 'dhcp'

config device
	option type 'bridge'
	option name 'br-wan'
	option bridge_empty '1'
	option ipv6 '0'
	list ports 'wan'

config interface 'USER'
	option proto 'none'
	option device 'br-user'

config device
	option type 'bridge'
	option name 'br-user'
	option ipv6 '0'
	list ports 'wan.2'
	option bridge_empty '1'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2g'
	option channel '1'
	option htmode 'HT20'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option band '5g'
	option channel '36'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid '<my-ssid>'
	option encryption 'psk2+ccmp'
	option key '<my-pwd>'
	option network 'USER'

Try using bridge vlan filtering:

config device
        option type 'bridge'
        option name 'br-wan'
        list ports 'wan'
	
config bridge-vlan
        option device 'br-wan'
        option vlan '10'
        list ports 'wan'
        
config bridge-vlan
        option device 'br-wan'
        option vlan '2'
        list ports 'wan:t'

config interface 'wan'
        option device 'br-wan.10'
        option proto 'dhcp'

config interface 'USER'
        option proto 'none'
        option device 'br-wan.2'

Note that some devices do not support more than one bridge. If this is the case, you will need to add the lan port to br-wan or the wan port to br-lan and adapt the config.

it works now :slight_smile:
Thanks for your help.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.