Cf-e314n - flashing openwrt / lede

just wanted to share my experience with cf-e314n v2.

grabbed it for $50 on ebay and had no expectations of running openwrt / lede on it but after a bit of googling, found a patch and thought i'll give it a try.

I setup on azure a ubuntu 16 instance and did the following (combining afew howtos below)

sudo apt-get install subversion g++ zlib1g-dev build-essential git python rsync man-db
sudo apt-get install libncurses5-dev gawk gettext unzip file libssl-dev wget zip

git clone -b v17.01.4 https://git.lede-project.org/source.git lede
cd lede

wget https://patchwork.ozlabs.org/patch/884850/raw/ -O cf314n.patch
patch -p1 < cf314n.patch

./scripts/feeds update -a
./scripts/feeds install -a

make menuconfig

  • select cf-e314n as target profile
  • select the luci ->collections->luci
    exit (saving when prompted)

make

takes about an hour on my f1 instance

the flash file was accepted through the stock firmwares web interface
After flashing, i couldnt login until i performed a reset (hold down that hidden reset button)

for those who just want the flash file.... (and trust that its safe....)

http://bit.ly/cfe314n

I put together a more recent version v18.06.2 https://1drv.ms/f/s!Arx4N_3ospCtnGbtZ1mQVlwDFeTb


There is a firmware from Comfast cf-e355nv2, works perfectly on cf-e314nv2. New assembly. Firmware

Dear colleague, dont you remember if any password for root has been installed by you?
?
I ve just had uploaded your latest firmware to my cf-e314n and stopped due to unable to log in(((

Kindly ask for help

Dear all, I had reset my router after flashing and everything becomes perfect! Thanks!

Hi i dont get it how to start this method, i have a problem with my cf e314n v2 i flash a.bin file that i downloaeded openwrt thru the default gui of comfast, in the upgrade tab i browse the file that i downloaded and press confirm after that no wifi light the four light signal indicator has only 1 green light the strongest signal, now i cannot access 192.168.10.1 i dont have any idea how to flash it again to stock firmware please help :sob: