Can't upgrade to 18.06

Hey Guys,

I'm new to OpenWrt so its possible that I ask some stupid questions. (sorry for that)

I'm using a Medion MD 86517 with LEDE 17.01 installed. I follow the HowTo on this site:

unfortunately I copied the last statement, so I'm on 17.01 despite 18.06 is available for my device. I later tried to upgrade through the Webinterface but by clicking the Flash Image Button it is telling me this:

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

I tried the .bin and the .tar from the Link above. I also tried to upgrade through SSH Terminal with this file. But after the restart I'm still on 17.01. What am I doing wrong?

The device page states that web sysupgrade does not work... the bin and tar file from the link above are 17.x...

Show the commands you used when trying to flash "this" file...

( use code tags </> )

First of all thanks for you help.

Do you mean:


are 17.x ? So why then the naming scheme with 18.x ?

The commands were

cd /tmp
sysupgrade -n -F openwrt-18.06.4-oxnas-ox820-mitrastar-stg212-squashfs-ubinized.bin

No those ones are 18... the ( device page ) sample commands show 17...

If it were my router/device... i'd try the sysupgrade.tar with the commands you show... maybe without the -F to begin with... ... but... there is an element of risk to that...

i believe the ubinize.bin is equivalent to a "factory" ( new install ) but thats just a guess..

Ok, I just realized that after every restart the settings were reset to factory defaults. It also gets a new MAC address. So I think I have to solve this Problem first.

Ok after a couple of reflashs the settings save now. But I still cant upgrade. Is there maybe a nandwrite command included in LEDE? Maybe I have to write the bin file to the NAND manually.

Hi thisismenow,

any news? I ran into the same problem.

Git the same ... cant update my STG-212 ... hangs in the version I installed first 17.01 :frowning:

Nobody here got the same problem with the OXNAS files ?